mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-01-27 23:44:04 +00:00
extra/chromium to 52.0.2743.82-1
This commit is contained in:
parent
4c68264895
commit
77fa32c980
4 changed files with 19 additions and 62 deletions
|
@ -1,4 +1,4 @@
|
|||
From 3e466a13cbd0fbc4db71d9ad9b60e3d6cf6a94c7 Mon Sep 17 00:00:00 2001
|
||||
From 8d174a47fce05738c247d1e7f5247b6e26461492 Mon Sep 17 00:00:00 2001
|
||||
From: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
Date: Sun, 6 Mar 2016 20:26:53 -0700
|
||||
Subject: [PATCH 1/2] system ffmpeg fixes
|
||||
|
@ -9,7 +9,7 @@ Subject: [PATCH 1/2] system ffmpeg fixes
|
|||
2 files changed, 23 deletions(-)
|
||||
|
||||
diff --git a/media/ffmpeg/ffmpeg_common.h b/media/ffmpeg/ffmpeg_common.h
|
||||
index d5ad132..04140e2 100644
|
||||
index fa5dfee..db045f3 100644
|
||||
--- a/media/ffmpeg/ffmpeg_common.h
|
||||
+++ b/media/ffmpeg/ffmpeg_common.h
|
||||
@@ -22,10 +22,6 @@
|
||||
|
@ -32,10 +32,10 @@ index d5ad132..04140e2 100644
|
|||
#include <libavutil/avutil.h>
|
||||
#include <libavutil/imgutils.h>
|
||||
diff --git a/media/filters/ffmpeg_demuxer.cc b/media/filters/ffmpeg_demuxer.cc
|
||||
index c7e00ce..fe3a39d 100644
|
||||
index 2785c0a..40de4b1 100644
|
||||
--- a/media/filters/ffmpeg_demuxer.cc
|
||||
+++ b/media/filters/ffmpeg_demuxer.cc
|
||||
@@ -1092,24 +1092,6 @@ void FFmpegDemuxer::OnFindStreamInfoDone(const PipelineStatusCB& status_cb,
|
||||
@@ -1101,24 +1101,6 @@ void FFmpegDemuxer::OnFindStreamInfoDone(const PipelineStatusCB& status_cb,
|
||||
// If no estimate is found, the stream entry will be kInfiniteDuration().
|
||||
std::vector<base::TimeDelta> start_time_estimates(format_context->nb_streams,
|
||||
kInfiniteDuration());
|
||||
|
@ -58,8 +58,8 @@ index c7e00ce..fe3a39d 100644
|
|||
- }
|
||||
- }
|
||||
|
||||
scoped_ptr<MediaTracks> media_tracks(new MediaTracks());
|
||||
std::unique_ptr<MediaTracks> media_tracks(new MediaTracks());
|
||||
AVStream* audio_stream = NULL;
|
||||
--
|
||||
2.7.2
|
||||
2.9.0
|
||||
|
||||
|
|
|
@ -1,4 +1,4 @@
|
|||
From 25d42d8e806a4a38fe5e3fec7d52a896f7b7de42 Mon Sep 17 00:00:00 2001
|
||||
From fd390d689c538c2d315430fecde8e65863984b2d Mon Sep 17 00:00:00 2001
|
||||
From: "riku.voipio" <riku.voipio@linaro.org>
|
||||
Date: Tue, 1 Mar 2016 08:02:43 -0800
|
||||
Subject: [PATCH 2/2] Linux Sandbox: whitelist arm64 syscalls
|
||||
|
@ -17,14 +17,14 @@ Review URL: https://codereview.chromium.org/1613883002
|
|||
|
||||
Cr-Commit-Position: refs/heads/master@{#378440}
|
||||
---
|
||||
mojo/shell/runner/host/linux_sandbox.cc | 2 ++
|
||||
services/shell/runner/host/linux_sandbox.cc | 2 ++
|
||||
1 file changed, 2 insertions(+)
|
||||
|
||||
diff --git a/mojo/shell/runner/host/linux_sandbox.cc b/mojo/shell/runner/host/linux_sandbox.cc
|
||||
index 9e9dbc7..0d9082c 100644
|
||||
--- a/mojo/shell/runner/host/linux_sandbox.cc
|
||||
+++ b/mojo/shell/runner/host/linux_sandbox.cc
|
||||
@@ -39,12 +39,14 @@ intptr_t SandboxSIGSYSHandler(const struct sandbox::arch_seccomp_data& args,
|
||||
diff --git a/services/shell/runner/host/linux_sandbox.cc b/services/shell/runner/host/linux_sandbox.cc
|
||||
index 24461a5..33822bd 100644
|
||||
--- a/services/shell/runner/host/linux_sandbox.cc
|
||||
+++ b/services/shell/runner/host/linux_sandbox.cc
|
||||
@@ -38,12 +38,14 @@ intptr_t SandboxSIGSYSHandler(const struct sandbox::arch_seccomp_data& args,
|
||||
const sandbox::syscall_broker::BrokerProcess* broker_process =
|
||||
static_cast<const sandbox::syscall_broker::BrokerProcess*>(aux);
|
||||
switch (args.nr) {
|
||||
|
@ -40,5 +40,5 @@ index 9e9dbc7..0d9082c 100644
|
|||
if (static_cast<int>(args.args[0]) == AT_FDCWD) {
|
||||
return broker_process->Access(
|
||||
--
|
||||
2.7.2
|
||||
2.9.0
|
||||
|
||||
|
|
|
@ -19,7 +19,7 @@ buildarch=12
|
|||
highmem=1
|
||||
|
||||
pkgname=chromium
|
||||
pkgver=51.0.2704.106
|
||||
pkgver=52.0.2743.82
|
||||
pkgrel=1
|
||||
_launcher_ver=3
|
||||
pkgdesc="The open-source project behind Google Chrome, an attempt at creating a safer, faster, and more stable browser"
|
||||
|
@ -45,13 +45,13 @@ source=(https://commondatastorage.googleapis.com/chromium-browser-official/$pkgn
|
|||
PNGImageDecoder.patch
|
||||
0001-system-ffmpeg-fixes.patch
|
||||
0002-Linux-Sandbox-whitelist-arm64-syscalls.patch)
|
||||
sha256sums=('fb97a6a3119ec2c8cc4ad9a0bd6c4d306516769039a2633633f7d0c770012cfd'
|
||||
sha256sums=('a7de6015df9cf685d68efd1e070ae9c706c723cd9395d079a7d43672a2c37eb4'
|
||||
'8b01fb4efe58146279858a754d90b49e5a38c9a0b36a1f84cbb7d12f92b84c28'
|
||||
'028a748a5c275de9b8f776f97909f999a8583a4b77fd1cd600b4fc5c0c3e91e9'
|
||||
'4660344789c45c9b9e52cb6d86f7cb6edb297b39320d04f6947e5216d6e5f64c'
|
||||
'd6fdcb922e5a7fbe15759d39ccc8ea4225821c44d98054ce0f23f9d1f00c9808'
|
||||
'd9fd982ba6d50edb7743db6122b975ad1d3da5a9ad907c8ab7cf574395b186cd'
|
||||
'81f9859f29d40ebea54c6031296bc4e809ac6694ddbb81c0313f57c7e913f194'
|
||||
'f3779695ef808e5f8d122ecda98418cc0f4b5d0a6f064237b856dc1be71428fa')
|
||||
'2c9f39c04397898711ba9d5e008cf11e909d479e9af0627d4534206051cc77ef'
|
||||
'b2d301f48f603bd7b9ae5802aa9211a6a7991ea94e0e725b4c4272bdfd6c35db')
|
||||
|
||||
# Google API keys (see http://www.chromium.org/developers/how-tos/api-keys)
|
||||
# Note: These are for Arch Linux use ONLY. For your own distribution, please
|
||||
|
|
|
@ -1,46 +1,3 @@
|
|||
diff -upr chromium-48.0.2564.82.orig/chrome/common/chrome_content_client.cc chromium-48.0.2564.82/chrome/common/chrome_content_client.cc
|
||||
--- chromium-48.0.2564.82.orig/chrome/common/chrome_content_client.cc 2016-01-20 22:01:20.000000000 +0200
|
||||
+++ chromium-48.0.2564.82/chrome/common/chrome_content_client.cc 2016-01-21 20:02:02.788936626 +0200
|
||||
@@ -158,7 +158,12 @@ void ComputeBuiltInPlugins(std::vector<c
|
||||
#if defined(WIDEVINE_CDM_AVAILABLE) && defined(ENABLE_PEPPER_CDMS) && \
|
||||
!defined(WIDEVINE_CDM_IS_COMPONENT)
|
||||
static bool skip_widevine_cdm_file_check = false;
|
||||
- if (PathService::Get(chrome::FILE_WIDEVINE_CDM_ADAPTER, &path)) {
|
||||
+ bool widevine_cdm_present =
|
||||
+ skip_widevine_cdm_file_check ||
|
||||
+ (PathService::Get(chrome::FILE_WIDEVINE_CDM, &path) &&
|
||||
+ base::PathExists(path));
|
||||
+ if (widevine_cdm_present &&
|
||||
+ PathService::Get(chrome::FILE_WIDEVINE_CDM_ADAPTER, &path)) {
|
||||
if (skip_widevine_cdm_file_check || base::PathExists(path)) {
|
||||
content::PepperPluginInfo widevine_cdm;
|
||||
widevine_cdm.is_out_of_process = true;
|
||||
diff -upr chromium-48.0.2564.82.orig/chrome/common/chrome_paths.cc chromium-48.0.2564.82/chrome/common/chrome_paths.cc
|
||||
--- chromium-48.0.2564.82.orig/chrome/common/chrome_paths.cc 2016-01-20 22:01:20.000000000 +0200
|
||||
+++ chromium-48.0.2564.82/chrome/common/chrome_paths.cc 2016-01-21 19:18:51.287978456 +0200
|
||||
@@ -375,6 +375,11 @@ bool PathProvider(int key, base::FilePat
|
||||
return false;
|
||||
cur = cur.AppendASCII(kWidevineCdmAdapterFileName);
|
||||
break;
|
||||
+ case chrome::FILE_WIDEVINE_CDM:
|
||||
+ if (!GetInternalPluginsDirectory(&cur))
|
||||
+ return false;
|
||||
+ cur = cur.AppendASCII(kWidevineCdmFileName);
|
||||
+ break;
|
||||
#endif // defined(WIDEVINE_CDM_AVAILABLE) && defined(ENABLE_PEPPER_CDMS)
|
||||
case chrome::FILE_RESOURCES_PACK:
|
||||
#if defined(OS_MACOSX) && !defined(OS_IOS)
|
||||
diff -upr chromium-48.0.2564.82.orig/chrome/common/chrome_paths.h chromium-48.0.2564.82/chrome/common/chrome_paths.h
|
||||
--- chromium-48.0.2564.82.orig/chrome/common/chrome_paths.h 2016-01-14 03:49:22.000000000 +0200
|
||||
+++ chromium-48.0.2564.82/chrome/common/chrome_paths.h 2016-01-21 19:18:51.287978456 +0200
|
||||
@@ -99,6 +99,7 @@ enum {
|
||||
DIR_COMPONENT_WIDEVINE_CDM, // Directory that contains component-updated
|
||||
// Widevine CDM files.
|
||||
FILE_WIDEVINE_CDM_ADAPTER, // Full path to the Widevine CDM adapter file.
|
||||
+ FILE_WIDEVINE_CDM, // Full path to the Widevine CDM file.
|
||||
FILE_RESOURCES_PACK, // Full path to the .pak file containing
|
||||
// binary data (e.g., html files and images
|
||||
// used by internal pages).
|
||||
diff -upr chromium-48.0.2564.82.orig/third_party/widevine/cdm/stub/widevine_cdm_version.h chromium-48.0.2564.82/third_party/widevine/cdm/stub/widevine_cdm_version.h
|
||||
--- chromium-48.0.2564.82.orig/third_party/widevine/cdm/stub/widevine_cdm_version.h 2016-01-14 01:05:17.000000000 +0200
|
||||
+++ chromium-48.0.2564.82/third_party/widevine/cdm/stub/widevine_cdm_version.h 2016-01-21 19:18:51.287978456 +0200
|
||||
|
|
Loading…
Reference in a new issue