core/file to 5.40-2

This commit is contained in:
Kevin Mihelich 2021-04-12 23:36:57 +00:00
parent e6adfc77cd
commit 78258887a3
3 changed files with 36 additions and 31 deletions

View file

@ -0,0 +1,31 @@
From b258a4e460569678cd554236cb75027897a42858 Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?S=C3=A9bastien=20Luttringer?= <seblu@seblu.net>
Date: Mon, 12 Apr 2021 18:15:33 +0200
Subject: [PATCH] Revert "Add checksum for XZ"
This reverts commit 3ebd747de661b244f1acec29495d676dd52e71d5.
---
magic/Magdir/compress | 9 ++-------
1 file changed, 2 insertions(+), 7 deletions(-)
diff --git a/magic/Magdir/compress b/magic/Magdir/compress
index 64d11a73..a364a880 100644
--- a/magic/Magdir/compress
+++ b/magic/Magdir/compress
@@ -264,12 +264,7 @@
>>5 lequad !0xffffffffffffffff non-streamed, size %lld
# http://tukaani.org/xz/xz-file-format.txt
-0 ustring \xFD7zXZ\x00 XZ compressed data, checksum
->7 byte&0xf 0x0 NONE
->7 byte&0xf 0x1 CRC32
->7 byte&0xf 0x4 CRC64
->7 byte&0xf 0xa SHA-256
-
+0 ustring \xFD7zXZ\x00 XZ compressed data
!:strength * 2
!:mime application/x-xz
--
2.31.1

View file

@ -8,7 +8,7 @@
pkgname=file
pkgver=5.40
pkgrel=1
pkgrel=2
pkgdesc='File type identification utility'
arch=('x86_64')
license=('custom')
@ -16,10 +16,12 @@ groups=('base-devel')
url='https://www.darwinsys.com/file/'
depends=('glibc' 'zlib' 'xz' 'bzip2')
provides=('libmagic.so')
source=("https://astron.com/pub/$pkgname/$pkgname-$pkgver.tar.gz"{,.asc})
source=("https://astron.com/pub/$pkgname/$pkgname-$pkgver.tar.gz"{,.asc}
'0001-Revert-Add-checksum-for-XZ.patch')
validpgpkeys=('BE04995BA8F90ED0C0C176C471112AB16CB33B3A') # Christos Zoulas
sha256sums=('167321f43c148a553f68a0ea7f579821ef3b11c27b8cbe158e4df897e4a5dd57'
'SKIP')
'SKIP'
'bd3633ffb41e4a8f9831bcda6e8e4589f67647ec33240d68d5a53bac4a82b594')
prepare() {
cd $pkgname-$pkgver

View file

@ -1,28 +0,0 @@
From 78573ec1c43346064661169c5c8df32e7c3bd6d6 Mon Sep 17 00:00:00 2001
From: Christos Zoulas <christos@zoulas.com>
Date: Fri, 17 Jan 2020 17:12:58 +0000
Subject: [PATCH] PR/130: tobias: adjust seccomp for ioctl on hardwired
terminal
---
src/seccomp.c | 8 ++++++--
1 file changed, 6 insertions(+), 2 deletions(-)
diff --git a/src/seccomp.c b/src/seccomp.c
index ebf3ea1cb..0ba17233b 100644
--- a/src/seccomp.c
+++ b/src/seccomp.c
@@ -186,8 +186,12 @@ enable_sandbox_full(void)
ALLOW_IOCTL_RULE(FIONREAD);
#endif
#ifdef TIOCGWINSZ
- // musl libc may call ioctl TIOCGWINSZ when calling stdout
+ // musl libc may call ioctl TIOCGWINSZ on stdout
ALLOW_IOCTL_RULE(TIOCGWINSZ);
+#endif
+#ifdef TCGETS
+ // glibc may call ioctl TCGETS on stdout on physical terminal
+ ALLOW_IOCTL_RULE(TCGETS);
#endif
ALLOW_RULE(lseek);
ALLOW_RULE(_llseek);