mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-03-09 00:17:31 +00:00
kodi-rbp4-git: update/rename for 19.0a1.55516-1
This commit is contained in:
parent
a6ef42364c
commit
78301c367e
9 changed files with 401 additions and 0 deletions
34
alarm/kodi-rbp4-git/000-python3.8.patch
Normal file
34
alarm/kodi-rbp4-git/000-python3.8.patch
Normal file
|
@ -0,0 +1,34 @@
|
|||
Upstream bug report, https://github.com/xbmc/xbmc/issues/16560
|
||||
Patch by asavah, https://forum.kodi.tv/showthread.php?tid=349548
|
||||
|
||||
diff --git a/CMakeLists.txt b/CMakeLists.txt
|
||||
index 2fb6bf5bed..52be5b649d 100644
|
||||
--- a/CMakeLists.txt
|
||||
+++ b/CMakeLists.txt
|
||||
@@ -163,7 +163,7 @@ find_package(JsonSchemaBuilder REQUIRED)
|
||||
core_optional_dep(${optional_deps})
|
||||
core_require_dep(${required_deps})
|
||||
|
||||
-SET(PYTHON_VERSION 3.7)
|
||||
+SET(PYTHON_VERSION 3.8)
|
||||
|
||||
if(ENABLE_MARIADBCLIENT AND NOT ENABLE_MARIADBCLIENT STREQUAL AUTO AND ENABLE_MYSQLCLIENT AND NOT ENABLE_MYSQLCLIENT STREQUAL AUTO)
|
||||
MESSAGE(FATAL_ERROR "You can not use MySql and MariaDB at the same time. Disable one by adding -DENABLE_MYSQLCLIENT=OFF or -DENABLE_MARIADBCLIENT=OFF.")
|
||||
diff --git a/xbmc/interfaces/python/PythonInvoker.cpp b/xbmc/interfaces/python/PythonInvoker.cpp
|
||||
index 4342e05dcd..660e82c254 100644
|
||||
--- a/xbmc/interfaces/python/PythonInvoker.cpp
|
||||
+++ b/xbmc/interfaces/python/PythonInvoker.cpp
|
||||
@@ -8,6 +8,14 @@
|
||||
|
||||
// python.h should always be included first before any other includes
|
||||
#include <Python.h>
|
||||
+#if PY_VERSION_HEX >= 0x03080000
|
||||
+# define Py_BUILD_CORE
|
||||
+# undef HAVE_STD_ATOMIC
|
||||
+/* for access to the fields of PyInterpreterState */
|
||||
+# include "internal/pycore_pystate.h"
|
||||
+# undef Py_BUILD_CORE
|
||||
+# define HAVE_STD_ATOMIC
|
||||
+#endif
|
||||
#include <iterator>
|
||||
#include <osdefs.h>
|
5
alarm/kodi-rbp4-git/99-kodi.rules
Normal file
5
alarm/kodi-rbp4-git/99-kodi.rules
Normal file
|
@ -0,0 +1,5 @@
|
|||
SUBSYSTEM=="vc-sm",GROUP="video",MODE="0660"
|
||||
SUBSYSTEM=="vchiq",GROUP="video",MODE="0660"
|
||||
SUBSYSTEM=="tty", KERNEL=="tty[0-9]*", GROUP="tty", MODE="0660"
|
||||
SUBSYSTEM=="dma_heap", KERNEL=="linux*", GROUP="video", MODE="0660"
|
||||
SUBSYSTEM=="dma_heap", KERNEL=="system", GROUP="video", MODE="0660"
|
288
alarm/kodi-rbp4-git/PKGBUILD
Normal file
288
alarm/kodi-rbp4-git/PKGBUILD
Normal file
|
@ -0,0 +1,288 @@
|
|||
# Contributor graysky <graysky AT archlinux DOT org>
|
||||
# Contributor Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
# Contributor BlackIkeEagle < ike DOT devolder AT gmail DOT com >
|
||||
# Contributor Oleg Rakhmanov <oleg [at] archlinuxarm [dot] com>
|
||||
# Contributor tomasgroth at yahoo.dk
|
||||
# Contributor WarheadsSE <max@warheads.net>
|
||||
# Contributor Adrian Fedoreanu <adrian [dot] fedoreanu [at] gmail [dot] com>
|
||||
|
||||
buildarch=4
|
||||
|
||||
_prefix=/usr
|
||||
|
||||
pkgbase=kodi-rbp4-git
|
||||
_suffix=rbp4-git
|
||||
pkgname=("kodi-$_suffix" "kodi-eventclients-$_suffix" "kodi-tools-texturepacker-$_suffix" "kodi-dev-$_suffix")
|
||||
|
||||
# which source to pull
|
||||
# xbmc is vanilla upstream which currently lacks HEVC decoding in ffmpeg
|
||||
# here as popcornmix has this code which is under review by ffmpeg for
|
||||
# inclusion in some form
|
||||
_source=popcornmix
|
||||
#_source=xbmc
|
||||
|
||||
# vanilla kodi 19.0a1-Matrix
|
||||
#_commitnumber=55510
|
||||
#_commithash=db40b2ade4b6e13d6fead7004e819325e2ea0f0b
|
||||
|
||||
# popcornmix's gbm branch
|
||||
_commitnumber=55516
|
||||
_commithash=4ddad477766edf540f7f020b030fac3b5ac1f1e2
|
||||
|
||||
pkgver="19.0a1.$_commitnumber"
|
||||
pkgrel=1
|
||||
arch=('armv7h')
|
||||
url="http://kodi.tv"
|
||||
license=('GPL2')
|
||||
makedepends=(
|
||||
'afpfs-ng' 'bluez-libs' 'cmake' 'curl' 'dav1d' 'doxygen' 'glew'
|
||||
'gperf' 'hicolor-icon-theme' 'java-runtime' 'libaacs' 'libass'
|
||||
'libbluray' 'libcdio' 'libcec-rpi' 'libgl' 'mariadb-libs' 'libmicrohttpd'
|
||||
'libmodplug' 'libmpeg2' 'libnfs' 'libplist' 'libpulse' 'libva'
|
||||
'libvdpau' 'libxrandr' 'libxslt' 'lirc' 'lzo' 'mesa' 'nasm'
|
||||
'python-pycryptodomex' 'python-pillow6' 'python-pybluez' 'python-simplejson'
|
||||
'shairplay' 'smbclient' 'taglib' 'tinyxml' 'swig'
|
||||
'upower' 'giflib' 'rapidjson' 'ghostscript' 'git' 'meson' 'gtest'
|
||||
'libinput' 'libxkbcommon' 'linux-raspberrypi4-headers'
|
||||
)
|
||||
_codename=Leia
|
||||
# Found on their respective github release pages. One can check them against
|
||||
# what is pulled down when not specifying them in the cmake step.
|
||||
# $CHROOT/build/kodi-git/src/kodi-build/build/download
|
||||
#
|
||||
# https://github.com/xbmc/FFmpeg/tags
|
||||
# https://github.com/xbmc/libdvdcss/tags
|
||||
# https://github.com/xbmc/libdvdnav/tags
|
||||
# https://github.com/xbmc/libdvdread/tags
|
||||
#
|
||||
# fmt and crossguid can be found http://mirrors.kodi.tv/build-deps/sources/
|
||||
#
|
||||
_libdvdcss_version="1.4.2-$_codename-Beta-5"
|
||||
_libdvdnav_version="6.0.0-$_codename-Alpha-3"
|
||||
_libdvdread_version="6.0.0-$_codename-Alpha-3"
|
||||
#_ffmpeg_version="4.3.1-Matrix-Alpha1-1"
|
||||
_ffmpeg_version="4.3-Matrix-Alpha1"
|
||||
_fmt_version="6.1.2"
|
||||
_crossguid_version="8f399e8bd4"
|
||||
_fstrcmp_version="0.7.D001"
|
||||
_flatbuffers_version="1.11.0"
|
||||
_spdlog_version="1.5.0"
|
||||
source=(
|
||||
"xbmc-$pkgver.tar.gz::https://github.com/$_source/xbmc/archive/$_commithash.tar.gz"
|
||||
kodi.service
|
||||
99-kodi.rules
|
||||
polkit.rules
|
||||
kodi-gbm.config.txt
|
||||
"libdvdcss-$_libdvdcss_version.tar.gz::https://github.com/xbmc/libdvdcss/archive/$_libdvdcss_version.tar.gz"
|
||||
"libdvdnav-$_libdvdnav_version.tar.gz::https://github.com/xbmc/libdvdnav/archive/$_libdvdnav_version.tar.gz"
|
||||
"libdvdread-$_libdvdread_version.tar.gz::https://github.com/xbmc/libdvdread/archive/$_libdvdread_version.tar.gz"
|
||||
"ffmpeg-$_ffmpeg_version.tar.gz::https://github.com/xbmc/FFmpeg/archive/$_ffmpeg_version.tar.gz"
|
||||
"http://mirrors.kodi.tv/build-deps/sources/fmt-$_fmt_version.tar.gz"
|
||||
"http://mirrors.kodi.tv/build-deps/sources/crossguid-$_crossguid_version.tar.gz"
|
||||
"http://mirrors.kodi.tv/build-deps/sources/fstrcmp-$_fstrcmp_version.tar.gz"
|
||||
"http://mirrors.kodi.tv/build-deps/sources/flatbuffers-$_flatbuffers_version.tar.gz"
|
||||
"http://mirrors.kodi.tv/build-deps/sources/spdlog-$_spdlog_version.tar.gz"
|
||||
000-python3.8.patch
|
||||
sysusers.conf
|
||||
tmpfiles.conf
|
||||
)
|
||||
backup=(boot/kodi-gbm.config.txt)
|
||||
noextract=(
|
||||
"libdvdcss-$_libdvdcss_version.tar.gz"
|
||||
"libdvdnav-$_libdvdnav_version.tar.gz"
|
||||
"libdvdread-$_libdvdread_version.tar.gz"
|
||||
"ffmpeg-$_ffmpeg_version.tar.gz"
|
||||
"fmt-$_fmt_version.tar.gz"
|
||||
"crossguid-$_crossguid_version.tar.gz"
|
||||
"fstrcmp-$_fstrcmp_version.tar.gz"
|
||||
"flatbuffers-$_flatbuffers_version.tar.gz"
|
||||
"spdlog-$_spdlog_version.tar.gz"
|
||||
)
|
||||
sha256sums=('7090c73b0a50cc4229fbce94900c677839ea2ca888777ef02d9f99e474ee2b2d'
|
||||
'84ee6e1f7872fb249799f1428d5ab79930912ab7e064122c5c008fbecd0b547a'
|
||||
'61a0648d4a5086f560ceb4e020f82472d00b99398f2cacba94fad3e96c4c362a'
|
||||
'5d38a895ee7b93689fab79124a3aad23a5e3e643abd08878d778d04066c8d26f'
|
||||
'4d4dfdd510a66f1dcf1c1a80650935c83683b1a8a0fc9072b8c2319969e7e3a9'
|
||||
'38816f8373e243bc5950449b4f3b18938c4e1c59348e3411e23f31db4072e40d'
|
||||
'071e414e61b795f2ff9015b21a85fc009dde967f27780d23092643916538a57a'
|
||||
'a30b6aa0aad0f2c505bc77948af2d5531a80b6e68112addb4c123fca24d5d3bf'
|
||||
'8e159cdf1dfd3de2ac838fdaecb1fbb315e47f2ee2c542cd9d6efeb545c2b916'
|
||||
'1cafc80701b746085dddf41bd9193e6d35089e1c6ec1940e037fcb9c98f62365'
|
||||
'3d77d09a5df0de510aeeb940df4cb534787ddff3bb1828779753f5dfa1229d10'
|
||||
'e4018e850f80700acee8da296e56e15b1eef711ab15157e542e7d7e1237c3476'
|
||||
'1789b97e790da8f2cb5ff827d15580878c8629fd889f5f038d7524dca43eacc9'
|
||||
'b38e0bbef7faac2b82fed550a0c19b0d4e7f6737d5321d4fd8f216b80f8aee8a'
|
||||
'edff38cea510817c3682c7c6086054ac49adaa478285093ea294d83db065b83f'
|
||||
'f521b98232e5035b7cada46cf03975b8d753e93d0802bf22913fceed769f9d96'
|
||||
'9c5e79ed8719cd032a3b17dac585aeff28a198e37af1da9af68ef1b86bab4d18')
|
||||
prepare() {
|
||||
cd "xbmc-$_commithash"
|
||||
|
||||
[[ -d kodi-build ]] && rm -rf kodi-build
|
||||
mkdir $srcdir/kodi-build
|
||||
|
||||
patch -Np1 -i ../000-python3.8.patch
|
||||
}
|
||||
|
||||
build() {
|
||||
cd kodi-build
|
||||
|
||||
# the build system expects to find /usr/include/drm/drm_fourcc.h however we provide this
|
||||
# in /usr/lib/modules/5.4.51-1-ARCH/build/include/uapi/drm/drm_fourcc.h
|
||||
#
|
||||
# credit to Kevin for the following hack:
|
||||
|
||||
_kernel_release="$(pacman -Q linux-raspberrypi4-headers | grep -Eo "[^\ ]+$")-ARCH"
|
||||
mkdir -p "$srcdir/uapi/drm"
|
||||
ln -s /usr/lib/modules/$_kernel_release/build/include/uapi/drm/drm_fourcc.h "$srcdir/uapi/drm"
|
||||
export CPPFLAGS+=" -I$srcdir/uapi"
|
||||
|
||||
unset CFLAGS CXXFLAGS
|
||||
export CFLAGS="-march=armv8-a+crc+simd -mtune=cortex-a72 -mfpu=neon-fp-armv8 -mfloat-abi=hard -O2 -pipe -fstack-protector-strong -fno-plt"
|
||||
export CXXFLAGS="${CFLAGS}"
|
||||
|
||||
cmake -DCMAKE_INSTALL_PREFIX=/usr \
|
||||
-DCMAKE_EXE_LINKER_FLAGS_INIT="-L/opt/vc/lib -lvcsm" \
|
||||
-DCMAKE_EXE_LINKER_FLAGS="-L/opt/vc/lib -lvcsm" \
|
||||
-DCMAKE_CXX_FLAGS="-Wl,-L/opt/vc/lib -Wl,-lvcsm" \
|
||||
-DCMAKE_INSTALL_LIBDIR=/usr/lib \
|
||||
-DENABLE_EVENTCLIENTS=ON \
|
||||
-DENABLE_INTERNAL_FFMPEG=ON \
|
||||
-DENABLE_INTERNAL_FMT=ON \
|
||||
-DENABLE_INTERNAL_CROSSGUID=ON \
|
||||
-DENABLE_INTERNAL_FSTRCMP=ON \
|
||||
-DENABLE_INTERNAL_FLATBUFFERS=ON \
|
||||
-DENABLE_INTERNAL_SPDLOG=ON \
|
||||
-DENABLE_EVENTCLIENTS=ON \
|
||||
-DENABLE_VAAPI=OFF \
|
||||
-DENABLE_VDPAU=OFF \
|
||||
-DENABLE_OPENGL=OFF \
|
||||
-DENABLE_MYSQLCLIENT=ON \
|
||||
-Dlibdvdcss_URL="$srcdir/libdvdcss-$_libdvdcss_version.tar.gz" \
|
||||
-Dlibdvdnav_URL="$srcdir/libdvdnav-$_libdvdnav_version.tar.gz" \
|
||||
-Dlibdvdread_URL="$srcdir/libdvdread-$_libdvdread_version.tar.gz" \
|
||||
-DFFMPEG_URL="$srcdir/ffmpeg-$_ffmpeg_version.tar.gz" \
|
||||
-DFMT_URL="$srcdir/fmt-$_fmt_version.tar.gz" \
|
||||
-DCROSSGUID_URL="$srcdir/crossguid-$_crossguid_version.tar.gz" \
|
||||
-DFSTRCMP_URL="$srcdir/fstrcmp-$_fstrcmp_version.tar.gz" \
|
||||
-DFLATBUFFERS_URL="$srcdir/flatbuffers-$_flatbuffers_version.tar.gz" \
|
||||
-DSPDLOG_URL="$srcdir/spdlog-$_spdlog_version.tar.gz" \
|
||||
-DCORE_PLATFORM_NAME=gbm \
|
||||
-DGBM_RENDER_SYSTEM=gles \
|
||||
../"xbmc-$_commithash"
|
||||
make
|
||||
make preinstall
|
||||
}
|
||||
|
||||
package_kodi-rbp4-git() {
|
||||
pkgdesc="A software media player and entertainment hub for digital media (Raspberry Pi4/gbm only)"
|
||||
depends=(
|
||||
'desktop-file-utils' 'hicolor-icon-theme' 'mesa' 'python-pycryptodomex'
|
||||
'python-pillow6' 'python-simplejson' 'xorg-xdpyinfo'
|
||||
'bluez-libs' 'curl' 'lcms2' 'libass' 'libbluray' 'libcdio' 'libcec-rpi'
|
||||
'libinput' 'libmicrohttpd' 'libnfs' 'libpulse' 'libva' 'libxkbcommon'
|
||||
'libxslt' 'lirc' 'mariadb-libs' 'python2' 'smbclient' 'taglib'
|
||||
'tinyxml' 'polkit' 'linux>=5.4.35' 'shairplay' 'dav1d'
|
||||
)
|
||||
optdepends=(
|
||||
'afpfs-ng: Apple shares support'
|
||||
'bluez: Blutooth support'
|
||||
'python-pybluez: Bluetooth support'
|
||||
'libplist: Limited AirPlay support'
|
||||
'lsb-release: log distro information in crashlog'
|
||||
'upower: Display battery level'
|
||||
)
|
||||
install='kodi.install'
|
||||
provides=('xbmc' 'kodi')
|
||||
conflicts=('xbmc' 'kodi' 'arm-mem-git' 'shairplay-git')
|
||||
replaces=('xbmc-rbp-git')
|
||||
_components=('kodi' 'kodi-bin')
|
||||
|
||||
export PATH="$srcdir/path:$PATH"
|
||||
|
||||
cd kodi-build
|
||||
for _cmp in ${_components[@]}; do
|
||||
DESTDIR="$pkgdir" /usr/bin/cmake \
|
||||
-DCMAKE_INSTALL_COMPONENT="$_cmp" \
|
||||
-P cmake_install.cmake
|
||||
done
|
||||
|
||||
cd "$pkgdir"
|
||||
|
||||
# fix permissions necessary for accelerated video playback
|
||||
install -Dm0644 "$srcdir/99-kodi.rules" "$pkgdir/etc/udev/rules.d/99-kodi.rules"
|
||||
|
||||
# systemd manages kodi user
|
||||
install -Dm644 "$srcdir"/sysusers.conf "$pkgdir/usr/lib/sysusers.d/kodi.conf"
|
||||
install -Dm644 "$srcdir"/tmpfiles.conf "$pkgdir/usr/lib/tmpfiles.d/kodi.conf"
|
||||
|
||||
# systemd service and polkit rules
|
||||
install -Dm0644 "$srcdir/kodi.service" "$pkgdir/usr/lib/systemd/system/kodi.service"
|
||||
install -Dm0644 "$srcdir/polkit.rules" "$pkgdir/usr/share/polkit-1/rules.d/10-kodi.rules"
|
||||
chmod 0750 "$pkgdir/usr/share/polkit-1/rules.d/"
|
||||
|
||||
# setup video drivers for kodi-gbm on RPi4
|
||||
install -Dm0644 "$srcdir/kodi-gbm.config.txt" "$pkgdir/boot/kodi-gbm.config.txt"
|
||||
}
|
||||
|
||||
package_kodi-eventclients-rbp4-git() {
|
||||
pkgdesc="Kodi Event Clients (master branch)"
|
||||
provides=('kodi-eventclients')
|
||||
conflicts=('kodi-eventclients')
|
||||
optdepends=('python: most eventclients are implemented in python')
|
||||
|
||||
_components=(
|
||||
'kodi-eventclients-common'
|
||||
'kodi-eventclients-ps3'
|
||||
'kodi-eventclients-kodi-send'
|
||||
)
|
||||
|
||||
export PATH="$srcdir/path:$PATH"
|
||||
|
||||
cd kodi-build
|
||||
for _cmp in ${_components[@]}; do
|
||||
DESTDIR="$pkgdir" /usr/bin/cmake \
|
||||
-DCMAKE_INSTALL_COMPONENT="$_cmp" \
|
||||
-P cmake_install.cmake
|
||||
done
|
||||
}
|
||||
|
||||
package_kodi-tools-texturepacker-rbp4-git() {
|
||||
pkgdesc="Kodi Texturepacker tool (master branch)"
|
||||
depends=('libpng' 'giflib' 'libjpeg-turbo' 'lzo')
|
||||
_components=('kodi-tools-texturepacker')
|
||||
|
||||
export PATH="$srcdir/path:$PATH"
|
||||
|
||||
cd kodi-build
|
||||
for _cmp in ${_components[@]}; do
|
||||
DESTDIR="$pkgdir" /usr/bin/cmake \
|
||||
-DCMAKE_INSTALL_COMPONENT="$_cmp" \
|
||||
-P cmake_install.cmake
|
||||
done
|
||||
}
|
||||
|
||||
package_kodi-dev-rbp4-git() {
|
||||
pkgdesc="Kodi dev files (master branch)"
|
||||
depends=('kodi')
|
||||
provides=('kodi-dev')
|
||||
|
||||
_components=('kodi-addon-dev'
|
||||
'kodi-audio-dev'
|
||||
'kodi-eventclients-dev'
|
||||
'kodi-game-dev'
|
||||
'kodi-inputstream-dev'
|
||||
'kodi-peripheral-dev'
|
||||
'kodi-pvr-dev'
|
||||
'kodi-screensaver-dev'
|
||||
'kodi-visualization-dev')
|
||||
|
||||
export PATH="$srcdir/path:$PATH"
|
||||
|
||||
cd kodi-build
|
||||
for _cmp in ${_components[@]}; do
|
||||
DESTDIR="$pkgdir" /usr/bin/cmake \
|
||||
-DCMAKE_INSTALL_COMPONENT="$_cmp" \
|
||||
-P cmake_install.cmake
|
||||
done
|
||||
}
|
5
alarm/kodi-rbp4-git/kodi-gbm.config.txt
Normal file
5
alarm/kodi-rbp4-git/kodi-gbm.config.txt
Normal file
|
@ -0,0 +1,5 @@
|
|||
# Taken from LibreELEC Testbuilds
|
||||
# edit at your own risk
|
||||
dtoverlay=vc4-kms-v3d-pi4,cma-size=402653184
|
||||
dtoverlay=rpivid-v4l2
|
||||
disable_overscan=1
|
15
alarm/kodi-rbp4-git/kodi.install
Normal file
15
alarm/kodi-rbp4-git/kodi.install
Normal file
|
@ -0,0 +1,15 @@
|
|||
post_install() {
|
||||
echo "--> WARNING"
|
||||
echo "--> Remove any tweaks you made to /boot/config.txt now!"
|
||||
echo "--> Add the following to /boot/config.txt or else kodi will not work!"
|
||||
echo " [all]"
|
||||
echo " include kodi-gbm.config.txt"
|
||||
}
|
||||
|
||||
post_remove() {
|
||||
echo "==> Optionally remove /var/lib/kodi/"
|
||||
}
|
||||
|
||||
post_upgrade() {
|
||||
post_install
|
||||
}
|
20
alarm/kodi-rbp4-git/kodi.service
Normal file
20
alarm/kodi-rbp4-git/kodi.service
Normal file
|
@ -0,0 +1,20 @@
|
|||
[Unit]
|
||||
Description=Kodi standalone (GBM)
|
||||
After=remote-fs.target systemd-user-sessions.service network-online.target nss-lookup.target sound.target bluetooth.target polkit.service upower.service mysqld.service
|
||||
Wants=network-online.target polkit.service upower.service
|
||||
Conflicts=getty@tty1.service
|
||||
|
||||
[Service]
|
||||
User=kodi
|
||||
Group=kodi
|
||||
SupplementaryGroups=input
|
||||
PAMName=login
|
||||
TTYPath=/dev/tty1
|
||||
Environment=WINDOWING=gbm
|
||||
ExecStart=/usr/bin/kodi-standalone
|
||||
Restart=on-abort
|
||||
StandardInput=tty
|
||||
StandardOutput=journal
|
||||
|
||||
[Install]
|
||||
Alias=display-manager.service
|
15
alarm/kodi-rbp4-git/polkit.rules
Normal file
15
alarm/kodi-rbp4-git/polkit.rules
Normal file
|
@ -0,0 +1,15 @@
|
|||
polkit.addRule(function(action, subject) {
|
||||
if (subject.user == "kodi") {
|
||||
polkit.log("action=" + action);
|
||||
polkit.log("subject=" + subject);
|
||||
if (action.id.indexOf("org.freedesktop.login1.") == 0) {
|
||||
return polkit.Result.YES;
|
||||
}
|
||||
if (action.id.indexOf("org.freedesktop.udisks.") == 0) {
|
||||
return polkit.Result.YES;
|
||||
}
|
||||
if (action.id.indexOf("org.freedesktop.udisks2.") == 0) {
|
||||
return polkit.Result.YES;
|
||||
}
|
||||
}
|
||||
});
|
16
alarm/kodi-rbp4-git/sysusers.conf
Normal file
16
alarm/kodi-rbp4-git/sysusers.conf
Normal file
|
@ -0,0 +1,16 @@
|
|||
# override these settings by copying this to /etc/sysusers.d/ and modifying it therein
|
||||
|
||||
#Type Name ID GECOS Home directory Shell
|
||||
g kodi - -
|
||||
u kodi - "Kodi User" /var/lib/kodi
|
||||
|
||||
# supplemental groups
|
||||
m kodi audio
|
||||
m kodi disk
|
||||
m kodi input
|
||||
m kodi network
|
||||
m kodi optical
|
||||
m kodi power
|
||||
m kodi storage
|
||||
m kodi tty
|
||||
m kodi video
|
3
alarm/kodi-rbp4-git/tmpfiles.conf
Normal file
3
alarm/kodi-rbp4-git/tmpfiles.conf
Normal file
|
@ -0,0 +1,3 @@
|
|||
#Type Path Mode User Group Age Argument
|
||||
d /var/lib/kodi 0750 kodi kodi - -
|
||||
Z /var/lib/kodi - kodi kodi - -
|
Loading…
Reference in a new issue