mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
extra/qt5-doc to 5.10.0-1
This commit is contained in:
parent
e48485dd78
commit
78654285f3
2 changed files with 23 additions and 6 deletions
|
@ -7,7 +7,7 @@
|
|||
# - patch for chromium GN
|
||||
|
||||
pkgname=qt5-doc
|
||||
_qtver=5.9.3
|
||||
_qtver=5.10.0
|
||||
pkgver=${_qtver/-/}
|
||||
pkgrel=1
|
||||
arch=('any')
|
||||
|
@ -15,12 +15,14 @@ url='http://qt-project.org/'
|
|||
license=('GPL3' 'LGPL3' 'FDL' 'custom')
|
||||
pkgdesc='A cross-platform application and UI framework (Documentation)'
|
||||
depends=('qt5-base')
|
||||
makedepends=('qt5-tools' 'python2' 'pciutils' 'libxtst' 'libxcursor' 'libxrandr' 'libxss' 'libxcomposite' 'git')
|
||||
makedepends=('qt5-tools' 'python2' 'pciutils' 'libxtst' 'libxcursor' 'libxrandr' 'libxss' 'libxcomposite' 'gperf' 'nss')
|
||||
groups=('qt' 'qt5')
|
||||
_pkgfqn="qt-everywhere-opensource-src-${_qtver}"
|
||||
_pkgfqn="qt-everywhere-src-${_qtver}"
|
||||
source=("http://download.qt.io/official_releases/qt/${pkgver%.*}/${_qtver}/single/${_pkgfqn}.tar.xz"
|
||||
'0001-ARM-toolchain-fixes.patch')
|
||||
sha256sums=('57acd8f03f830c2d7dc29fbe28aaa96781b2b9bdddce94196e6761a0f88c6046'
|
||||
qt-no-statx.patch
|
||||
0001-ARM-toolchain-fixes.patch)
|
||||
sha256sums=('936d4cf5d577298f4f9fdb220e85b008ae321554a5fcd38072dc327a7296230e'
|
||||
'5cd1d90622cc53609806a3ce0b2811b28f0e6e20eb835861de4492dddeef6e52'
|
||||
'8202b09a1caa82538a2eacd79b62b61d8661c65cdfb275560d231aa31a362b12')
|
||||
|
||||
prepare() {
|
||||
|
@ -34,7 +36,11 @@ prepare() {
|
|||
mkdir -p bin
|
||||
ln -s /usr/bin/python2 bin/python
|
||||
|
||||
cd ${_pkgfqn}/qtwebengine/src/3rdparty
|
||||
# Don't use the statx syscall https://bugs.archlinux.org/task/56289 https://bugreports.qt.io/browse/QTBUG-64490
|
||||
cd ${_pkgfqn}/qtbase
|
||||
patch -p1 -i "$srcdir"/qt-no-statx.patch
|
||||
|
||||
cd ${srcdir}/${_pkgfqn}/qtwebengine/src/3rdparty
|
||||
patch -p1 -i ${srcdir}/0001-ARM-toolchain-fixes.patch
|
||||
}
|
||||
|
||||
|
|
11
extra/qt5-doc/qt-no-statx.patch
Normal file
11
extra/qt5-doc/qt-no-statx.patch
Normal file
|
@ -0,0 +1,11 @@
|
|||
--- qtbase-everywhere-src-5.10.0-beta4/src/corelib/io/qfilesystemengine_unix.cpp.orig 2017-11-14 12:10:28.156094557 +0000
|
||||
+++ qtbase-everywhere-src-5.10.0-beta4/src/corelib/io/qfilesystemengine_unix.cpp 2017-11-14 12:10:46.156136206 +0000
|
||||
@@ -95,7 +95,7 @@
|
||||
{ return syscall(SYS_renameat2, oldfd, oldpath, newfd, newpath, flags); }
|
||||
# endif
|
||||
|
||||
-# if !QT_CONFIG(statx) && defined(SYS_statx) && QT_HAS_INCLUDE(<linux/stat.h>)
|
||||
+# if 0
|
||||
# include <linux/stat.h>
|
||||
static int statx(int dirfd, const char *pathname, int flag, unsigned mask, struct statx *statxbuf)
|
||||
{ return syscall(SYS_statx, dirfd, pathname, flag, mask, statxbuf); }
|
Loading…
Reference in a new issue