mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-01-17 23:34:07 +00:00
added community/maven
This commit is contained in:
parent
e4de987007
commit
78697f2280
4 changed files with 66 additions and 0 deletions
3
community/maven/ChangeLog
Normal file
3
community/maven/ChangeLog
Normal file
|
@ -0,0 +1,3 @@
|
|||
2007-06-29 tardo <tardo@nagi-fanboi.net>
|
||||
* Built for x86_64
|
||||
* Not sure if the binary will work.. but lets try anyway
|
46
community/maven/PKGBUILD
Normal file
46
community/maven/PKGBUILD
Normal file
|
@ -0,0 +1,46 @@
|
|||
# $Id$
|
||||
# Maintainer: Sergej Pupykin <pupykin.s+arch@gmail.com>
|
||||
# Contributor: William Rea <sillywilly@gmail.com>
|
||||
|
||||
# ALARM: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
# - patch to increase build timeout
|
||||
|
||||
pkgname=maven
|
||||
pkgver=3.1.1
|
||||
pkgrel=1
|
||||
pkgdesc="A Java project management and project comprehension tool"
|
||||
arch=('any')
|
||||
url="http://maven.apache.org"
|
||||
license=('APACHE')
|
||||
depends=('java-environment')
|
||||
makedepends=('apache-ant')
|
||||
backup=('opt/maven/conf/settings.xml')
|
||||
source=(http://apache-mirror.rbc.ru/pub/apache/maven/maven-3/$pkgver/source/apache-maven-$pkgver-src.tar.gz
|
||||
maven.sh
|
||||
timeout.patch)
|
||||
md5sums=('46e0b798750df60aa157d7b38a10265c'
|
||||
'5ed0bddbf5c5375fe5032a76a9506426'
|
||||
'7ddbe22786ce1f2fd5740f91c1026e53')
|
||||
|
||||
package() {
|
||||
cd $srcdir/apache-maven-$pkgver
|
||||
|
||||
patch -p1 -i ../timeout.patch
|
||||
|
||||
. /etc/profile.d/jre.sh
|
||||
. /etc/profile.d/jdk.sh
|
||||
|
||||
mkdir -p $srcdir/repo
|
||||
mkdir $pkgdir/opt
|
||||
export MAVEN_OPTS=-Xmx512m
|
||||
export M2_HOME=$pkgdir/opt/maven
|
||||
export PATH=$PATH:$M2_HOME/bin
|
||||
|
||||
# FIXME: downloads many deps from Internet. Probably they should be
|
||||
# packaged or added into source=()
|
||||
ant -Dmaven.repo.local=$srcdir/repo
|
||||
install -D -m 755 $srcdir/maven.sh $pkgdir/etc/profile.d/maven.sh
|
||||
rm $pkgdir/opt/maven/*.txt
|
||||
mkdir -p $pkgdir/usr/bin
|
||||
ln -s /opt/maven/bin/mvn $pkgdir/usr/bin/mvn
|
||||
}
|
5
community/maven/maven.sh
Normal file
5
community/maven/maven.sh
Normal file
|
@ -0,0 +1,5 @@
|
|||
#!/bin/bash
|
||||
|
||||
export MAVEN_OPTS=-Xmx512m
|
||||
#export M2_HOME=/opt/maven
|
||||
#export PATH=$PATH:$M2_HOME/bin
|
12
community/maven/timeout.patch
Normal file
12
community/maven/timeout.patch
Normal file
|
@ -0,0 +1,12 @@
|
|||
diff -urN a/build.xml b/build.xml
|
||||
--- a/build.xml 2013-09-17 09:19:37.000000000 -0600
|
||||
+++ b/build.xml 2014-02-13 19:36:57.481202993 -0700
|
||||
@@ -250,7 +250,7 @@
|
||||
</target>
|
||||
|
||||
<target name="maven-compile" depends="compile-boot,process-classes" description="compiles Maven using the bootstrap Maven, skipping automated tests">
|
||||
- <java fork="${maven-compile.fork}" classname="org.apache.maven.cli.MavenCli" failonerror="true" timeout="600000" maxmemory="${maven-compile.maxmemory}">
|
||||
+ <java fork="${maven-compile.fork}" classname="org.apache.maven.cli.MavenCli" failonerror="true" timeout="6000000" maxmemory="${maven-compile.maxmemory}">
|
||||
<!--jvmarg line="-Xdebug -Xnoagent -Djava.compiler=NONE -Xrunjdwp:transport=dt_socket,server=y,suspend=y,address=8000"/-->
|
||||
<!--jvmarg value="${maven-compile.jvmargs}"/-->
|
||||
<classpath refid="maven.classpath" />
|
Loading…
Reference in a new issue