added extra/webkit2gtk

This commit is contained in:
Kevin Mihelich 2014-10-17 16:01:45 +00:00
parent 23e66687c6
commit 787aebfe49
3 changed files with 91 additions and 5 deletions

View file

@ -1,4 +1,3 @@
# pkgbuilds.git - README - 2013-04-08
This repository hosts
[PKGBUILDs](https://wiki.archlinux.org/index.php/PKGBUILD) that have been
modified from the upstream [Arch Linux](http://archlinux.org) release in order
@ -33,8 +32,8 @@ feel belong within the scope of these repos.
Contains a selection of packages from the [AUR](https://aur.archlinux.org/
"Arch User Repository") that have been highly requested by the community to be
pre-compiled and easily installed. However, you're free to use the AUR just as
you would on Arch, and we have included Yaourt to compile and install directly
from AUR (`yaourt -AS packagename`).
you would on Arch, and we have included cower and packer to compile and install
directly from the AUR.
### alarm
Contains packages we have created or have been submitted to us to enable
@ -62,8 +61,8 @@ specified, the package will build for all architectures.
* `0000 0010` (2) = the package will be built only for armv5
* `0000 0100` (4) = the package will be built only for armv7h
* `0000 1000` (8) = reserved
* `0001 0000` (16) = the package will be build only for armv6h
* `0001 0000` (16) = the package will be built only for armv6h
### highmem
If non-zero, the build system will mark the package as requiring a builder that
has more than 1GB of RAM/swap to build successfully.
has more than 2GB of RAM to build successfully.

61
extra/webkit2gtk/PKGBUILD Normal file
View file

@ -0,0 +1,61 @@
# $Id$
# Maintainer: Andreas Radke <andyrtr@archlinux.org>
# ALARM: Kevin Mihelich <kevin@archlinuxarm.org>
# - do not use LLINT assembly for v5/v6
pkgname=webkit2gtk
pkgver=2.6.1
pkgrel=1
pkgdesc="GTK+ Web content engine library"
arch=(i686 x86_64)
url="http://webkitgtk.org/"
license=(custom)
depends=(libxt libxslt sqlite libsoup enchant libgl geoclue2 gst-plugins-base-libs
libsecret libwebp harfbuzz-icu gtk3)
makedepends=(gtk3 gtk2 gperf gobject-introspection python2 mesa ruby gtk-doc cmake python)
optdepends=('gtk2: Netscape plugin support'
'gst-plugins-base: free media decoding'
'gst-plugins-good: media decoding'
'gst-libav: nonfree media decoding')
options=(!emptydirs)
source=(http://webkitgtk.org/releases/webkitgtk-${pkgver}.tar.xz
fix-pretty-quotes.patch)
sha256sums=('c846a662762dd79c26e77fa36348e706d217d1385bb2dbdcfc28a5a1476c6d54'
'56316228bbbf0b7ebcbe210a35120f4e72cb9c1b680dd82cc2bde0f4549245e6')
prepare() {
mkdir build
cd webkitgtk-$pkgver
patch -Np0 -i ../fix-pretty-quotes.patch
sed -i '1s/python$/&2/' Tools/gtk/generate-gtkdoc
rm -r Source/ThirdParty/gtest/
rm -r Source/ThirdParty/qunit/
}
build() {
cd build
# do not use LLINT assembly for v5/v6
[[ $CARCH == "arm" || $CARCH == "armv6h" ]] && CONFIG="-DENABLE_LLINT_C_LOOP=1"
cmake -DPORT=GTK -DCMAKE_BUILD_TYPE=Release \
-DCMAKE_SKIP_RPATH=ON -DCMAKE_INSTALL_PREFIX=/usr \
-DLIB_INSTALL_DIR=/usr/lib -DLIBEXEC_INSTALL_DIR=/usr/lib/webkit2gtk-4.0 \
-DENABLE_GTKDOC=ON $CONFIG ../webkitgtk-$pkgver
make
}
package() {
cd build
make DESTDIR="$pkgdir" install
install -m755 -d "$pkgdir/usr/share/licenses/webkit2gtk"
cd "$srcdir/webkitgtk-$pkgver/Source"
for f in $(find -name 'COPYING*' -or -name 'LICENSE*'); do
echo $f >> "$pkgdir/usr/share/licenses/webkit2gtk/LICENSE"
cat $f >> "$pkgdir/usr/share/licenses/webkit2gtk/LICENSE"
echo "" >> "$pkgdir/usr/share/licenses/webkit2gtk/LICENSE"
done
}

View file

@ -0,0 +1,26 @@
Pretty quotes in licence break Python stdin.
https://bugs.webkit.org/show_bug.cgi?id=128971
--- Source/WebCore/xml/XMLViewer.css.orig 2014-01-23 16:49:58.000000000 +0000
+++ Source/WebCore/xml/XMLViewer.css
@@ -14,7 +14,7 @@
* distribution.
*
* THIS SOFTWARE IS PROVIDED BY GOOGLE INC. AND ITS CONTRIBUTORS
- * “AS IS” AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT
+ * "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT
* LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR
* A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL GOOGLE INC.
* OR ITS CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
--- Source/WebCore/xml/XMLViewer.js.orig 2014-01-23 16:49:58.000000000 +0000
+++ Source/WebCore/xml/XMLViewer.js
@@ -15,7 +15,7 @@
* distribution.
*
* THIS SOFTWARE IS PROVIDED BY GOOGLE INC. AND ITS CONTRIBUTORS
- * “AS IS” AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT
+ * "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT
* LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR
* A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL GOOGLE INC.
* OR ITS CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,