mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
extra/thunderbird to 45.1.0-1
This commit is contained in:
parent
f43a14ba39
commit
788bad141d
5 changed files with 9274 additions and 19 deletions
|
@ -15,31 +15,34 @@ buildarch=28
|
|||
highmem=1
|
||||
|
||||
pkgname=thunderbird
|
||||
pkgver=45.0
|
||||
pkgver=45.1.0
|
||||
pkgrel=1
|
||||
pkgdesc="Standalone mail and news reader from mozilla.org"
|
||||
arch=('i686' 'x86_64')
|
||||
license=('MPL' 'GPL')
|
||||
license=('MPL' 'GPL' 'LGPL')
|
||||
url="http://www.mozilla.org/thunderbird/"
|
||||
depends=('gtk2' 'mozilla-common' 'libxt' 'startup-notification' 'mime-types'
|
||||
'dbus-glib' 'alsa-lib' 'desktop-file-utils' 'hicolor-icon-theme'
|
||||
'libvpx' 'icu' 'libevent' 'nss' 'hunspell' 'sqlite' 'ttf-font')
|
||||
'dbus-glib' 'alsa-lib' 'libvpx' 'icu' 'libevent' 'nss' 'hunspell'
|
||||
'sqlite' 'ttf-font')
|
||||
makedepends=('unzip' 'zip' 'diffutils' 'python2' 'yasm' 'mesa' 'imake' 'gconf'
|
||||
'libpulse' 'inetutils')
|
||||
optdepends=('libcanberra: for sound support')
|
||||
install=thunderbird.install
|
||||
options=('!emptydirs' '!makeflags')
|
||||
source=(https://ftp.mozilla.org/pub/mozilla.org/thunderbird/releases/$pkgver/source/thunderbird-$pkgver.source.tar.xz
|
||||
mozconfig
|
||||
thunderbird.desktop
|
||||
thunderbird-install-dir.patch
|
||||
firefox-gcc-6.0.patch mozilla-1228540.patch mozilla-1228540-1.patch
|
||||
vendor.js
|
||||
no-neon.patch)
|
||||
options=('!emptydirs' '!makeflags')
|
||||
sha256sums=('15693897f1e46cbb5a95932b8c087a53004635415845fb4f50d4edfbba77d667'
|
||||
'ef963a9b1faa52343f65d61aea4db63000d789206221d02f908e4b0d0f1dc0d7'
|
||||
sha256sums=('8ae9ebe536895d69d99f412f2b3aba645b7dd839e520959330da13892d672309'
|
||||
'e6ab613a6d15668ac6856b591d07efa4a338671dad4ce09e9254662848462ee5'
|
||||
'3fba13d88aeb003ab0811ef739463858172ce0662a1c7d62835df3d83ddbb8fb'
|
||||
'24599eab8862476744fe1619a9a53a5b8cdcab30b3fc5767512f31d3529bd05d'
|
||||
'4d1e1ddabc9e975ed39f49e134559a29e01cd49439e358233f1ede43bf5a52bf'
|
||||
'2588c567fec88b44b65f0cd111e8769361c138d4c964310684f7bb80066f8f9f'
|
||||
'd1ccbaf0973615c57f7893355e5cd3a89efb4e91071d0ec376e429b50cf6ed19'
|
||||
'e4ea8e6788163d9f8db8f1f40023db3ea0a1358f9a4510169f2d4c4fe6a887ed'
|
||||
'59f40d8b2480aa67bf76f4f119826b6828a6a59cc040caf1ab5a6e19eef44c6e')
|
||||
|
||||
|
@ -64,6 +67,11 @@ prepare() {
|
|||
cp ../mozconfig .mozconfig
|
||||
patch -Np1 -i ../thunderbird-install-dir.patch
|
||||
|
||||
# Required for GCC 6
|
||||
patch -d mozilla -Np1 < ../firefox-gcc-6.0.patch
|
||||
patch -d mozilla -Np1 < ../mozilla-1228540.patch
|
||||
patch -d mozilla -Np1 < ../mozilla-1228540-1.patch
|
||||
|
||||
patch -Np0 -i ../no-neon.patch
|
||||
|
||||
echo -n "$_google_api_key" >google-api-key
|
||||
|
@ -79,17 +87,19 @@ prepare() {
|
|||
ln -s /usr/bin/python2 "$srcdir/path/python"
|
||||
|
||||
[[ $CARCH == "aarch64" ]] && echo "ac_add_options --disable-jemalloc" >> .mozconfig
|
||||
|
||||
# configure script misdetects the preprocessor without an optimization level
|
||||
# https://bugs.archlinux.org/task/34644
|
||||
sed -i '/ac_cpp=/s/$CPPFLAGS/& -O2/' mozilla/configure
|
||||
}
|
||||
|
||||
build() {
|
||||
cd $pkgname-$pkgver
|
||||
|
||||
# _FORTIFY_SOURCE causes configure failures
|
||||
CPPFLAGS+=" -O2"
|
||||
|
||||
# GCC 6
|
||||
CFLAGS+=" -fno-delete-null-pointer-checks -fno-lifetime-dse"
|
||||
CXXFLAGS+=" -fno-delete-null-pointer-checks -fno-lifetime-dse"
|
||||
|
||||
export PATH="$srcdir/path:$PATH"
|
||||
export PYTHON="/usr/bin/python2"
|
||||
export LDFLAGS="$LDFLAGS -Wl,--no-keep-memory -Wl,--reduce-memory-overheads"
|
||||
|
||||
make -f client.mk build
|
||||
|
|
26
extra/thunderbird/firefox-gcc-6.0.patch
Normal file
26
extra/thunderbird/firefox-gcc-6.0.patch
Normal file
|
@ -0,0 +1,26 @@
|
|||
diff -up firefox-44.0/nsprpub/config/make-system-wrappers.pl.back firefox-44.0/nsprpub/config/make-system-wrappers.pl
|
||||
--- firefox-44.0/nsprpub/config/make-system-wrappers.pl.back 2016-01-24 00:23:49.000000000 +0100
|
||||
+++ firefox-44.0/nsprpub/config/make-system-wrappers.pl 2016-02-02 14:58:45.064112655 +0100
|
||||
@@ -19,7 +19,9 @@ while (<STDIN>) {
|
||||
open OUT, ">$output_dir/$_";
|
||||
print OUT "#pragma GCC system_header\n"; # suppress include_next warning
|
||||
print OUT "#pragma GCC visibility push(default)\n";
|
||||
+ print OUT "#define _GLIBCXX_INCLUDE_NEXT_C_HEADERS\n";
|
||||
print OUT "#include_next \<$_\>\n";
|
||||
+ print OUT "#undef _GLIBCXX_INCLUDE_NEXT_C_HEADERS\n";
|
||||
print OUT "#pragma GCC visibility pop\n";
|
||||
close OUT;
|
||||
}
|
||||
diff -up firefox-44.0/mozglue/build/arm.cpp.old firefox-44.0/mozglue/build/arm.cpp
|
||||
--- firefox-44.0/mozglue/build/arm.cpp.old 2016-02-03 10:07:29.879526500 +0100
|
||||
+++ firefox-44.0/mozglue/build/arm.cpp 2016-02-03 10:08:11.062697517 +0100
|
||||
@@ -104,7 +104,9 @@ check_neon(void)
|
||||
|
||||
# elif defined(__linux__) || defined(ANDROID)
|
||||
# include <stdio.h>
|
||||
+#define _GLIBCXX_INCLUDE_NEXT_C_HEADERS
|
||||
# include <stdlib.h>
|
||||
+#undef _GLIBCXX_INCLUDE_NEXT_C_HEADERS
|
||||
# include <string.h>
|
||||
|
||||
enum{
|
|
@ -17,29 +17,26 @@ ac_add_options --disable-debug-symbols
|
|||
# System libraries
|
||||
ac_add_options --with-system-nspr
|
||||
ac_add_options --with-system-nss
|
||||
ac_add_options --with-system-icu
|
||||
ac_add_options --with-system-jpeg
|
||||
ac_add_options --with-system-zlib
|
||||
ac_add_options --with-system-bz2
|
||||
ac_add_options --with-system-png
|
||||
ac_add_options --with-system-libevent
|
||||
ac_add_options --with-system-libvpx
|
||||
ac_add_options --with-system-icu
|
||||
ac_add_options --enable-system-hunspell
|
||||
ac_add_options --enable-system-sqlite
|
||||
ac_add_options --enable-system-ffi
|
||||
ac_add_options --enable-system-cairo
|
||||
ac_add_options --enable-system-pixman
|
||||
|
||||
# Features
|
||||
ac_add_options --enable-calendar
|
||||
ac_add_options --enable-startup-notification
|
||||
|
||||
ac_add_options --enable-pulseaudio
|
||||
ac_add_options --disable-gstreamer
|
||||
|
||||
ac_add_options --disable-crashreporter
|
||||
ac_add_options --disable-updater
|
||||
ac_add_options --disable-installer
|
||||
ac_add_options --disable-debug-symbols
|
||||
ac_add_options --disable-crashreporter
|
||||
|
||||
STRIP_FLAGS="--strip-debug"
|
||||
|
||||
# vim:set ft=sh:
|
||||
|
|
84
extra/thunderbird/mozilla-1228540-1.patch
Normal file
84
extra/thunderbird/mozilla-1228540-1.patch
Normal file
|
@ -0,0 +1,84 @@
|
|||
# HG changeset patch
|
||||
# User Jonathan Kew <jkew@mozilla.com>
|
||||
# Date 1452675061 0
|
||||
# Wed Jan 13 08:51:01 2016 +0000
|
||||
# Node ID cf699e95e98829b465b64a7e0281d95ec851ce8c
|
||||
# Parent 3c9f357598e86c2f593e9895d5725bf3498f8f5a
|
||||
Bug 1228540 - pt 2 - Remove our HBGetGlyphHOrigin callback, as the default behavior is sufficient.
|
||||
|
||||
diff --git a/gfx/thebes/gfxHarfBuzzShaper.cpp b/gfx/thebes/gfxHarfBuzzShaper.cpp
|
||||
--- a/gfx/thebes/gfxHarfBuzzShaper.cpp
|
||||
+++ b/gfx/thebes/gfxHarfBuzzShaper.cpp
|
||||
@@ -349,27 +349,16 @@ gfxHarfBuzzShaper::HBGetGlyphVAdvance(hb
|
||||
static_cast<const gfxHarfBuzzShaper::FontCallbackData*>(font_data);
|
||||
// Currently, we don't offer gfxFont subclasses a method to override this
|
||||
// and provide hinted platform-specific vertical advances (analogous to the
|
||||
// GetGlyphWidth method for horizontal advances). If that proves necessary,
|
||||
// we'll add a new gfxFont method and call it from here.
|
||||
return fcd->mShaper->GetGlyphVAdvance(glyph);
|
||||
}
|
||||
|
||||
-/* static */
|
||||
-hb_bool_t
|
||||
-gfxHarfBuzzShaper::HBGetGlyphHOrigin(hb_font_t *font, void *font_data,
|
||||
- hb_codepoint_t glyph,
|
||||
- hb_position_t *x, hb_position_t *y,
|
||||
- void *user_data)
|
||||
-{
|
||||
- // We work in horizontal coordinates, so no origin adjustment needed here.
|
||||
- return true;
|
||||
-}
|
||||
-
|
||||
struct VORG {
|
||||
AutoSwap_PRUint16 majorVersion;
|
||||
AutoSwap_PRUint16 minorVersion;
|
||||
AutoSwap_PRInt16 defaultVertOriginY;
|
||||
AutoSwap_PRUint16 numVertOriginYMetrics;
|
||||
};
|
||||
|
||||
struct VORGrec {
|
||||
@@ -1262,19 +1251,16 @@ gfxHarfBuzzShaper::Initialize()
|
||||
hb_font_funcs_set_glyph_func(sHBFontFuncs, HBGetGlyph,
|
||||
nullptr, nullptr);
|
||||
hb_font_funcs_set_glyph_h_advance_func(sHBFontFuncs,
|
||||
HBGetGlyphHAdvance,
|
||||
nullptr, nullptr);
|
||||
hb_font_funcs_set_glyph_v_advance_func(sHBFontFuncs,
|
||||
HBGetGlyphVAdvance,
|
||||
nullptr, nullptr);
|
||||
- hb_font_funcs_set_glyph_h_origin_func(sHBFontFuncs,
|
||||
- HBGetGlyphHOrigin,
|
||||
- nullptr, nullptr);
|
||||
hb_font_funcs_set_glyph_v_origin_func(sHBFontFuncs,
|
||||
HBGetGlyphVOrigin,
|
||||
nullptr, nullptr);
|
||||
hb_font_funcs_set_glyph_extents_func(sHBFontFuncs,
|
||||
HBGetGlyphExtents,
|
||||
nullptr, nullptr);
|
||||
hb_font_funcs_set_glyph_contour_point_func(sHBFontFuncs,
|
||||
HBGetContourPoint,
|
||||
diff --git a/gfx/thebes/gfxHarfBuzzShaper.h b/gfx/thebes/gfxHarfBuzzShaper.h
|
||||
--- a/gfx/thebes/gfxHarfBuzzShaper.h
|
||||
+++ b/gfx/thebes/gfxHarfBuzzShaper.h
|
||||
@@ -56,21 +56,16 @@ public:
|
||||
hb_codepoint_t glyph, void *user_data);
|
||||
|
||||
// get harfbuzz vertical advance in 16.16 fixed point format.
|
||||
static hb_position_t
|
||||
HBGetGlyphVAdvance(hb_font_t *font, void *font_data,
|
||||
hb_codepoint_t glyph, void *user_data);
|
||||
|
||||
static hb_bool_t
|
||||
- HBGetGlyphHOrigin(hb_font_t *font, void *font_data,
|
||||
- hb_codepoint_t glyph,
|
||||
- hb_position_t *x, hb_position_t *y,
|
||||
- void *user_data);
|
||||
- static hb_bool_t
|
||||
HBGetGlyphVOrigin(hb_font_t *font, void *font_data,
|
||||
hb_codepoint_t glyph,
|
||||
hb_position_t *x, hb_position_t *y,
|
||||
void *user_data);
|
||||
|
||||
hb_position_t GetHKerning(uint16_t aFirstGlyph,
|
||||
uint16_t aSecondGlyph) const;
|
||||
|
9138
extra/thunderbird/mozilla-1228540.patch
Normal file
9138
extra/thunderbird/mozilla-1228540.patch
Normal file
File diff suppressed because it is too large
Load diff
Loading…
Reference in a new issue