added community/lxqt-build-tools

This commit is contained in:
Kevin Mihelich 2017-01-18 01:50:20 +00:00
parent bdbbf16045
commit 788e75df87
2 changed files with 75 additions and 0 deletions

View file

@ -0,0 +1,25 @@
From fb98e356551cea67f8810a377edf5c1d6205bcb8 Mon Sep 17 00:00:00 2001
From: Kevin Mihelich <kevin@archlinuxarm.org>
Date: Tue, 17 Jan 2017 18:36:03 -0700
Subject: [PATCH] disable LTO
---
cmake/modules/LXQtCompilerSettings.cmake | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/cmake/modules/LXQtCompilerSettings.cmake b/cmake/modules/LXQtCompilerSettings.cmake
index 2b1e774..a07b35a 100644
--- a/cmake/modules/LXQtCompilerSettings.cmake
+++ b/cmake/modules/LXQtCompilerSettings.cmake
@@ -150,7 +150,7 @@ endif()
if (CMAKE_COMPILER_IS_GNUCXX OR LXQT_COMPILER_IS_CLANGCXX)
# -flto: use link-time optimizations to generate more efficient code
if (CMAKE_COMPILER_IS_GNUCXX)
- set(LTO_FLAGS "-flto -fuse-linker-plugin")
+ #set(LTO_FLAGS "-flto -fuse-linker-plugin")
# When building static libraries with LTO in gcc >= 4.9,
# "gcc-ar" and "gcc-ranlib" should be used instead of "ar" and "ranlib".
# references:
--
2.11.0

View file

@ -0,0 +1,50 @@
# $Id$
# Maintainer: Jerome Leclanche <jerome@leclan.ch>
# ALARM: Kevin Mihelich <kevin@archlinuxarm.org>
# - disable LTO to fix FTBFS on other lxqt packages
pkgname=lxqt-build-tools
pkgver=0.3.2
pkgrel=4.1
pkgdesc="Various packaging tools and scripts for LXQt applications"
arch=("any")
groups=("lxqt")
url="http://lxqt.org"
license=("LGPL2.1")
depends=("cmake" "qt5-tools" "git")
source=(
"https://github.com/lxde/$pkgname/releases/download/$pkgver/$pkgname-$pkgver.tar.xz"
"https://github.com/lxde/$pkgname/releases/download/$pkgver/$pkgname-$pkgver.tar.xz.asc"
'0001-disable-LTO.patch'
)
sha256sums=(
"726fca2597fb438cc6dcdea1b9e34d719ff0fa371fcd9a304c608e425ff364ef"
"SKIP"
"7e9cd88a6e28f16204ff4facf4b29e53ecf4f25eb166e53ba9052bba901bad53"
)
validpgpkeys=(
"169704C6FB490C6892C7F23C37E0AF1FDA48F373" # Jerome Leclanche <jerome@leclan.ch>
"7C733BA5F585AAD669E4D23A42C9C8D3AF5EA5E3" # Alf Gaida <agaida@siduction.org>
)
prepare() {
cd $pkgname-$pkgver
if [[ $CARCH != "aarch64" ]]; then
patch -p1 -i ../0001-disable-LTO.patch
fi
}
build() {
mkdir -p build
cd build
cmake "$srcdir/$pkgname-$pkgver" \
-DCMAKE_INSTALL_PREFIX=/usr
make
}
package() {
cd build
make DESTDIR="$pkgdir" install
}