mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-28 22:57:37 +00:00
extra/vlc to 2.0.8-1
This commit is contained in:
parent
89a415ea50
commit
78ca4b29d3
2 changed files with 28 additions and 12 deletions
|
@ -7,15 +7,15 @@
|
||||||
# - drop oss support
|
# - drop oss support
|
||||||
|
|
||||||
pkgname=vlc
|
pkgname=vlc
|
||||||
pkgver=2.0.7
|
pkgver=2.0.8
|
||||||
pkgrel=2
|
pkgrel=1
|
||||||
pkgdesc="A multi-platform MPEG, VCD/DVD, and DivX player"
|
pkgdesc="A multi-platform MPEG, VCD/DVD, and DivX player"
|
||||||
arch=('i686' 'x86_64')
|
arch=('i686' 'x86_64')
|
||||||
url="http://www.videolan.org/vlc/"
|
url="http://www.videolan.org/vlc/"
|
||||||
license=('LGPL2.1' 'GPL2')
|
license=('LGPL2.1' 'GPL2')
|
||||||
depends=('a52dec' 'libdvbpsi' 'libxpm' 'libdca' 'qt4' 'libproxy'
|
depends=('a52dec' 'libdvbpsi' 'libxpm' 'libdca' 'qt4' 'libproxy'
|
||||||
'sdl_image' 'libdvdnav' 'libtiger' 'lua51' 'libmatroska'
|
'sdl_image' 'libdvdnav' 'libtiger' 'lua51' 'libmatroska'
|
||||||
'zvbi' 'taglib' 'libmpcdec' 'ffmpeg' 'faad2' 'libupnp'
|
'zvbi' 'taglib' 'libmpcdec' 'ffmpeg-compat' 'faad2' 'libupnp'
|
||||||
'libshout' 'libmad' 'libmpeg2' 'xcb-util-keysyms')
|
'libshout' 'libmad' 'libmpeg2' 'xcb-util-keysyms')
|
||||||
makedepends=('live-media' 'libnotify' 'libbluray' 'flac' 'kdelibs'
|
makedepends=('live-media' 'libnotify' 'libbluray' 'flac' 'kdelibs'
|
||||||
'libdc1394' 'libavc1394' 'lirc-utils' 'libcaca'
|
'libdc1394' 'libavc1394' 'lirc-utils' 'libcaca'
|
||||||
|
@ -58,20 +58,25 @@ backup=('usr/share/vlc/lua/http/.hosts'
|
||||||
'usr/share/vlc/lua/http/dialogs/.hosts')
|
'usr/share/vlc/lua/http/dialogs/.hosts')
|
||||||
options=('!libtool' '!emptydirs')
|
options=('!libtool' '!emptydirs')
|
||||||
install=vlc.install
|
install=vlc.install
|
||||||
source=("http://download.videolan.org/pub/videolan/${pkgname}/${pkgver}/${pkgname}-${pkgver}.tar.xz")
|
source=("http://download.videolan.org/pub/videolan/${pkgname}/${pkgver}/${pkgname}-${pkgver}.tar.xz"
|
||||||
md5sums=('3b0e465b0990097b65abaf3e25589957')
|
vlc-2.0.7-vaapi-compat.patch)
|
||||||
|
md5sums=('3b0e465b0990097b65abaf3e25589957'
|
||||||
|
'6df10774bb7acf20e09d6139e5c7839e')
|
||||||
|
|
||||||
|
prepare() {
|
||||||
|
cd "${srcdir}/${pkgname}-${pkgver}"
|
||||||
|
|
||||||
|
patch -Np1 -i ../vlc-2.0.7-vaapi-compat.patch
|
||||||
|
|
||||||
|
sed -i -e 's:truetype/freefont:TTF:g' modules/text_renderer/freetype.c
|
||||||
|
sed -i -e 's:truetype/ttf-dejavu:TTF:g' modules/visualization/projectm.cpp
|
||||||
|
}
|
||||||
|
|
||||||
build() {
|
build() {
|
||||||
cd "${srcdir}/${pkgname}-${pkgver}"
|
cd "${srcdir}/${pkgname}-${pkgver}"
|
||||||
|
|
||||||
sed -i -e 's:truetype/freefont:TTF:g' modules/text_renderer/freetype.c
|
|
||||||
sed -i -e 's:truetype/ttf-dejavu:TTF:g' modules/visualization/projectm.cpp
|
|
||||||
|
|
||||||
# fix for flac-1.3.0
|
|
||||||
sed -i -e 's:stream_decoder.h:FLAC/stream_decoder.h:' modules/codec/flac.c
|
|
||||||
sed -i -e 's:stream_encoder.h:FLAC/stream_encoder.h:' modules/codec/flac.c
|
|
||||||
|
|
||||||
CFLAGS+="-I/usr/include/samba-4.0" CPPFLAGS+="-I/usr/include/samba-4.0" \
|
CFLAGS+="-I/usr/include/samba-4.0" CPPFLAGS+="-I/usr/include/samba-4.0" \
|
||||||
|
PKG_CONFIG_PATH+="/usr/lib/ffmpeg-compat/pkgconfig" \
|
||||||
./configure --prefix=/usr \
|
./configure --prefix=/usr \
|
||||||
--sysconfdir=/etc \
|
--sysconfdir=/etc \
|
||||||
--disable-rpath \
|
--disable-rpath \
|
||||||
|
|
11
extra/vlc/vlc-2.0.7-vaapi-compat.patch
Normal file
11
extra/vlc/vlc-2.0.7-vaapi-compat.patch
Normal file
|
@ -0,0 +1,11 @@
|
||||||
|
diff -rupN a/modules/codec/avcodec/vaapi.c b/modules/codec/avcodec/vaapi.c
|
||||||
|
--- a/modules/codec/avcodec/vaapi.c 2013-01-22 09:51:40.000000000 +0000
|
||||||
|
+++ b/modules/codec/avcodec/vaapi.c 2013-07-27 17:23:37.965202118 +0000
|
||||||
|
@@ -47,6 +47,7 @@
|
||||||
|
|
||||||
|
#include <X11/Xlib.h>
|
||||||
|
#include <va/va_x11.h>
|
||||||
|
+#include <va/va_compat.h>
|
||||||
|
|
||||||
|
typedef struct
|
||||||
|
{
|
Loading…
Reference in a new issue