mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-18 22:54:00 +00:00
added community/xine-ui
This commit is contained in:
parent
5afc37d0a9
commit
79019b8dac
2 changed files with 90 additions and 0 deletions
54
community/xine-ui/0003-Fix-build.patch
Normal file
54
community/xine-ui/0003-Fix-build.patch
Normal file
|
@ -0,0 +1,54 @@
|
||||||
|
From: Torsten Jager <t.jager@gmx.de>
|
||||||
|
Date: Thu, 16 Dec 2021 23:43:10 +0100
|
||||||
|
Subject: Fix build.
|
||||||
|
|
||||||
|
---
|
||||||
|
configure.ac | 6 ++++--
|
||||||
|
src/common/utils.h | 2 +-
|
||||||
|
src/xitk/network.c | 2 ++
|
||||||
|
3 files changed, 7 insertions(+), 3 deletions(-)
|
||||||
|
|
||||||
|
diff --git a/configure.ac b/configure.ac
|
||||||
|
index 58342e0..8d7276e 100644
|
||||||
|
--- a/configure.ac
|
||||||
|
+++ b/configure.ac
|
||||||
|
@@ -600,8 +600,10 @@ int n = my_strlen ("what");
|
||||||
|
])], [have_attr_iaso=yes], [have_attr_iaso=no])
|
||||||
|
AC_MSG_RESULT([$have_attr_iaso])
|
||||||
|
if test x"$have_attr_iaso" = x"yes" ; then
|
||||||
|
- AC_DEFINE([ATTR_INLINE_ALL_STRINGOPS],
|
||||||
|
- [__attribute__ ((__target__ ("inline-all-stringops")))],
|
||||||
|
+ AC_DEFINE([ATTR_INLINE_ALL_STRINGOPS], [__attribute__ ((__target__ ("inline-all-stringops")))],
|
||||||
|
+ [Define this to a function attribute that inlines string handling code])
|
||||||
|
+else
|
||||||
|
+ AC_DEFINE([ATTR_INLINE_ALL_STRINGOPS], [],
|
||||||
|
[Define this to a function attribute that inlines string handling code])
|
||||||
|
fi
|
||||||
|
|
||||||
|
diff --git a/src/common/utils.h b/src/common/utils.h
|
||||||
|
index 8adad40..cfb2628 100644
|
||||||
|
--- a/src/common/utils.h
|
||||||
|
+++ b/src/common/utils.h
|
||||||
|
@@ -21,7 +21,7 @@
|
||||||
|
#ifndef _COMMON_UTILS_H
|
||||||
|
#define _COMMON_UTILS_H
|
||||||
|
|
||||||
|
-#ifndef HAVE_CONFIG_H
|
||||||
|
+#ifndef PACKAGE_NAME
|
||||||
|
#error config.h not included
|
||||||
|
#endif
|
||||||
|
|
||||||
|
diff --git a/src/xitk/network.c b/src/xitk/network.c
|
||||||
|
index 616400e..0fe39c5 100644
|
||||||
|
--- a/src/xitk/network.c
|
||||||
|
+++ b/src/xitk/network.c
|
||||||
|
@@ -34,7 +34,9 @@
|
||||||
|
|
||||||
|
//#warning IMPLEMENT POST SUPPORT
|
||||||
|
|
||||||
|
+#ifdef HAVE_CONFIG_H
|
||||||
|
#include "config.h"
|
||||||
|
+#endif
|
||||||
|
|
||||||
|
#ifdef HAVE_READLINE
|
||||||
|
|
36
community/xine-ui/PKGBUILD
Normal file
36
community/xine-ui/PKGBUILD
Normal file
|
@ -0,0 +1,36 @@
|
||||||
|
# Maintainer : Daniel Bermond <dbermond@archlinux.org>
|
||||||
|
# Contributor: Eric Bélanger
|
||||||
|
|
||||||
|
# ALARM: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||||
|
# - patch from debian to fix ARM FTBFS
|
||||||
|
|
||||||
|
pkgname=xine-ui
|
||||||
|
pkgver=0.99.13
|
||||||
|
pkgrel=2
|
||||||
|
pkgdesc='A free multimedia player'
|
||||||
|
arch=('x86_64')
|
||||||
|
license=('GPL')
|
||||||
|
url='https://www.xine-project.org'
|
||||||
|
depends=('xine-lib' 'aalib' 'curl' 'hicolor-icon-theme' 'libjpeg-turbo' 'libpng'
|
||||||
|
'libx11' 'libxext' 'libxft' 'libxinerama' 'libxv' 'libxxf86vm' 'lirc'
|
||||||
|
'readline')
|
||||||
|
source=("https://downloads.sourceforge.net/xine/${pkgname}-${pkgver}.tar.xz"
|
||||||
|
'0003-Fix-build.patch')
|
||||||
|
sha256sums=('b2382d075c72b1b10039e0e90310cc86c8d910358c53559ed82d3d584201f5c5'
|
||||||
|
'f4a99353034788321c13ac754dd2122dae21d1f902f05e4917036e39d8e8b60b')
|
||||||
|
|
||||||
|
prepare() {
|
||||||
|
cd "${pkgname}-${pkgver}"
|
||||||
|
patch -p1 -i ../0003-Fix-build.patch
|
||||||
|
autoreconf -fi
|
||||||
|
}
|
||||||
|
|
||||||
|
build() {
|
||||||
|
cd "${pkgname}-${pkgver}"
|
||||||
|
./configure --prefix='/usr' --with-x --without-caca
|
||||||
|
make
|
||||||
|
}
|
||||||
|
|
||||||
|
package() {
|
||||||
|
make -C "${pkgname}-${pkgver}" DESTDIR="$pkgdir" install
|
||||||
|
}
|
Loading…
Reference in a new issue