mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
extra/meson to 0.62.0-1
This commit is contained in:
parent
3be2c3fc9f
commit
790368bd22
2 changed files with 20 additions and 11 deletions
|
@ -6,7 +6,7 @@
|
|||
# - disable lto in arch-meson
|
||||
|
||||
pkgname=meson
|
||||
pkgver=0.61.3
|
||||
pkgver=0.62.0
|
||||
pkgrel=1
|
||||
pkgdesc='High productivity build system'
|
||||
url='https://mesonbuild.com/'
|
||||
|
@ -22,9 +22,9 @@ checkdepends=('gcc-objc' 'vala' 'rust' 'gcc-fortran' 'mono' 'boost' 'qt5-base' '
|
|||
source=(https://github.com/mesonbuild/meson/releases/download/${pkgver}/meson-${pkgver}.tar.gz{,.asc}
|
||||
skip-test.diff
|
||||
arch-meson)
|
||||
sha512sums=('955c56cbaeb23a33a5e536eee547312ca5f1122aaa03d839113a2b2bcd9a0486ab24d1783220d9981c29ed9b4bda06a971cb0e21aa9f32d57f6696fa27853da8'
|
||||
sha512sums=('96cbcc9ce731b856a89fa96a3929570627cb87a5f2079d7d087f5a7e7c5c59db15f2ab544f11d128b568dd7f12739617e3fd79d6bcb4e995f9cd5a6f9de9fabb'
|
||||
'SKIP'
|
||||
'5a5cd1b2e12f63eab787e4e102f2bdf2b170f0a7f2675f6f4f8ae5dc8188ccab5f488dcecfbb3ab69e4c70e266d5bf5a8270214c0dc20efcca77bab976f6e38a'
|
||||
'201e1d19d4acedadc0ed38a6ec56b90266cd7caf72db46869282489e5d52be949f7794b53bbf5ccc328ce902a90b8cebe59716ca2b2493eeaef26821e44557dc'
|
||||
'278f5e4de3aa1170d9b4f9f212985d664f44d90ffec727febeeea1ed570046c6469558a5d123a41bf4c2fdf99dbe7832515b06f1ace423c63e2e95ba6d0ef235')
|
||||
validpgpkeys=('19E2D6D9B46D8DAA6288F877C24E631BABB1FE70') # Jussi Pakkanen <jpakkane@gmail.com>
|
||||
|
||||
|
@ -54,7 +54,6 @@ package() {
|
|||
cp -rt "${pkgdir}/usr/share/vim/vimfiles" data/syntax-highlighting/vim/*/
|
||||
|
||||
install -Dt "${pkgdir}/usr/share/bash-completion/completions" -m644 data/shell-completions/bash/*
|
||||
install -Dt "${pkgdir}/usr/share/emacs/site-lisp" -m644 data/syntax-highlighting/emacs/*
|
||||
install -Dt "${pkgdir}/usr/share/zsh/site-functions" -m644 data/shell-completions/zsh/*
|
||||
|
||||
# Arch packaging helper
|
||||
|
|
|
@ -1,10 +1,20 @@
|
|||
unittests/linuxliketests.py | 2 ++
|
||||
1 file changed, 2 insertions(+)
|
||||
|
||||
diff --git c/unittests/linuxliketests.py i/unittests/linuxliketests.py
|
||||
index 594e9f0cc..a2c4f8b8b 100644
|
||||
--- c/unittests/linuxliketests.py
|
||||
+++ i/unittests/linuxliketests.py
|
||||
diff --git i/test cases/linuxlike/13 cmake dependency/meson.build w/test cases/linuxlike/13 cmake dependency/meson.build
|
||||
index 193ad184b..e94ba68ac 100644
|
||||
--- i/test cases/linuxlike/13 cmake dependency/meson.build
|
||||
+++ w/test cases/linuxlike/13 cmake dependency/meson.build
|
||||
@@ -6,6 +6,8 @@ if not find_program('cmake', required: false).found()
|
||||
error('MESON_SKIP_TEST cmake binary not available.')
|
||||
endif
|
||||
|
||||
+error('MESON_SKIP_TEST flaky, see https://github.com/mesonbuild/meson/issues/10104')
|
||||
+
|
||||
# Zlib is probably on all dev machines.
|
||||
|
||||
dep = dependency('ZLIB', version : '>=1.2', method : 'cmake')
|
||||
diff --git i/unittests/linuxliketests.py w/unittests/linuxliketests.py
|
||||
index 79db0b896..12082ce61 100644
|
||||
--- i/unittests/linuxliketests.py
|
||||
+++ w/unittests/linuxliketests.py
|
||||
@@ -343,6 +343,7 @@ class LinuxlikeTests(BasePlatformTests):
|
||||
raise SkipTest('asan not available on Cygwin')
|
||||
if is_openbsd():
|
||||
|
|
Loading…
Reference in a new issue