mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
extra/openjdk6 to 6.b22_1.10.5-1
This commit is contained in:
parent
8793ccb8cc
commit
791b20a477
2 changed files with 248 additions and 26 deletions
|
@ -2,7 +2,7 @@
|
|||
# Maintainer: Andreas Radke <andyrtr@archlinux.org>
|
||||
# Contributor: Jan de Groot <jgc@archlinux.org>
|
||||
|
||||
# ALARM: Kevin Mihelich <kevin@plugapps.com>
|
||||
# PlugApps: Kevin Mihelich <kevin@plugapps.com>
|
||||
# - Run autogen.sh, then configure with --enable-zero, make -j1
|
||||
# - Either remove -Werror from makefiles, or #ifndef ARM in ffi.h
|
||||
# - Fake reporting of total ram if <512MB
|
||||
|
@ -18,12 +18,10 @@ noautobuild=1
|
|||
|
||||
pkgname=('openjdk6')
|
||||
pkgbase="openjdk6"
|
||||
#_date=20100715
|
||||
_javaver=6
|
||||
_icedteaver=1.10
|
||||
_icedteaver=1.10.5
|
||||
_openjdk_version=b22
|
||||
_openjdk_date=28_feb_2011
|
||||
#pkgver=${_javaver}.${_openjdk_version}_0.hg_${_date}
|
||||
pkgver=${_javaver}.${_openjdk_version}_${_icedteaver}
|
||||
pkgrel=1
|
||||
url='http://icedtea.classpath.org'
|
||||
|
@ -31,46 +29,34 @@ arch=('arm')
|
|||
license=('custom')
|
||||
makedepends=('gcc-libs' 'xdg-utils' 'hicolor-icon-theme' 'ca-certificates-java' 'libxtst' 'alsa-lib' 'giflib' 'libxp' 'gtk2'
|
||||
'nspr' 'zlib' 'freetype2' 'libjpeg>=8' 'libx11' 'libcups' 'patch' 'xalan-java' 'libxt' 'nss'
|
||||
'apache-ant' 'autoconf' 'unzip' 'rhino' 'mercurial' 'zip' 'cpio')
|
||||
'apache-ant' 'autoconf' 'unzip' 'rhino' 'mercurial' 'zip' 'cpio' 'openjdk6')
|
||||
options=('!emptydirs') # 'force') # force needed for hg shots
|
||||
source=(http://icedtea.classpath.org/download/source/icedtea6-${_icedteaver}.tar.gz
|
||||
#ftp://ftp.archlinux.org/other/openjdk6/icedtea6-${_date}.tar.xz
|
||||
http://download.java.net/openjdk/jdk6/promoted/${_openjdk_version}/openjdk-6-src-${_openjdk_version}-${_openjdk_date}.tar.gz
|
||||
http://icedtea.classpath.org/download/drops/jaxp144_01.zip
|
||||
https://jax-ws.dev.java.net/files/documents/4202/150724/jdk6-jaxws-b20.zip
|
||||
https://jax-ws.dev.java.net/files/documents/4202/150725/jdk6-jaf-b20.zip
|
||||
http://icedtea.classpath.org/download/drops/jdk6-jaxws-b20.zip
|
||||
http://icedtea.classpath.org/download/drops/jdk6-jaf-b20.zip
|
||||
fix_jdk_cmds_path.diff
|
||||
fix_corba_cmds_path.diff
|
||||
aatext_by_default.diff
|
||||
fontconfig-paths.diff
|
||||
nonreparenting-wm.diff
|
||||
openjdk6.profile
|
||||
openjdk6.profile.csh)
|
||||
openjdk6.profile.csh
|
||||
glibc2_15.diff)
|
||||
noextract=(openjdk-6-src-${_openjdk_version}-${_openjdk_date}.tar.gz)
|
||||
md5sums=('fd3f35e8a8a2ef9a64c035ed66cea06d'
|
||||
md5sums=('e2316f463b5d9f53f8c5c9020f2a7e5a'
|
||||
'2d2bbbb0f9b81f1fec41ec730da8a933'
|
||||
'ef7a8b3624ea904bf584bc46d79b5e75'
|
||||
'91adfd41e6f001add4f92ae31216b1e3'
|
||||
'bc95c133620bd68c161cac9891592901'
|
||||
'5da3e39fa60985576c4f37d1491efbe2'
|
||||
'f7e7a212e50abb56a6ef1a2b1bd27405'
|
||||
'ef60d567c0d9bad111212851220deafd'
|
||||
'ee1afda124d5927345014ab382ef581e'
|
||||
'409812b5675f9678b1c9e1a12a945a9a'
|
||||
'9b4d368f5ee08de248eaf029303a446c'
|
||||
'74c4a7adc782edd087802bf92ae3d6d0'
|
||||
'fdf295e2f186dfa4d308691a3d7ac8c5')
|
||||
|
||||
# source PKGBUILD && mksource
|
||||
mksource() {
|
||||
mkdir /tmp/icedtea6-${_date}
|
||||
pushd /tmp/icedtea6-${_date}
|
||||
#hg -v clone http://icedtea.classpath.org/hg/icedtea6
|
||||
# use specific release branch
|
||||
hg -v clone http://icedtea.classpath.org/hg/release/icedtea6-1.8/
|
||||
rm -rf icedtea6/.hg*
|
||||
tar -cvJf /tmp/icedtea6-${_date}/icedtea6-${_date}.tar.xz *
|
||||
popd
|
||||
}
|
||||
'fdf295e2f186dfa4d308691a3d7ac8c5'
|
||||
'0c8f0a398c88f85e0db44b4417562cf3')
|
||||
|
||||
build() {
|
||||
|
||||
|
@ -90,7 +76,7 @@ build() {
|
|||
|
||||
autoreconf -i
|
||||
|
||||
export DISTRIBUTION_PATCHES="patches/fix_jdk_cmds_path.diff patches/aatext_by_default.diff patches/fontconfig-paths.diff patches/fix_corba_cmds_path.diff patches/nonreparenting-wm.diff"
|
||||
export DISTRIBUTION_PATCHES="patches/fix_jdk_cmds_path.diff patches/aatext_by_default.diff patches/fontconfig-paths.diff patches/fix_corba_cmds_path.diff patches/nonreparenting-wm.diff patches/glibc2_15.diff"
|
||||
|
||||
export ALT_PARALLEL_COMPILE_JOBS="${MAKEFLAGS/-j}"
|
||||
export HOTSPOT_BUILD_JOBS="${ALT_PARALLEL_COMPILE_JOBS}"
|
||||
|
|
236
extra/openjdk6/glibc2_15.diff
Normal file
236
extra/openjdk6/glibc2_15.diff
Normal file
|
@ -0,0 +1,236 @@
|
|||
# HG changeset patch
|
||||
# User never
|
||||
# Date 1319555835 25200
|
||||
# Node ID a6eef545f1a2ceca6aeadf688a965df600ffef28
|
||||
# Parent 2ec638646e86e455978c31a9d47fc0ec271ed926
|
||||
7103224: collision between __LEAF define in interfaceSupport.hpp and /usr/include/sys/cdefs.h with gcc
|
||||
Reviewed-by: never
|
||||
Contributed-by: Omair Majid <omajid@redhat.com>
|
||||
|
||||
diff -r 2ec638646e86 -r a6eef545f1a2 src/share/vm/opto/addnode.cpp
|
||||
--- openjdk/hotspot/src/share/vm/opto/addnode.cpp Tue Oct 25 04:07:20 2011 -0700
|
||||
+++ openjdk/hotspot/src/share/vm/opto/addnode.cpp Tue Oct 25 08:17:15 2011 -0700
|
||||
@@ -34,8 +34,6 @@
|
||||
|
||||
// Portions of code courtesy of Clifford Click
|
||||
|
||||
-#define MAXFLOAT ((float)3.40282346638528860e+38)
|
||||
-
|
||||
// Classic Add functionality. This covers all the usual 'add' behaviors for
|
||||
// an algebraic ring. Add-integer, add-float, add-double, and binary-or are
|
||||
// all inherited from this class. The various identity values are supplied
|
||||
diff -r 2ec638646e86 -r a6eef545f1a2 src/share/vm/prims/jniCheck.cpp
|
||||
--- openjdk/hotspot/src/share/vm/prims/jniCheck.cpp Tue Oct 25 04:07:20 2011 -0700
|
||||
+++ openjdk/hotspot/src/share/vm/prims/jniCheck.cpp Tue Oct 25 08:17:15 2011 -0700
|
||||
@@ -107,7 +107,7 @@
|
||||
if (env != xenv) { \
|
||||
NativeReportJNIFatalError(thr, warn_wrong_jnienv); \
|
||||
} \
|
||||
- __ENTRY(result_type, header, thr)
|
||||
+ VM_ENTRY_BASE(result_type, header, thr)
|
||||
|
||||
|
||||
#define UNCHECKED() (unchecked_jni_NativeInterface)
|
||||
diff -r 2ec638646e86 -r a6eef545f1a2 src/share/vm/prims/jvmtiEnter.xsl
|
||||
--- openjdk/hotspot/src/share/vm/prims/jvmtiEnter.xsl Tue Oct 25 04:07:20 2011 -0700
|
||||
+++ openjdk/hotspot/src/share/vm/prims/jvmtiEnter.xsl Tue Oct 25 08:17:15 2011 -0700
|
||||
@@ -426,7 +426,7 @@
|
||||
<xsl:value-of select="$space"/>
|
||||
<xsl:text>ThreadInVMfromNative __tiv(current_thread);</xsl:text>
|
||||
<xsl:value-of select="$space"/>
|
||||
- <xsl:text>__ENTRY(jvmtiError, </xsl:text>
|
||||
+ <xsl:text>VM_ENTRY_BASE(jvmtiError, </xsl:text>
|
||||
<xsl:apply-templates select="." mode="functionid"/>
|
||||
<xsl:text> , current_thread)</xsl:text>
|
||||
<xsl:value-of select="$space"/>
|
||||
diff -r 2ec638646e86 -r a6eef545f1a2 src/share/vm/prims/jvmtiEnv.cpp
|
||||
--- openjdk/hotspot/src/share/vm/prims/jvmtiEnv.cpp Tue Oct 25 04:07:20 2011 -0700
|
||||
+++ openjdk/hotspot/src/share/vm/prims/jvmtiEnv.cpp Tue Oct 25 08:17:15 2011 -0700
|
||||
@@ -173,7 +173,7 @@
|
||||
// from native so as to resolve the jthread.
|
||||
|
||||
ThreadInVMfromNative __tiv(current_thread);
|
||||
- __ENTRY(jvmtiError, JvmtiEnv::GetThreadLocalStorage , current_thread)
|
||||
+ VM_ENTRY_BASE(jvmtiError, JvmtiEnv::GetThreadLocalStorage , current_thread)
|
||||
debug_only(VMNativeEntryWrapper __vew;)
|
||||
|
||||
oop thread_oop = JNIHandles::resolve_external_guard(thread);
|
||||
diff -r 2ec638646e86 -r a6eef545f1a2 src/share/vm/prims/jvmtiExport.cpp
|
||||
--- openjdk/hotspot/src/share/vm/prims/jvmtiExport.cpp Tue Oct 25 04:07:20 2011 -0700
|
||||
+++ openjdk/hotspot/src/share/vm/prims/jvmtiExport.cpp Tue Oct 25 08:17:15 2011 -0700
|
||||
@@ -373,7 +373,7 @@
|
||||
JavaThread* current_thread = (JavaThread*) ThreadLocalStorage::thread();
|
||||
// transition code: native to VM
|
||||
ThreadInVMfromNative __tiv(current_thread);
|
||||
- __ENTRY(jvmtiEnv*, JvmtiExport::get_jvmti_interface, current_thread)
|
||||
+ VM_ENTRY_BASE(jvmtiEnv*, JvmtiExport::get_jvmti_interface, current_thread)
|
||||
debug_only(VMNativeEntryWrapper __vew;)
|
||||
|
||||
JvmtiEnv *jvmti_env = JvmtiEnv::create_a_jvmti(version);
|
||||
diff -r 2ec638646e86 -r a6eef545f1a2 src/share/vm/runtime/interfaceSupport.hpp
|
||||
--- openjdk/hotspot/src/share/vm/runtime/interfaceSupport.hpp Tue Oct 25 04:07:20 2011 -0700
|
||||
+++ openjdk/hotspot/src/share/vm/runtime/interfaceSupport.hpp Tue Oct 25 08:17:15 2011 -0700
|
||||
@@ -72,9 +72,9 @@
|
||||
}
|
||||
};
|
||||
|
||||
-// InterfaceSupport provides functionality used by the __LEAF and __ENTRY
|
||||
-// macros. These macros are used to guard entry points into the VM and
|
||||
-// perform checks upon leave of the VM.
|
||||
+// InterfaceSupport provides functionality used by the VM_LEAF_BASE and
|
||||
+// VM_ENTRY_BASE macros. These macros are used to guard entry points into
|
||||
+// the VM and perform checks upon leave of the VM.
|
||||
|
||||
|
||||
class InterfaceSupport: AllStatic {
|
||||
@@ -433,7 +433,7 @@
|
||||
|
||||
// LEAF routines do not lock, GC or throw exceptions
|
||||
|
||||
-#define __LEAF(result_type, header) \
|
||||
+#define VM_LEAF_BASE(result_type, header) \
|
||||
TRACE_CALL(result_type, header) \
|
||||
debug_only(NoHandleMark __hm;) \
|
||||
/* begin of body */
|
||||
@@ -441,7 +441,7 @@
|
||||
|
||||
// ENTRY routines may lock, GC and throw exceptions
|
||||
|
||||
-#define __ENTRY(result_type, header, thread) \
|
||||
+#define VM_ENTRY_BASE(result_type, header, thread) \
|
||||
TRACE_CALL(result_type, header) \
|
||||
HandleMarkCleaner __hm(thread); \
|
||||
Thread* THREAD = thread; \
|
||||
@@ -450,7 +450,7 @@
|
||||
|
||||
// QUICK_ENTRY routines behave like ENTRY but without a handle mark
|
||||
|
||||
-#define __QUICK_ENTRY(result_type, header, thread) \
|
||||
+#define VM_QUICK_ENTRY_BASE(result_type, header, thread) \
|
||||
TRACE_CALL(result_type, header) \
|
||||
debug_only(NoHandleMark __hm;) \
|
||||
Thread* THREAD = thread; \
|
||||
@@ -463,20 +463,20 @@
|
||||
#define IRT_ENTRY(result_type, header) \
|
||||
result_type header { \
|
||||
ThreadInVMfromJava __tiv(thread); \
|
||||
- __ENTRY(result_type, header, thread) \
|
||||
+ VM_ENTRY_BASE(result_type, header, thread) \
|
||||
debug_only(VMEntryWrapper __vew;)
|
||||
|
||||
|
||||
#define IRT_LEAF(result_type, header) \
|
||||
result_type header { \
|
||||
- __LEAF(result_type, header) \
|
||||
+ VM_LEAF_BASE(result_type, header) \
|
||||
debug_only(No_Safepoint_Verifier __nspv(true);)
|
||||
|
||||
|
||||
#define IRT_ENTRY_NO_ASYNC(result_type, header) \
|
||||
result_type header { \
|
||||
ThreadInVMfromJavaNoAsyncException __tiv(thread); \
|
||||
- __ENTRY(result_type, header, thread) \
|
||||
+ VM_ENTRY_BASE(result_type, header, thread) \
|
||||
debug_only(VMEntryWrapper __vew;)
|
||||
|
||||
// Another special case for nmethod_entry_point so the nmethod that the
|
||||
@@ -487,7 +487,7 @@
|
||||
result_type header { \
|
||||
nmethodLocker _nmlock(nm); \
|
||||
ThreadInVMfromJavaNoAsyncException __tiv(thread); \
|
||||
- __ENTRY(result_type, header, thread)
|
||||
+ VM_ENTRY_BASE(result_type, header, thread)
|
||||
|
||||
#define IRT_END }
|
||||
|
||||
@@ -497,20 +497,20 @@
|
||||
#define JRT_ENTRY(result_type, header) \
|
||||
result_type header { \
|
||||
ThreadInVMfromJava __tiv(thread); \
|
||||
- __ENTRY(result_type, header, thread) \
|
||||
+ VM_ENTRY_BASE(result_type, header, thread) \
|
||||
debug_only(VMEntryWrapper __vew;)
|
||||
|
||||
|
||||
#define JRT_LEAF(result_type, header) \
|
||||
result_type header { \
|
||||
- __LEAF(result_type, header) \
|
||||
+ VM_LEAF_BASE(result_type, header) \
|
||||
debug_only(JRT_Leaf_Verifier __jlv;)
|
||||
|
||||
|
||||
#define JRT_ENTRY_NO_ASYNC(result_type, header) \
|
||||
result_type header { \
|
||||
ThreadInVMfromJavaNoAsyncException __tiv(thread); \
|
||||
- __ENTRY(result_type, header, thread) \
|
||||
+ VM_ENTRY_BASE(result_type, header, thread) \
|
||||
debug_only(VMEntryWrapper __vew;)
|
||||
|
||||
// Same as JRT Entry but allows for return value after the safepoint
|
||||
@@ -543,11 +543,11 @@
|
||||
assert( !VerifyJNIEnvThread || (thread == Thread::current()), "JNIEnv is only valid in same thread"); \
|
||||
ThreadInVMfromNative __tiv(thread); \
|
||||
debug_only(VMNativeEntryWrapper __vew;) \
|
||||
- __ENTRY(result_type, header, thread)
|
||||
+ VM_ENTRY_BASE(result_type, header, thread)
|
||||
|
||||
|
||||
// Ensure that the VMNativeEntryWrapper constructor, which can cause
|
||||
-// a GC, is called outside the NoHandleMark (set via __QUICK_ENTRY).
|
||||
+// a GC, is called outside the NoHandleMark (set via VM_QUICK_ENTRY_BASE).
|
||||
#define JNI_QUICK_ENTRY(result_type, header) \
|
||||
extern "C" { \
|
||||
result_type JNICALL header { \
|
||||
@@ -555,7 +555,7 @@
|
||||
assert( !VerifyJNIEnvThread || (thread == Thread::current()), "JNIEnv is only valid in same thread"); \
|
||||
ThreadInVMfromNative __tiv(thread); \
|
||||
debug_only(VMNativeEntryWrapper __vew;) \
|
||||
- __QUICK_ENTRY(result_type, header, thread)
|
||||
+ VM_QUICK_ENTRY_BASE(result_type, header, thread)
|
||||
|
||||
|
||||
#define JNI_LEAF(result_type, header) \
|
||||
@@ -563,7 +563,7 @@
|
||||
result_type JNICALL header { \
|
||||
JavaThread* thread=JavaThread::thread_from_jni_environment(env); \
|
||||
assert( !VerifyJNIEnvThread || (thread == Thread::current()), "JNIEnv is only valid in same thread"); \
|
||||
- __LEAF(result_type, header)
|
||||
+ VM_LEAF_BASE(result_type, header)
|
||||
|
||||
|
||||
// Close the routine and the extern "C"
|
||||
@@ -579,7 +579,7 @@
|
||||
JavaThread* thread=JavaThread::thread_from_jni_environment(env); \
|
||||
ThreadInVMfromNative __tiv(thread); \
|
||||
debug_only(VMNativeEntryWrapper __vew;) \
|
||||
- __ENTRY(result_type, header, thread)
|
||||
+ VM_ENTRY_BASE(result_type, header, thread)
|
||||
|
||||
|
||||
#define JVM_ENTRY_NO_ENV(result_type, header) \
|
||||
@@ -588,7 +588,7 @@
|
||||
JavaThread* thread = (JavaThread*)ThreadLocalStorage::thread(); \
|
||||
ThreadInVMfromNative __tiv(thread); \
|
||||
debug_only(VMNativeEntryWrapper __vew;) \
|
||||
- __ENTRY(result_type, header, thread)
|
||||
+ VM_ENTRY_BASE(result_type, header, thread)
|
||||
|
||||
|
||||
#define JVM_QUICK_ENTRY(result_type, header) \
|
||||
@@ -597,14 +597,14 @@
|
||||
JavaThread* thread=JavaThread::thread_from_jni_environment(env); \
|
||||
ThreadInVMfromNative __tiv(thread); \
|
||||
debug_only(VMNativeEntryWrapper __vew;) \
|
||||
- __QUICK_ENTRY(result_type, header, thread)
|
||||
+ VM_QUICK_ENTRY_BASE(result_type, header, thread)
|
||||
|
||||
|
||||
#define JVM_LEAF(result_type, header) \
|
||||
extern "C" { \
|
||||
result_type JNICALL header { \
|
||||
VM_Exit::block_if_vm_exited(); \
|
||||
- __LEAF(result_type, header)
|
||||
+ VM_LEAF_BASE(result_type, header)
|
||||
|
||||
|
||||
#define JVM_END } }
|
Loading…
Reference in a new issue