community/gdc fix

This commit is contained in:
Kevin Mihelich 2015-06-23 04:54:20 +00:00
parent d2ce24720b
commit 797783a737
2 changed files with 12 additions and 11 deletions

View file

@ -7,6 +7,9 @@
# - specifid build host
# - replaced bugurl with our GitHub issue page
# ALARM: Kevin Mihelich <kevin@archlinuxarm.org>
# - TEMPORARY: specify current gdc head commit, adjusted system_zlib.diff
pkgname=('gdc' 'libgphobos-devel')
pkgver=5.1.0
pkgrel=3
@ -17,18 +20,16 @@ makedepends=('binutils>=2.23' 'git' 'gcc' 'make' 'perl' 'automake')
options=('!emptydirs' '!buildflags')
source=(
"ftp://gcc.gnu.org/pub/gcc/releases/gcc-${pkgver}/gcc-${pkgver}.tar.bz2"
"gdc::git://github.com/D-Programming-GDC/GDC.git#tag=v2.066.1_gcc5"
"gdc::git://github.com/D-Programming-GDC/GDC.git#commit=42c4f6c"
"git+https://github.com/D-Programming-GDC/GDMD.git"
"folders.diff"
"system_zlib.diff"
)
sha256sums=(
'b7dafdf89cbb0e20333dbf5b5349319ae06e3d1a30bf3515b5488f7e89dca5ad'
'SKIP'
'SKIP'
'ea5c80a28026393bd4627485602660a4a01d9fbc65299e95e768013e197bad20'
'1bf81cde6a7bad096f76db2f20ad8ab2801cd0ab2dd2fa0219503073e8dae480'
)
sha256sums=('b7dafdf89cbb0e20333dbf5b5349319ae06e3d1a30bf3515b5488f7e89dca5ad'
'SKIP'
'SKIP'
'ea5c80a28026393bd4627485602660a4a01d9fbc65299e95e768013e197bad20'
'79b618e5223bc145da360bee8cf3e71b86baa15c4686815e418ae8e3110df243')
groups=('dlang' 'dlang-gdc')
conflicts=('gdc1-bin' 'gdc1-hg' 'gdc-git')

View file

@ -1,7 +1,7 @@
diff --git a/gcc/d/d-spec.cc b/gcc/d/d-spec.cc
diff --git a/gcc/d/d-spec.c b/gcc/d/d-spec.c
index a43cb34..e4bb527 100644
--- a/gcc/d/d-spec.cc
+++ b/gcc/d/d-spec.cc
--- a/gcc/d/d-spec.c
+++ b/gcc/d/d-spec.c
@@ -96,7 +96,7 @@ lang_specific_driver (cl_decoded_option **in_decoded_options,
/* The number of arguments being added to what's in argv, other than
libraries. We use this to track the number of times we've inserted