mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-01-17 23:34:07 +00:00
added community/libcec
This commit is contained in:
parent
8e95008cda
commit
7984266906
3 changed files with 1424 additions and 0 deletions
54
community/libcec/PKGBUILD
Normal file
54
community/libcec/PKGBUILD
Normal file
|
@ -0,0 +1,54 @@
|
|||
# $Id$
|
||||
# Maintainer: BlackIkeEagle <ike DOT devolder AT gmail DOT com>
|
||||
# Contributor: Philippe Cherel <philippe.cherel@mayenne.org>
|
||||
|
||||
# ALARM: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
# - Exynos and RPi support
|
||||
|
||||
pkgname=libcec
|
||||
pkgver=2.1.4
|
||||
pkgrel=1.1
|
||||
pkgdesc="Pulse-Eight's libcec for the Pulse-Eight USB-CEC adapter"
|
||||
arch=('i686' 'x86_64')
|
||||
url="http://libcec.pulse-eight.com/"
|
||||
license=('GPL')
|
||||
depends=('udev' 'lockdev')
|
||||
source=("$pkgname-$pkgver.tar.gz::https://github.com/Pulse-Eight/$pkgname/archive/$pkgname-$pkgver.tar.gz"
|
||||
'exynos.patch'
|
||||
'fix-bool_t.patch')
|
||||
sha256sums=('79bef5232a5c9ab987ca3a2d4bfcaeb80480fd26f502dc1a996fe845d90fe147'
|
||||
'ae746a22142aec24b4a5cfffa3d42c97a9be5d8a22f7215bf217934b9d1ce9d1'
|
||||
'ab695a6638d3a4009c4f7f76e2b84b98a7f03c0332f5e1038e53ae804ea12821')
|
||||
|
||||
if [[ $CARCH = 'armv6h' ]]; then
|
||||
depends+=('raspberrypi-firmware')
|
||||
replaces=('libcec-rpi')
|
||||
provides=('libcec-rpi')
|
||||
fi
|
||||
|
||||
prepare() {
|
||||
cd "$pkgname-$pkgname-$pkgver"
|
||||
|
||||
patch -Np1 -i ../exynos.patch
|
||||
patch -Np1 -i ../fix-bool_t.patch
|
||||
}
|
||||
|
||||
build() {
|
||||
cd "$pkgname-$pkgname-$pkgver"
|
||||
autoreconf -vif
|
||||
|
||||
if [[ $CARCH == 'armv7h' ]]; then
|
||||
CONFIG='--enable-exynos'
|
||||
elif [[ $CARCH == 'armv6h' ]]; then
|
||||
CONFIG='--enable-rpi --with-rpi-include-path=/opt/vc/include --with-rpi-lib-path=/opt/vc/lib'
|
||||
unset LDFLAGS
|
||||
fi
|
||||
|
||||
./configure --prefix=/usr $CONFIG
|
||||
make
|
||||
}
|
||||
|
||||
package() {
|
||||
cd "$pkgname-$pkgname-$pkgver"
|
||||
make DESTDIR="$pkgdir" install
|
||||
}
|
1337
community/libcec/exynos.patch
Normal file
1337
community/libcec/exynos.patch
Normal file
File diff suppressed because it is too large
Load diff
33
community/libcec/fix-bool_t.patch
Normal file
33
community/libcec/fix-bool_t.patch
Normal file
|
@ -0,0 +1,33 @@
|
|||
diff -urN a/src/lib/adapter/RPi/RPiCECAdapterCommunication.cpp b/src/lib/adapter/RPi/RPiCECAdapterCommunication.cpp
|
||||
--- a/src/lib/adapter/RPi/RPiCECAdapterCommunication.cpp 2013-12-13 08:03:33.000000000 -0700
|
||||
+++ b/src/lib/adapter/RPi/RPiCECAdapterCommunication.cpp 2014-01-09 13:51:12.250929575 -0700
|
||||
@@ -299,7 +299,7 @@
|
||||
if (bStartListening)
|
||||
{
|
||||
// enable passive mode
|
||||
- vc_cec_set_passive(true);
|
||||
+ vc_cec_set_passive((bool_t)true);
|
||||
|
||||
// register the callbacks
|
||||
vc_cec_register_callback(rpi_cec_callback, (void*)this);
|
||||
@@ -358,7 +358,7 @@
|
||||
UnregisterLogicalAddress();
|
||||
|
||||
// disable passive mode
|
||||
- vc_cec_set_passive(false);
|
||||
+ vc_cec_set_passive((bool_t)false);
|
||||
|
||||
if (!g_bHostInited)
|
||||
{
|
||||
diff -urN a/src/lib/adapter/RPi/RPiCECAdapterMessageQueue.cpp b/src/lib/adapter/RPi/RPiCECAdapterMessageQueue.cpp
|
||||
--- a/src/lib/adapter/RPi/RPiCECAdapterMessageQueue.cpp 2013-12-13 08:03:33.000000000 -0700
|
||||
+++ b/src/lib/adapter/RPi/RPiCECAdapterMessageQueue.cpp 2014-01-09 13:51:12.255929509 -0700
|
||||
@@ -182,7 +182,7 @@
|
||||
LIB_CEC->AddLog(CEC_LOG_DEBUG, "sending data: %s", strDump.c_str());
|
||||
#endif
|
||||
|
||||
- int iReturn = vc_cec_send_message((uint32_t)command.destination, (uint8_t*)&payload, iLength, bIsReply);
|
||||
+ int iReturn = vc_cec_send_message((uint32_t)command.destination, (uint8_t*)&payload, iLength, (bool_t)bIsReply);
|
||||
#endif
|
||||
|
||||
if (iReturn != VCHIQ_SUCCESS)
|
Loading…
Reference in a new issue