mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-02-16 23:57:11 +00:00
added community/clementine
This commit is contained in:
parent
2d1a06e5af
commit
7995ec67c4
5 changed files with 213 additions and 0 deletions
74
community/clementine/PKGBUILD
Normal file
74
community/clementine/PKGBUILD
Normal file
|
@ -0,0 +1,74 @@
|
|||
# $Id$
|
||||
# Maintainer: Maxime Gauduin <alucryd@archlinux.org>
|
||||
# Contributor: Stéphane Gaudreault <stephane@archlinux.org>
|
||||
# Contributor: BlackEagle <ike.devolder@gmail.com>
|
||||
# Contributor: Dany Martineau <dany.luc.martineau@gmail.com>
|
||||
|
||||
# ALARM: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
# - fix fPIC on AArch64
|
||||
|
||||
pkgname=clementine
|
||||
pkgver=1.3.1
|
||||
pkgrel=14
|
||||
pkgdesc='A modern music player and library organizer'
|
||||
url='http://www.clementine-player.org/'
|
||||
license=('GPL')
|
||||
arch=('x86_64')
|
||||
depends=('chromaprint' 'crypto++' 'fftw' 'gcc-libs' 'glew' 'glib2' 'glibc'
|
||||
'gst-plugins-base-libs' 'gstreamer' 'libcdio' 'libechonest' 'libgl'
|
||||
'libgpod' 'liblastfm' 'libmtp' 'libpulse' 'libx11' 'protobuf' 'qjson'
|
||||
'qt4' 'sqlite' 'taglib' 'zlib')
|
||||
makedepends=('boost' 'cmake' 'mesa' 'sparsehash')
|
||||
optdepends=('gst-plugins-base: "Base" plugin libraries'
|
||||
'gst-plugins-good: "Good" plugin libraries'
|
||||
'gst-plugins-bad: "Bad" plugin libraries'
|
||||
'gst-plugins-ugly: "Ugly" plugin libraries'
|
||||
'gst-libav: Libav plugin'
|
||||
'gvfs: Various devices support')
|
||||
source=("clementine-${pkgver}.tar.gz::https://github.com/clementine-player/Clementine/archive/${pkgver}.tar.gz"
|
||||
'clementine-gcc6.patch'
|
||||
'add-missing-functional-includes-5630.patch'
|
||||
'clementine-1.3.1-chromaprint-1.4.0.patch'
|
||||
'clementine-cryptopp6.patch')
|
||||
sha256sums=('f885931a9ab7c88607d07b50c64fcce46fc05f13dd2c0a04188c94eff938f37c'
|
||||
'05bd4dc0138eed084332fa1a688a96858418731f337f54e0d8ab0853123f40ee'
|
||||
'213a1c2eb3f3c1d2904ed855ad851c10705d04cfa20b36b843b60003469fdc1a'
|
||||
'4cc9c9df599df4a595c6acf4e129a54296c0a8e537627435e3df14e1e95447b0'
|
||||
'e9c09dca76ed8fae2ecb089571396c9293f546871fb2f27cc37010dd5cba9e46')
|
||||
|
||||
prepare() {
|
||||
cd Clementine-${pkgver}
|
||||
|
||||
# Fix build with GCC 6
|
||||
patch -p1 -i ../clementine-gcc6.patch
|
||||
# https://github.com/clementine-player/Clementine/pull/5630
|
||||
patch -p1 -i ../add-missing-functional-includes-5630.patch
|
||||
# Fix build with chromaprint 1.4.0
|
||||
patch -p1 -i ../clementine-1.3.1-chromaprint-1.4.0.patch
|
||||
# Fix build with crypto++ 6.0.0 due to https://github.com/weidai11/cryptopp/issues/442
|
||||
patch -p1 -i ../clementine-cryptopp6.patch
|
||||
|
||||
[[ $CARCH == "aarch64" ]] && sed -i 's/fpic/fPIC/' 3rdparty/vreen/vreen/cmake/CommonUtils.cmake
|
||||
|
||||
if [[ -d build ]]; then
|
||||
rm -rf build
|
||||
fi
|
||||
mkdir build
|
||||
}
|
||||
|
||||
build() {
|
||||
cd Clementine-${pkgver}/build
|
||||
|
||||
cmake .. \
|
||||
-DCMAKE_BUILD_TYPE='Release' \
|
||||
-DCMAKE_INSTALL_PREFIX='/usr'
|
||||
make
|
||||
}
|
||||
|
||||
package() {
|
||||
cd Clementine-${pkgver}/build
|
||||
|
||||
make DESTDIR="${pkgdir}" install
|
||||
}
|
||||
|
||||
# vim: ts=2 sw=2 et:
|
|
@ -0,0 +1,51 @@
|
|||
From 8a6cc8b5069265e1e92e22def985e22c5955e503 Mon Sep 17 00:00:00 2001
|
||||
From: Morris Hafner <mmha@users.noreply.github.com>
|
||||
Date: Mon, 13 Feb 2017 17:46:46 +0100
|
||||
Subject: [PATCH] Add missing <functional> includes (#5630)
|
||||
|
||||
---
|
||||
src/core/mergedproxymodel.cpp | 1 +
|
||||
src/devices/giolister.cpp | 1 +
|
||||
src/library/groupbydialog.cpp | 2 ++
|
||||
3 files changed, 4 insertions(+)
|
||||
|
||||
diff --git a/src/core/mergedproxymodel.cpp b/src/core/mergedproxymodel.cpp
|
||||
index 56217f6fd..8c210d391 100644
|
||||
--- a/src/core/mergedproxymodel.cpp
|
||||
+++ b/src/core/mergedproxymodel.cpp
|
||||
@@ -23,6 +23,7 @@
|
||||
|
||||
#include <QStringList>
|
||||
|
||||
+#include <functional>
|
||||
#include <limits>
|
||||
|
||||
// boost::multi_index still relies on these being in the global namespace.
|
||||
diff --git a/src/devices/giolister.cpp b/src/devices/giolister.cpp
|
||||
index aa3bddb34..5f63ef248 100644
|
||||
--- a/src/devices/giolister.cpp
|
||||
+++ b/src/devices/giolister.cpp
|
||||
@@ -17,6 +17,7 @@
|
||||
|
||||
#include "config.h"
|
||||
|
||||
+#include <functional>
|
||||
#include <memory>
|
||||
|
||||
#include <QFile>
|
||||
diff --git a/src/library/groupbydialog.cpp b/src/library/groupbydialog.cpp
|
||||
index 5efdc9f36..e5f711b34 100644
|
||||
--- a/src/library/groupbydialog.cpp
|
||||
+++ b/src/library/groupbydialog.cpp
|
||||
@@ -20,6 +20,8 @@
|
||||
|
||||
#include <QPushButton>
|
||||
|
||||
+#include <functional>
|
||||
+
|
||||
// boost::multi_index still relies on these being in the global namespace.
|
||||
using std::placeholders::_1;
|
||||
using std::placeholders::_2;
|
||||
--
|
||||
2.13.4
|
||||
|
|
@ -0,0 +1,41 @@
|
|||
From ded312685735fc266d4154d355286eeb86db3bcd Mon Sep 17 00:00:00 2001
|
||||
From: Chocobozzz <florian.bigard@gmail.com>
|
||||
Date: Thu, 8 Dec 2016 23:12:17 +0100
|
||||
Subject: [PATCH] Add compatibility with chromaprint >= 1.4
|
||||
|
||||
---
|
||||
src/musicbrainz/chromaprinter.cpp | 14 +++++++++++---
|
||||
1 file changed, 11 insertions(+), 3 deletions(-)
|
||||
|
||||
diff --git a/src/musicbrainz/chromaprinter.cpp b/src/musicbrainz/chromaprinter.cpp
|
||||
index 9579b62ae..c7ad99e2e 100644
|
||||
--- a/src/musicbrainz/chromaprinter.cpp
|
||||
+++ b/src/musicbrainz/chromaprinter.cpp
|
||||
@@ -143,16 +143,24 @@ QString Chromaprinter::CreateFingerprint() {
|
||||
ChromaprintContext* chromaprint =
|
||||
chromaprint_new(CHROMAPRINT_ALGORITHM_DEFAULT);
|
||||
chromaprint_start(chromaprint, kDecodeRate, kDecodeChannels);
|
||||
- chromaprint_feed(chromaprint, reinterpret_cast<void*>(data.data()),
|
||||
+ chromaprint_feed(chromaprint, reinterpret_cast<int16_t *>(data.data()),
|
||||
data.size() / 2);
|
||||
chromaprint_finish(chromaprint);
|
||||
|
||||
- void* fprint = nullptr;
|
||||
int size = 0;
|
||||
+
|
||||
+#if CHROMAPRINT_VERSION_MAJOR >= 1 && CHROMAPRINT_VERSION_MINOR >= 4
|
||||
+ u_int32_t *fprint = nullptr;
|
||||
+ char *encoded = nullptr;
|
||||
+#else
|
||||
+ void *fprint = nullptr;
|
||||
+ void *encoded = nullptr;
|
||||
+#endif
|
||||
+
|
||||
int ret = chromaprint_get_raw_fingerprint(chromaprint, &fprint, &size);
|
||||
+
|
||||
QByteArray fingerprint;
|
||||
if (ret == 1) {
|
||||
- void* encoded = nullptr;
|
||||
int encoded_size = 0;
|
||||
chromaprint_encode_fingerprint(fprint, size, CHROMAPRINT_ALGORITHM_DEFAULT,
|
||||
&encoded, &encoded_size, 1);
|
25
community/clementine/clementine-cryptopp6.patch
Normal file
25
community/clementine/clementine-cryptopp6.patch
Normal file
|
@ -0,0 +1,25 @@
|
|||
diff --git a/src/internet/spotify/spotifyblobdownloader.cpp b/src/internet/spotify/spotifyblobdownloader.cpp
|
||||
index e34577f5d..045aeeb8a 100644
|
||||
--- a/src/internet/spotify/spotifyblobdownloader.cpp
|
||||
+++ b/src/internet/spotify/spotifyblobdownloader.cpp
|
||||
@@ -189,7 +189,7 @@ bool SpotifyBlobDownloader::CheckSignature(
|
||||
|
||||
try {
|
||||
CryptoPP::ByteQueue bytes;
|
||||
- bytes.Put(reinterpret_cast<const byte*>(public_key_data.constData()),
|
||||
+ bytes.Put(reinterpret_cast<const CryptoPP::byte*>(public_key_data.constData()),
|
||||
public_key_data.size());
|
||||
bytes.MessageEnd();
|
||||
|
||||
@@ -204,9 +204,9 @@ bool SpotifyBlobDownloader::CheckSignature(
|
||||
actual_filename.remove(kSignatureSuffix);
|
||||
|
||||
const bool result = verifier.VerifyMessage(
|
||||
- reinterpret_cast<const byte*>(file_data[actual_filename].constData()),
|
||||
+ reinterpret_cast<const CryptoPP::byte*>(file_data[actual_filename].constData()),
|
||||
file_data[actual_filename].size(),
|
||||
- reinterpret_cast<const byte*>(
|
||||
+ reinterpret_cast<const CryptoPP::byte*>(
|
||||
file_data[signature_filename].constData()),
|
||||
file_data[signature_filename].size());
|
||||
qLog(Debug) << "Verifying" << actual_filename << "against"
|
22
community/clementine/clementine-gcc6.patch
Normal file
22
community/clementine/clementine-gcc6.patch
Normal file
|
@ -0,0 +1,22 @@
|
|||
From e31278c05666f8ae0e819bd831c65e8766ba2679 Mon Sep 17 00:00:00 2001
|
||||
From: Bigard Florian <florian.bigard@gmail.com>
|
||||
Date: Mon, 9 May 2016 11:55:34 +0200
|
||||
Subject: [PATCH] Fix projectm compilation with GCC 6 (#5371)
|
||||
|
||||
---
|
||||
3rdparty/libprojectm/CMakeLists.txt | 2 ++
|
||||
1 file changed, 2 insertions(+)
|
||||
|
||||
diff --git a/3rdparty/libprojectm/CMakeLists.txt b/3rdparty/libprojectm/CMakeLists.txt
|
||||
index e6287f176..0ef785c49 100644
|
||||
--- a/3rdparty/libprojectm/CMakeLists.txt
|
||||
+++ b/3rdparty/libprojectm/CMakeLists.txt
|
||||
@@ -24,6 +24,8 @@ set(BUILD_PROJECTM_STATIC ON)
|
||||
set(DISABLE_NATIVE_PRESETS ON)
|
||||
set(DISABLE_MILKDROP_PRESETS OFF)
|
||||
|
||||
+set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -std=gnu++98")
|
||||
+
|
||||
if(DISABLE_NATIVE_PRESETS)
|
||||
ADD_DEFINITIONS(-DDISABLE_NATIVE_PRESETS)
|
||||
endif(DISABLE_NATIVE_PRESETS)
|
Loading…
Reference in a new issue