aur/python2-rtslib to 2.1-3

This commit is contained in:
Kevin Mihelich 2012-04-15 13:09:31 -04:00
parent 8b3e9e1b61
commit 799962d8b9
2 changed files with 17 additions and 24 deletions

View file

@ -1,27 +1,34 @@
# Contributor: Johannes Dewender arch at JonnyJD dot net
# Contributor: Kevin Mihelich <kevin@plugapps.com>
plugrel=1
pkgname=python2-rtslib
_pkgname=rtslib
pkgver=2.1
pkgrel=2
pkgrel=3
epoch=
pkgdesc="RisingTide Systems generic SCSI target API in python"
arch=('any')
url="http://www.risingtidesystems.com/git/?p=rtslib.git;a=summary"
license=('AGPL3')
depends=('python2-ipaddr' 'python2-netifaces' 'python-configobj')
source=("http://archlinuxarm.org/builder/src/$_pkgname-$pkgver.tgz"
'gz-modules.patch')
md5sums=('144863bf1e74e60fa66794950d28edde'
'c0cf6b8ca9c2f12f701e99c011d2ba03')
depends=('python2-ipaddr' 'python-netifaces' 'python-configobj')
provides=()
conflicts=()
backup=()
options=()
install=
source=('gz-modules-upstream.patch')
md5sums=('4add05b9cbd12258dc993f19728fbafe')
_pkgname=rtslib
build() {
cd "$srcdir"
patch -p0 < gz-modules.patch
if [ ! -e "$_pkgname-$pkgver.tgz" ]; then
wget "http://www.risingtidesystems.com/git/?p=$_pkgname.git;a=snapshot;h=c4ba14ff21f68e56d6a3a227a0220d1a6b6df958;sf=tgz" -O "$_pkgname-$pkgver.tgz"
fi
bsdtar -xf "$srcdir/$_pkgname-$pkgver.tgz"
cd "$srcdir/$_pkgname"
patch -p1 < ../gz-modules-upstream.patch
python2 setup.py build
}

View file

@ -1,14 +0,0 @@
also find gzipped modules
--- rtslib/rtslib/utils.py 2011-10-06 00:46:09.000000000 +0200
+++ rtslib/rtslib/utils.py 2011-10-06 01:36:26.000000000 +0200
@@ -604,8 +604,8 @@
'''
kver = os.uname()[2]
depfile = "/lib/modules/%s/modules.dep" % kver
- return [module.split(".")[0] for module in
- re.findall(r"[a-zA-Z0-9_-]+\.ko:", fread(depfile))]
+ return [module[0] for module in
+ re.findall(r"([a-zA-Z0-9_-]+)\.ko(.gz)?:", fread(depfile))]
def list_loaded_kernel_modules():
'''