mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-01-17 23:34:07 +00:00
community/blender to 2.79.b.git3.32432d91-1
This commit is contained in:
parent
6a75e5b9ea
commit
79c3b05153
4 changed files with 240 additions and 12 deletions
|
@ -6,7 +6,6 @@
|
|||
# ALARM: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
# - remove makedepend, optdepend on cuda
|
||||
# - set -DWITH_CYCLES_CUDA_BINARIES=OFF, -DWITH_CYCLES=OFF, -DWITH_RAYOPTIMIZATION=OFF
|
||||
# - cherry-pick upstream commit to fix ARM FTBFS
|
||||
|
||||
buildarch=12
|
||||
|
||||
|
@ -19,12 +18,12 @@ buildarch=12
|
|||
# unreasonable.
|
||||
|
||||
# _gittag=v2.79b
|
||||
_gitcommit=0385b33f0b3e389ea2a82c4b6bb181c684f0511a
|
||||
_gitcommit=32432d91bbec558cbd88e54aece61b0d641c1761
|
||||
|
||||
pkgname=blender
|
||||
pkgver=2.79.b
|
||||
[[ -n $_gitcommit ]] && pkgver=${pkgver}.git2.${_gitcommit:0:8}
|
||||
pkgrel=16
|
||||
[[ -n $_gitcommit ]] && pkgver=${pkgver}.git3.${_gitcommit:0:8}
|
||||
pkgrel=1
|
||||
epoch=17
|
||||
pkgdesc="A fully integrated 3D graphics creation suite"
|
||||
arch=('x86_64')
|
||||
|
@ -41,7 +40,11 @@ source=("git://git.blender.org/blender-addons.git"
|
|||
"git://git.blender.org/blender-addons-contrib.git"
|
||||
"git://git.blender.org/blender-translations.git"
|
||||
"git://git.blender.org/blender-dev-tools.git"
|
||||
"git://git.blender.org/scons.git")
|
||||
"git://git.blender.org/scons.git"
|
||||
ffmpeg4.0.patch
|
||||
tree_hpp.patch
|
||||
util_sseb.patch
|
||||
openvdb3-abi.patch)
|
||||
if [[ -n $_gittag ]]; then
|
||||
source+=("${pkgname}-${pkgver}::git://git.blender.org/blender.git#tag=${_gittag}")
|
||||
elif [[ -n $_gitcommit ]]; then
|
||||
|
@ -52,6 +55,10 @@ md5sums=('SKIP'
|
|||
'SKIP'
|
||||
'SKIP'
|
||||
'SKIP'
|
||||
'da14d7cbdea1ab5499659a066658cdd2'
|
||||
'feea89510de171946c41c6208461f453'
|
||||
'53da216adbc2a9d555a59c15b8f0ef08'
|
||||
'3f9613fcb7ea61214982272e9c20a294'
|
||||
'SKIP')
|
||||
|
||||
prepare() {
|
||||
|
@ -65,11 +72,10 @@ prepare() {
|
|||
git config submodule."scons".url ${srcdir}/scons
|
||||
git submodule update
|
||||
|
||||
# Fix installation of modules
|
||||
sed -i "144i\ \ \ \ pass" release/scripts/addons_contrib/np_station/np_point_dimension.py
|
||||
|
||||
# Upstream commit to fix ARM FTBFS
|
||||
git cherry-pick -n 176e18436c45e38a2b7f1e7fccfdc0abedc1c13d
|
||||
patch -Np1 -i "$srcdir"/ffmpeg4.0.patch
|
||||
patch -Np1 -i "$srcdir"/tree_hpp.patch
|
||||
patch -Np1 -i "$srcdir"/util_sseb.patch
|
||||
patch -Np1 -i "$srcdir"/openvdb3-abi.patch
|
||||
}
|
||||
|
||||
build() {
|
||||
|
@ -78,8 +84,6 @@ build() {
|
|||
[[ -d build ]] && rm -rf build
|
||||
mkdir build && cd build
|
||||
|
||||
export CFLAGS="${CFLAGS} -DOPENVDB_3_ABI_COMPATIBLE"
|
||||
export CXXFLAGS="${CXXFLAGS} -DOPENVDB_3_ABI_COMPATIBLE"
|
||||
cmake -C../build_files/cmake/config/blender_release.cmake .. \
|
||||
-DCMAKE_INSTALL_PREFIX=/usr \
|
||||
-DCMAKE_BUILD_TYPE=Release \
|
||||
|
|
28
community/blender/openvdb3-abi.patch
Normal file
28
community/blender/openvdb3-abi.patch
Normal file
|
@ -0,0 +1,28 @@
|
|||
diff --git a/CMakeLists.txt b/CMakeLists.txt
|
||||
index bfea2dd1a97..c59aff4c62c 100644
|
||||
--- a/CMakeLists.txt
|
||||
+++ b/CMakeLists.txt
|
||||
@@ -252,6 +252,10 @@ option(WITH_OPENSUBDIV "Enable OpenSubdiv for surface subdivision" _init_OPEN
|
||||
option(WITH_OPENVDB "Enable features relying on OpenVDB" OFF)
|
||||
option(WITH_OPENVDB_BLOSC "Enable blosc compression for OpenVDB, only enable if OpenVDB was built with blosc support" OFF)
|
||||
|
||||
+if(WITH_OPENVDB)
|
||||
+ add_definitions(-DOPENVDB_3_ABI_COMPATIBLE=TRUE)
|
||||
+endif()
|
||||
+
|
||||
# GHOST Windowing Library Options
|
||||
option(WITH_GHOST_DEBUG "Enable debugging output for the GHOST library" OFF)
|
||||
mark_as_advanced(WITH_GHOST_DEBUG)
|
||||
diff --git a/intern/openvdb/intern/openvdb_writer.cc b/intern/openvdb/intern/openvdb_writer.cc
|
||||
index e886c5a76a8..bedcfe65552 100644
|
||||
--- a/intern/openvdb/intern/openvdb_writer.cc
|
||||
+++ b/intern/openvdb/intern/openvdb_writer.cc
|
||||
@@ -45,7 +45,7 @@ void OpenVDBWriter::insert(const openvdb::GridBase::Ptr &grid)
|
||||
|
||||
void OpenVDBWriter::insert(const openvdb::GridBase &grid)
|
||||
{
|
||||
-#if (OPENVDB_LIBRARY_MAJOR_VERSION_NUMBER == 3)
|
||||
+#if (OPENVDB_LIBRARY_MAJOR_VERSION_NUMBER <= 3) || defined(OPENVDB_3_ABI_COMPATIBLE)
|
||||
m_grids->push_back(grid.copyGrid());
|
||||
#else
|
||||
m_grids->push_back(grid.copyGridWithNewTree());
|
183
community/blender/tree_hpp.patch
Normal file
183
community/blender/tree_hpp.patch
Normal file
|
@ -0,0 +1,183 @@
|
|||
diff --git a/intern/itasc/kdl/tree.hpp b/intern/itasc/kdl/tree.hpp
|
||||
index c8a253fc901..bd35f82d185 100644
|
||||
--- a/intern/itasc/kdl/tree.hpp
|
||||
+++ b/intern/itasc/kdl/tree.hpp
|
||||
@@ -1,177 +1,177 @@
|
||||
// Copyright (C) 2007 Ruben Smits <ruben dot smits at mech dot kuleuven dot be>
|
||||
|
||||
// Version: 1.0
|
||||
// Author: Ruben Smits <ruben dot smits at mech dot kuleuven dot be>
|
||||
// Maintainer: Ruben Smits <ruben dot smits at mech dot kuleuven dot be>
|
||||
// URL: http://www.orocos.org/kdl
|
||||
|
||||
// This library is free software; you can redistribute it and/or
|
||||
// modify it under the terms of the GNU Lesser General Public
|
||||
// License as published by the Free Software Foundation; either
|
||||
// version 2.1 of the License, or (at your option) any later version.
|
||||
|
||||
// This library is distributed in the hope that it will be useful,
|
||||
// but WITHOUT ANY WARRANTY; without even the implied warranty of
|
||||
// MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
|
||||
// Lesser General Public License for more details.
|
||||
|
||||
// You should have received a copy of the GNU Lesser General Public
|
||||
// License along with this library; if not, write to the Free Software
|
||||
// Foundation, Inc., 51 Franklin St, Fifth Floor, Boston, MA 02110-1301 USA
|
||||
|
||||
#ifndef KDL_TREE_HPP
|
||||
#define KDL_TREE_HPP
|
||||
|
||||
#include "segment.hpp"
|
||||
#include "chain.hpp"
|
||||
|
||||
#include <string>
|
||||
#include <map>
|
||||
#include <Eigen/Core>
|
||||
|
||||
namespace KDL
|
||||
{
|
||||
//Forward declaration
|
||||
class TreeElement;
|
||||
// Eigen allocator is needed for alignment of Eigen data types
|
||||
- typedef std::map<std::string,TreeElement, std::less<std::string>, Eigen::aligned_allocator<std::pair<std::string, TreeElement> > > SegmentMap;
|
||||
+ typedef std::map<std::string,TreeElement, std::less<std::string>, Eigen::aligned_allocator<std::pair<const std::string, TreeElement> > > SegmentMap;
|
||||
|
||||
class TreeElement
|
||||
{
|
||||
public:
|
||||
TreeElement():q_nr(0),parent(0)
|
||||
{};
|
||||
public:
|
||||
Segment segment;
|
||||
unsigned int q_nr;
|
||||
SegmentMap::value_type const *parent;
|
||||
std::vector<SegmentMap::const_iterator > children;
|
||||
TreeElement(const Segment& segment_in,const SegmentMap::value_type& parent_in,unsigned int q_nr_in)
|
||||
{
|
||||
q_nr=q_nr_in;
|
||||
segment=segment_in;
|
||||
parent=&parent_in;
|
||||
};
|
||||
static TreeElement Root()
|
||||
{
|
||||
return TreeElement();
|
||||
};
|
||||
};
|
||||
|
||||
/**
|
||||
* \brief This class encapsulates a <strong>tree</strong>
|
||||
* kinematic interconnection structure. It is build out of segments.
|
||||
*
|
||||
* @ingroup KinematicFamily
|
||||
*/
|
||||
class Tree
|
||||
{
|
||||
private:
|
||||
SegmentMap segments;
|
||||
unsigned int nrOfJoints;
|
||||
unsigned int nrOfSegments;
|
||||
|
||||
bool addTreeRecursive(SegmentMap::const_iterator root, const std::string& tree_name, const std::string& hook_name);
|
||||
|
||||
public:
|
||||
/**
|
||||
* The constructor of a tree, a new tree is always empty
|
||||
*/
|
||||
Tree();
|
||||
Tree(const Tree& in);
|
||||
Tree& operator= (const Tree& arg);
|
||||
|
||||
/**
|
||||
* Adds a new segment to the end of the segment with
|
||||
* hook_name as segment_name
|
||||
*
|
||||
* @param segment new segment to add
|
||||
* @param segment_name name of the new segment
|
||||
* @param hook_name name of the segment to connect this
|
||||
* segment with.
|
||||
*
|
||||
* @return false if hook_name could not be found.
|
||||
*/
|
||||
bool addSegment(const Segment& segment, const std::string& segment_name, const std::string& hook_name);
|
||||
|
||||
/**
|
||||
* Adds a complete chain to the end of the segment with
|
||||
* hook_name as segment_name. Segment i of
|
||||
* the chain will get chain_name+".Segment"+i as segment_name.
|
||||
*
|
||||
* @param chain Chain to add
|
||||
* @param chain_name name of the chain
|
||||
* @param hook_name name of the segment to connect the chain with.
|
||||
*
|
||||
* @return false if hook_name could not be found.
|
||||
*/
|
||||
bool addChain(const Chain& chain, const std::string& chain_name, const std::string& hook_name);
|
||||
|
||||
/**
|
||||
* Adds a complete tree to the end of the segment with
|
||||
* hookname as segment_name. The segments of the tree will get
|
||||
* tree_name+segment_name as segment_name.
|
||||
*
|
||||
* @param tree Tree to add
|
||||
* @param tree_name name of the tree
|
||||
* @param hook_name name of the segment to connect the tree with
|
||||
*
|
||||
* @return false if hook_name could not be found
|
||||
*/
|
||||
bool addTree(const Tree& tree, const std::string& tree_name,const std::string& hook_name);
|
||||
|
||||
/**
|
||||
* Request the total number of joints in the tree.\n
|
||||
* <strong> Important:</strong> It is not the same as the
|
||||
* total number of segments since a segment does not need to have
|
||||
* a joint.
|
||||
*
|
||||
* @return total nr of joints
|
||||
*/
|
||||
unsigned int getNrOfJoints()const
|
||||
{
|
||||
return nrOfJoints;
|
||||
};
|
||||
|
||||
/**
|
||||
* Request the total number of segments in the tree.
|
||||
* @return total number of segments
|
||||
*/
|
||||
unsigned int getNrOfSegments()const {return nrOfSegments;};
|
||||
|
||||
/**
|
||||
* Request the segment of the tree with name segment_name.
|
||||
*
|
||||
* @param segment_name the name of the requested segment
|
||||
*
|
||||
* @return constant iterator pointing to the requested segment
|
||||
*/
|
||||
SegmentMap::const_iterator getSegment(const std::string& segment_name)const
|
||||
{
|
||||
return segments.find(segment_name);
|
||||
};
|
||||
|
||||
SegmentMap::value_type const* getSegmentPtr(const std::string& segment_name)const
|
||||
{
|
||||
SegmentMap::const_iterator it = segments.find(segment_name);
|
||||
|
||||
if (it == segments.end())
|
||||
return 0;
|
||||
|
||||
return &*it;
|
||||
};
|
||||
|
||||
const SegmentMap& getSegments()const
|
||||
{
|
||||
return segments;
|
||||
}
|
||||
|
||||
virtual ~Tree(){};
|
||||
};
|
||||
}
|
||||
#endif
|
||||
|
||||
|
||||
|
||||
|
||||
|
13
community/blender/util_sseb.patch
Normal file
13
community/blender/util_sseb.patch
Normal file
|
@ -0,0 +1,13 @@
|
|||
diff --git a/intern/cycles/util/util_sseb.h b/intern/cycles/util/util_sseb.h
|
||||
index 6e669701f3b..9ffe391666a 100644
|
||||
--- a/intern/cycles/util/util_sseb.h
|
||||
+++ b/intern/cycles/util/util_sseb.h
|
||||
@@ -116,7 +116,7 @@ __forceinline const sseb unpacklo( const sseb& a, const sseb& b ) { return _mm_u
|
||||
__forceinline const sseb unpackhi( const sseb& a, const sseb& b ) { return _mm_unpackhi_ps(a, b); }
|
||||
|
||||
template<size_t i0, size_t i1, size_t i2, size_t i3> __forceinline const sseb shuffle( const sseb& a ) {
|
||||
- return _mm_shuffle_epi32(a, _MM_SHUFFLE(i3, i2, i1, i0));
|
||||
+ return _mm_castsi128_ps(_mm_shuffle_epi32(a, _MM_SHUFFLE(i3, i2, i1, i0)));
|
||||
}
|
||||
|
||||
template<> __forceinline const sseb shuffle<0, 1, 0, 1>( const sseb& a ) {
|
Loading…
Reference in a new issue