core/mkinitcpio to 31-3

This commit is contained in:
Kevin Mihelich 2022-07-05 20:19:08 +00:00
parent 9a7d90edae
commit 7a1cc0054c
2 changed files with 37 additions and 1 deletions

View file

@ -0,0 +1,33 @@
From e629e34f18141a6244eaac2f0288d7b2a5d669ee Mon Sep 17 00:00:00 2001
From: Chih-Hsuan Yen <yan12125@gmail.com>
Date: Sun, 3 Jul 2022 11:03:10 +0800
Subject: [PATCH] Fix the warning about missing modules.builtin.modinfo
> depmod: WARNING: could not open modules.builtin.modinfo at /tmp/mkinitcpio.EftMSK/root/lib/modules/5.15.52-1-lts: No such file or directory
kmod wants modules.builtin.modinfo since v30 [1].
Also adds modules.order as suggested by heftig. That file is used (if
exists) since the first commit of depmod.
[1] https://git.kernel.org/pub/scm/utils/kernel/kmod/kmod.git/commit/?id=0246e06340df292b5dda4bc00e24cc9ae894e881
---
functions | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/functions b/functions
index 48cfd7a..e77a4c4 100644
--- a/functions
+++ b/functions
@@ -876,7 +876,7 @@ install_modules() {
(( ${#zst_comp[*]} )) && zstd -d --rm -q "${zst_comp[@]}"
msg "Generating module dependencies"
- install -m644 -t "$moduledest" "$_d_kmoduledir"/modules.builtin
+ install -m644 -t "$moduledest" "$_d_kmoduledir"/modules.{builtin,builtin.modinfo,order}
# we install all modules into kernel/, making the .order file incorrect for
# the module tree. munge it, so that we have an accurate index. This avoids
--
2.37.0

View file

@ -9,7 +9,7 @@
pkgname=mkinitcpio
pkgver=31
pkgrel=2.1
pkgrel=3
pkgdesc="Modular initramfs image creation utility"
arch=('any')
url='https://github.com/archlinux/mkinitcpio'
@ -25,11 +25,13 @@ optdepends=('xz: Use lzma or xz compression for the initramfs image'
provides=('initramfs')
backup=('etc/mkinitcpio.conf')
source=("https://sources.archlinux.org/other/$pkgname/$pkgname-$pkgver.tar.gz"{,.sig}
0001-Fix-the-warning-about-missing-modules.builtin.modinf.patch
'0001-use-gzip-for-compression-by-default.patch'
'0002-functions-handle-gzip-compressed-kernels-in-kver_gen.patch')
install=mkinitcpio.install
sha512sums=('4ef87c2e4f579b292c38f9c487e78b3b99f6db77909cab322e860e5ca70aca3747fcfc272e2e15c9a3605c924ab178057b8b23151f98debc5d96e65f3c0c49d5'
'SKIP'
'fd348d6fcff249672b495db50fa67ce06d5d9a0c8f749c8b488bc1e4b43c9b850a5ad87392230fbe8b715422bb14e760bb0ad219cfcf1d7e132c6a7e4dd118a6'
'209b3c296ac7ee65a025c13df023d063127f0168e1aa3205da7c43d05228104a46f64f7162bded79eca6c46149186964208d01692d8015f4fc7210c8de8eeaee'
'c1720f268a29361b54da026eb3aaaea2a36fac519cfc5396e7339e5f938adba43aa11d8cb6089e720e3dd218d1643876f0ca45b6147a0600410863f7e159c9f3')
b2sums=('0113e288906e3b5fa485c29c00e7df60d85addd96718c45531031a686f18c739fa18303b6cac374d35b85edb7b663e221c8dc9158dff08c75858a4ed4dd154bf'
@ -40,6 +42,7 @@ validpgpkeys=('ECCAC84C1BA08A6CC8E63FBBF22FB1D78A77AEAB') # Giancarlo Razzoli
prepare() {
cd $pkgname-$pkgver
patch -Np1 < "$srcdir"/0001-Fix-the-warning-about-missing-modules.builtin.modinf.patch
patch -p1 -i ../0001-use-gzip-for-compression-by-default.patch
patch -p1 -i ../0002-functions-handle-gzip-compressed-kernels-in-kver_gen.patch
}