extra/libreoffice-fresh to 5.1.1-2

This commit is contained in:
Kevin Mihelich 2016-03-13 18:20:53 +00:00
parent 8f445346de
commit 7a4716a245
3 changed files with 2119 additions and 2 deletions

View file

@ -12,7 +12,7 @@ pkgbase=libreoffice-fresh
pkgname=('libreoffice-fresh-sdk' 'libreoffice-fresh')
_LOver=5.1.1.3
pkgver=5.1.1
pkgrel=1
pkgrel=2
arch=('i686' 'x86_64')
license=('LGPL3')
url="http://www.libreoffice.org/"
@ -65,6 +65,8 @@ source=(${_mirror}/libreoffice{,-help,-translations}-${_LOver}.tar.xz{,.asc}
${_additional_source_url2}/185d60944ea767075d27247c3162b3bc-unowinreg.dll
make-pyuno-work-with-system-wide-module-install.diff
libreoffice-fresh.sh libreoffice-fresh.csh
update_liborcus_to_0.11.0.diff
remove_unnecessary_orcus_external_usage_from_makefiles.diff
buildfix.diff)
noextract=(boost_1_59_0.tar.bz2
1f24ab1d39f4a51faf22244c94a6203f-xmlsec1-1.2.14.tar.gz
@ -132,6 +134,8 @@ md5sums=('5354a6172015603ba057a2fbbfc9977e'
'dcb5ad3e5f7139227677ea064b075422'
'4195735a80876ae812fca5736b50192a'
'e7e4b3e70e99e5cba8f8dfcacf3b0d87'
'9ad03bcf1549acc0274e67bfc4c95390'
'ac71e21ecc0976b2ea6e233854963d4b'
'97dac0a03bbcaa4ee29f262dbcb4b427')
prepare() {
@ -173,8 +177,14 @@ prepare() {
sed -i "s:qmake:qmake-qt4:g" configure.ac
# mdds 1.0.0/liborcus 0.11.0 fix
# https://cgit.freedesktop.org/libreoffice/core/commit/?id=b325b4c286b56a63316063a3ac4648bf7b7efcbe
patch -Np1 -i ${srcdir}/update_liborcus_to_0.11.0.diff
# https://cgit.freedesktop.org/libreoffice/core/commit/?id=07d4c443e21cd22545d4516515c50b1c8dd39a9b
patch -Np1 -i ${srcdir}/remove_unnecessary_orcus_external_usage_from_makefiles.diff
sed -i "s:mdds >= 0.12.0:mdds-1.0 >= 0.12.0:g" configure.ac
# sed -i "s:liborcus-0.10:liborcus-0.11:g" configure.ac
# sed -i "s:liborcus-0.10:liborcus-0.11:g" configure.ac
}
build() {

View file

@ -0,0 +1,124 @@
From 07d4c443e21cd22545d4516515c50b1c8dd39a9b Mon Sep 17 00:00:00 2001
From: Michael Stahl <mstahl@redhat.com>
Date: Tue, 8 Mar 2016 15:01:59 +0100
Subject: sc: remove unnecessary orcus external usage from makefiles
This caused incremental builds to fail after today's orcus upgrade.
The cxx files of these tests don't actually include orcus headers, so
the libraries were not re-linked in incremental builds.
Change-Id: Ibfcf216a7848f3c0adfae4ef59c4b756c290d6b2
diff --git a/sc/CppunitTest_sc_bugfix_test.mk b/sc/CppunitTest_sc_bugfix_test.mk
index 55311cd..712f444 100644
--- a/sc/CppunitTest_sc_bugfix_test.mk
+++ b/sc/CppunitTest_sc_bugfix_test.mk
@@ -16,8 +16,6 @@ $(eval $(call gb_CppunitTest_add_exception_objects,sc_bugfix_test, \
$(eval $(call gb_CppunitTest_use_externals,sc_bugfix_test, \
boost_headers \
mdds_headers \
- orcus \
- orcus-parser \
libxml2 \
))
diff --git a/sc/CppunitTest_sc_copypaste.mk b/sc/CppunitTest_sc_copypaste.mk
index 7df4f51..641709c 100644
--- a/sc/CppunitTest_sc_copypaste.mk
+++ b/sc/CppunitTest_sc_copypaste.mk
@@ -16,8 +16,6 @@ $(eval $(call gb_CppunitTest_add_exception_objects,sc_copypaste, \
$(eval $(call gb_CppunitTest_use_externals,sc_copypaste, \
boost_headers \
mdds_headers \
- orcus \
- orcus-parser \
libxml2 \
))
diff --git a/sc/CppunitTest_sc_filters_test.mk b/sc/CppunitTest_sc_filters_test.mk
index 4fbf489..db445f53 100644
--- a/sc/CppunitTest_sc_filters_test.mk
+++ b/sc/CppunitTest_sc_filters_test.mk
@@ -22,8 +22,6 @@ endif
$(eval $(call gb_CppunitTest_use_externals,sc_filters_test, \
boost_headers \
mdds_headers \
- orcus \
- orcus-parser \
))
$(eval $(call gb_CppunitTest_use_libraries,sc_filters_test, \
diff --git a/sc/CppunitTest_sc_opencl_test.mk b/sc/CppunitTest_sc_opencl_test.mk
index 86605a2..ea93111 100644
--- a/sc/CppunitTest_sc_opencl_test.mk
+++ b/sc/CppunitTest_sc_opencl_test.mk
@@ -16,8 +16,6 @@ $(eval $(call gb_CppunitTest_add_exception_objects,sc_opencl_test, \
$(eval $(call gb_CppunitTest_use_externals,sc_opencl_test, \
boost_headers \
mdds_headers \
- orcus \
- orcus-parser \
))
$(eval $(call gb_CppunitTest_use_libraries,sc_opencl_test, \
diff --git a/sc/CppunitTest_sc_rangelst_test.mk b/sc/CppunitTest_sc_rangelst_test.mk
index 2bf6f0f..fa6f690 100644
--- a/sc/CppunitTest_sc_rangelst_test.mk
+++ b/sc/CppunitTest_sc_rangelst_test.mk
@@ -16,18 +16,12 @@ $(eval $(call gb_CppunitTest_use_externals,sc_rangelst_test, \
icuuc \
libxml2 \
mdds_headers \
- orcus \
- orcus-parser \
))
$(eval $(call gb_CppunitTest_add_exception_objects,sc_rangelst_test, \
sc/qa/unit/rangelst_test \
))
-$(eval $(call gb_CppunitTest_use_library_objects,sc_rangelst_test, \
- scqahelper \
-))
-
$(eval $(call gb_CppunitTest_use_libraries,sc_rangelst_test, \
basegfx \
comphelper \
@@ -45,6 +39,7 @@ $(eval $(call gb_CppunitTest_use_libraries,sc_rangelst_test, \
sax \
sb \
sc \
+ scqahelper \
sfx \
sot \
svl \
diff --git a/sc/CppunitTest_sc_subsequent_export_test.mk b/sc/CppunitTest_sc_subsequent_export_test.mk
index 1cfaf69..6c2c9e5 100644
--- a/sc/CppunitTest_sc_subsequent_export_test.mk
+++ b/sc/CppunitTest_sc_subsequent_export_test.mk
@@ -16,8 +16,6 @@ $(eval $(call gb_CppunitTest_add_exception_objects,sc_subsequent_export_test, \
$(eval $(call gb_CppunitTest_use_externals,sc_subsequent_export_test, \
boost_headers \
mdds_headers \
- orcus \
- orcus-parser \
libxml2 \
))
diff --git a/sc/CppunitTest_sc_subsequent_filters_test.mk b/sc/CppunitTest_sc_subsequent_filters_test.mk
index 08dedbb..845206b 100644
--- a/sc/CppunitTest_sc_subsequent_filters_test.mk
+++ b/sc/CppunitTest_sc_subsequent_filters_test.mk
@@ -16,8 +16,6 @@ $(eval $(call gb_CppunitTest_add_exception_objects,sc_subsequent_filters_test, \
$(eval $(call gb_CppunitTest_use_externals,sc_subsequent_filters_test, \
boost_headers \
mdds_headers \
- orcus \
- orcus-parser \
libxml2 \
))
--
cgit v0.10.2

File diff suppressed because it is too large Load diff