mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-18 22:54:00 +00:00
extra/webkit2gtk to 2.26.3-1
This commit is contained in:
parent
ebf53bbb41
commit
7a7dc8c9f3
2 changed files with 5 additions and 47 deletions
|
@ -7,8 +7,8 @@
|
|||
highmem=1
|
||||
|
||||
pkgname=webkit2gtk
|
||||
pkgver=2.26.2
|
||||
pkgrel=2
|
||||
pkgver=2.26.3
|
||||
pkgrel=1
|
||||
pkgdesc="GTK+ Web content engine library"
|
||||
arch=(x86_64)
|
||||
url="https://webkitgtk.org/"
|
||||
|
@ -21,17 +21,14 @@ optdepends=('geoclue: Geolocation support'
|
|||
'gst-plugins-good: media decoding'
|
||||
'gst-plugins-bad: media decoding'
|
||||
'gst-libav: nonfree media decoding')
|
||||
source=(https://webkitgtk.org/releases/webkitgtk-${pkgver}.tar.xz{,.asc}
|
||||
icu65.patch)
|
||||
sha256sums=('6b80f0637a80818559ac8fd50db3b394f41cb61904fb9b3ed65fa51635806512'
|
||||
'SKIP'
|
||||
'3acd85fecfca223e3fbf834e3be286ea29270689da994a758659abc8ed0a6635')
|
||||
source=(https://webkitgtk.org/releases/webkitgtk-${pkgver}.tar.xz{,.asc})
|
||||
sha256sums=('add51153943cc11d90a7038d0ea5f6332281e6c0be0640f802a211b035f0e611'
|
||||
'SKIP')
|
||||
validpgpkeys=('D7FCF61CF9A2DEAB31D81BD3F3D322D0EC4582C3'
|
||||
'5AA3BC334FD7E3369E7C77B291C559DBE4C9123B')
|
||||
|
||||
prepare() {
|
||||
cd webkitgtk-$pkgver
|
||||
patch -Np1 -i ../icu65.patch # from PLD Linux
|
||||
}
|
||||
|
||||
build() {
|
||||
|
|
|
@ -1,39 +0,0 @@
|
|||
diff -urN webkitgtk-2.26.1.orig/Source/WebCore/dom/Document.cpp webkitgtk-2.26.1/Source/WebCore/dom/Document.cpp
|
||||
--- webkitgtk-2.26.1.orig/Source/WebCore/dom/Document.cpp 2019-09-02 11:41:47.000000000 +0200
|
||||
+++ webkitgtk-2.26.1/Source/WebCore/dom/Document.cpp 2019-10-08 16:24:57.649551493 +0200
|
||||
@@ -4944,12 +4944,12 @@
|
||||
unsigned i = 0;
|
||||
|
||||
UChar32 c;
|
||||
- U16_NEXT(characters, i, length, c)
|
||||
+ U16_NEXT(characters, i, length, c);
|
||||
if (!isValidNameStart(c))
|
||||
return false;
|
||||
|
||||
while (i < length) {
|
||||
- U16_NEXT(characters, i, length, c)
|
||||
+ U16_NEXT(characters, i, length, c);
|
||||
if (!isValidNamePart(c))
|
||||
return false;
|
||||
}
|
||||
@@ -5009,7 +5009,7 @@
|
||||
|
||||
for (unsigned i = 0; i < length; ) {
|
||||
UChar32 c;
|
||||
- U16_NEXT(qualifiedName, i, length, c)
|
||||
+ U16_NEXT(qualifiedName, i, length, c);
|
||||
if (c == ':') {
|
||||
if (sawColon)
|
||||
return Exception { InvalidCharacterError };
|
||||
diff -urN webkitgtk-2.26.1.orig/Source/WTF/wtf/URLHelpers.cpp webkitgtk-2.26.1/Source/WTF/wtf/URLHelpers.cpp
|
||||
--- webkitgtk-2.26.1.orig/Source/WTF/wtf/URLHelpers.cpp 2019-08-28 13:46:29.000000000 +0200
|
||||
+++ webkitgtk-2.26.1/Source/WTF/wtf/URLHelpers.cpp 2019-10-08 16:24:50.619850993 +0200
|
||||
@@ -301,7 +301,7 @@
|
||||
Optional<UChar32> previousCodePoint;
|
||||
while (i < length) {
|
||||
UChar32 c;
|
||||
- U16_NEXT(buffer, i, length, c)
|
||||
+ U16_NEXT(buffer, i, length, c);
|
||||
UErrorCode error = U_ZERO_ERROR;
|
||||
UScriptCode script = uscript_getScript(c, &error);
|
||||
if (error != U_ZERO_ERROR) {
|
Loading…
Reference in a new issue