extra/calligra to 3.0.0.1-1

This commit is contained in:
Kevin Mihelich 2017-01-03 19:35:47 +00:00
parent 38b4abbbcd
commit 7a87408d0f
2 changed files with 39 additions and 233 deletions

View file

@ -5,207 +5,64 @@
# Contributor: Ronald van Haren <ronald.archlinux.org>
# ALARM: Kevin Mihelich <kevin@archlinuxarm.org>
# - upstream patch for signed char on ARM
# - remove makedepend on vc
# - fedora patch to fix ARM build with GCC 6
pkgbase=calligra
pkgname=('calligra-braindump'
'calligra-devtools'
'calligra-extras'
'calligra-filters'
'calligra-flow'
'calligra-gemini'
'calligra-handbook'
'calligra-karbon'
'calligra-libs'
'calligra-plan'
'calligra-plugins'
'calligra-sheets'
'calligra-stage'
'calligra-words')
pkgver=2.9.11
pkgrel=10
pkgname=calligra
pkgdesc="A set of applications for productivity and creative usage"
pkgver=3.0.0.1
pkgrel=1
arch=('i686' 'x86_64')
url='http://www.calligra-suite.org/'
license=('FDL1.2' 'GPL2' 'LGPL')
makedepends=('cmake' 'automoc4' 'boost' 'kdepimlibs4' 'eigen'
'lcms2' 'libwpg' 'libwps' 'gsl' 'glew' 'fftw' 'poppler-qt4' 'libodfgen'
'pstoedit' 'libvisio' 'libetonyek' 'libspnav')
groups=('calligra')
source=("http://download.kde.org/stable/${pkgbase}-${pkgver}/${pkgbase}-${pkgver}.tar.xz" 'libwps-0.4.patch'
'https://github.com/KDE/calligra/commit/956bb80db4f300e4f8edeaf19d24fd61eb1932b2.patch'
depends=('kcmutils' 'knotifyconfig' 'kross' 'ktexteditor' 'threadweaver' 'kactivities' 'kdiagram' 'kreport' 'libspnav'
'gsl' 'openexr' 'akonadi-contacts' 'kcalcore' 'qca-qt5' 'poppler-qt5' 'libodfgen' 'qt5-webkit' 'cauchy')
makedepends=('extra-cmake-modules' 'kdoctools' 'python' 'kdesignerplugin' 'khtml' 'boost' 'openjpeg'
'libwpg' 'okular' 'eigen' 'marble' 'pstoedit' 'libvisio' 'libetonyek' 'libodfgen' 'libwps')
optdepends=('libwpg: Corel WordPerfect Graphics image importer'
'libwps: Microsoft Works file word processor format import'
'libvisio: Microsoft Visio import filter'
'libetonyek: Apple Keynote import filter'
'pstoedit: EPS to SVG filter'
'poppler: PDF to SVG filter'
'khtml: HTML to ODS filter'
'openjpeg: PDF to SVG filer'
'cauchy: formula shape')
conflicts=('calligra-devtools' 'calligra-extras' 'calligra-filters' 'calligra-karbon' 'karbon' 'calligra-libs' 'calligra-plan'
'calligra-plugins' 'calligra-sheets' 'calligra-stage' 'calligra-words' 'calligra-l10n' 'calligra-meta')
replaces=('calligra-devtools' 'calligra-extras' 'calligra-filters' 'calligra-karbon' 'karbon' 'calligra-libs' 'calligra-plan'
'calligra-plugins' 'calligra-sheets' 'calligra-stage' 'calligra-words' 'calligra-l10n' 'calligra-meta')
for _lang in bs ca ca@valencia cs da de el en_gb es et fi fr gl hu it ja kk nb nl \
pl pt pt_br ru sk sv uk zh_cn zh_tw; do
conflicts+=(calligra-l10n-$_lang)
replaces+=(calligra-l10n-$_lang)
done
source=("http://download.kde.org/stable/$pkgname/$pkgver/$pkgname-$pkgver.tar.xz"{,.sig}
'calligra-2.9.11-gcc6_arm.patch')
md5sums=('a1a4935debae64724cd4c0d17d61ae4e'
'6ea15f8b3938838d89ea0aa08921afd1'
'47305e6e25a076d5761e7b22a65b777e'
'6f40e8f90b21fd1b5fe9d57998fc2b3e')
sha256sums=('dedc51efc42f7dda37514d450cb772d9db37a658e0abbcf0f513712a04c1f011'
'SKIP'
'33d803c49abefc37f51f824543e889f9e369e86df9ce64d980e0a7dbca2ea27d')
validpgpkeys=(05D00A8B73A686789E0A156858B9596C722EA3BD) # Boudewijn Rempt <foundation@krita.org>
prepare() {
mkdir -p build
# Fix build against libwps 0.4
# Fix build on ARM
cd $pkgbase-$pkgver
patch -p1 -i "$srcdir"/libwps-0.4.patch
# Fix build on ARM
patch -p1 -i ../956bb80db4f300e4f8edeaf19d24fd61eb1932b2.patch
patch -p1 -i ../calligra-2.9.11-gcc6_arm.patch
}
build() {
cd build
cmake ../${pkgbase}-${pkgver} \
-DCMAKE_BUILD_TYPE=Release \
-DCMAKE_BUILD_TYPE=Debug \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib \
-DBUILD_active=OFF \
-DWITH_Soprano=OFF \
-DBUILD_krita=OFF \
-DBUILD_kexi=OFF
-DKDE_INSTALL_LIBDIR=lib \
-DBUILD_TESTING=OFF
make
}
package_calligra-filters() {
pkgdesc="Filters for the Calligra office suite"
depends=('libodfgen')
optdepends=('libwpg: Corel WordPerfect Graphics image importer'
'libwps: Microsoft Works file word processor format import'
'libvisio: Microsoft Visio import filter'
'libetonyek: Apple Keynote import filter')
cd build/filters
make DESTDIR="${pkgdir}" install
}
package_calligra-libs() {
pkgdesc="Libraries for the Calligra office suite"
depends=('kdepimlibs4')
conflicts=('calligra-interfaces' 'calligra-pics' 'calligra-servicetypes')
replaces=('calligra-interfaces' 'calligra-pics' 'calligra-servicetypes')
for d in interfaces libs pics servicetypes; do
cd "${srcdir}"/build/${d}
make DESTDIR="${pkgdir}" install
done
}
package_calligra-plugins() {
pkgdesc="Plugins for the Calligra office suite"
depends=('calligra-libs' 'calligra-filters' 'libspnav')
cd build/plugins
make DESTDIR="${pkgdir}" install
cd ../3rdparty/kdchart
make DESTDIR="${pkgdir}" install
}
package_calligra-karbon() {
pkgdesc="Create scalable vector drawings"
depends=('calligra-libs' 'kdebase-runtime' 'pstoedit')
optdepends=('calligra-filters: import/export filters'
'calligra-extras: extra calligra tools')
cd build/karbon
make DESTDIR="${pkgdir}" install
}
package_calligra-plan() {
pkgdesc="Calligra Project Management Component"
depends=('calligra-words')
cd build/plan
make DESTDIR="${pkgdir}" install
cd ../3rdparty/kdgantt
make DESTDIR="${pkgdir}" install
}
package_calligra-stage() {
pkgdesc="Write presentation documents"
depends=('calligra-plugins' 'kdebase-runtime')
cd build/stage
make DESTDIR="${pkgdir}" install
cd ../doc/stage
make DESTDIR="${pkgdir}" install
}
package_calligra-sheets() {
pkgdesc="Write spreadsheet documents"
depends=('calligra-libs' 'gsl' 'kdebase-runtime')
optdepends=('calligra-filters: import/export filters'
'calligra-plugins: extra calligra plugins'
'calligra-extras: extra calligra tools')
cd build/sheets
make DESTDIR="${pkgdir}" install
cd ../doc/sheets
make DESTDIR="${pkgdir}" install
}
package_calligra-words() {
pkgdesc="Word Processor"
depends=('kdebase-runtime' 'calligra-plugins')
optdepends=('calligra-extras: extra calligra tools')
cd build/words
make DESTDIR="${pkgdir}" install
}
package_calligra-handbook() {
pkgdesc="Documentation for Calligra"
options=('docs')
cd build/doc/calligra
make DESTDIR="${pkgdir}" install
}
package_calligra-braindump() {
pkgdesc="Notes and idea gathering"
depends=('calligra-libs' 'kdebase-runtime')
cd build/braindump
make DESTDIR="${pkgdir}" install
}
package_calligra-flow() {
pkgdesc="Flowchart & Diagram Editing"
depends=('calligra-words')
optdepends=('calligra-karbon: to export the charts in various formats')
cd build/flow
make DESTDIR="${pkgdir}" install
}
package_calligra-extras() {
pkgdesc="Calligra suite extras"
depends=('calligra-libs')
conflicts=('calligra-tools')
replaces=('calligra-tools')
cd build/extras
make DESTDIR="${pkgdir}" install
cd ../data
make DESTDIR="${pkgdir}" install
}
package_calligra-devtools() {
pkgdesc="Calligra developer tools"
depends=('calligra-libs' 'poppler-qt4')
cd build/devtools
make DESTDIR="${pkgdir}" install
}
package_calligra-gemini() {
pkgdesc="QML interface for Calligra Words and Stage"
depends=('calligra-words' 'calligra-stage')
# optdepends=('libqgit2: GIT plugin')
cd build/qtquick
make DESTDIR="${pkgdir}" install
cd "${srcdir}"/build/gemini
make DESTDIR="${pkgdir}" install
package() {
cd build
make DESTDIR="$pkgdir" install
}

View file

@ -1,51 +0,0 @@
From e81fe84405bc635dfa93e54fb8a3c8e6065dbf10 Mon Sep 17 00:00:00 2001
From: David Tardon <dtardon@redhat.com>
Date: Sat, 6 Jun 2015 18:27:24 +0200
Subject: [PATCH] adapt to libwps 0.4
---
cmake/modules/FindLibWps.cmake | 6 +++---
filters/words/works/import/WPSImport.cpp | 4 +++-
2 files changed, 6 insertions(+), 4 deletions(-)
diff --git a/cmake/modules/FindLibWps.cmake b/cmake/modules/FindLibWps.cmake
index f8c8225..58ef2b5 100644
--- a/cmake/modules/FindLibWps.cmake
+++ b/cmake/modules/FindLibWps.cmake
@@ -10,16 +10,16 @@
include(LibFindMacros)
libfind_package(LIBWPS LibWpd)
-libfind_pkg_check_modules(LIBWPS_PKGCONF libwps-0.3)
+libfind_pkg_check_modules(LIBWPS_PKGCONF libwps-0.4)
find_path(LIBWPS_INCLUDE_DIR
NAMES libwps/libwps.h
HINTS ${LIBWPS_PKGCONF_INCLUDE_DIRS} ${LIBWPS_PKGCONF_INCLUDEDIR}
- PATH_SUFFIXES libwps-0.3
+ PATH_SUFFIXES libwps-0.4
)
find_library(LIBWPS_LIBRARY
- NAMES wps wps-0.3
+ NAMES wps wps-0.4
HINTS ${LIBWPS_PKGCONF_LIBRARY_DIRS} ${LIBWPS_PKGCONF_LIBDIR}
)
diff --git a/filters/words/works/import/WPSImport.cpp b/filters/words/works/import/WPSImport.cpp
index eea2cc9..94b859d 100644
--- a/filters/words/works/import/WPSImport.cpp
+++ b/filters/words/works/import/WPSImport.cpp
@@ -91,7 +91,9 @@ public:
bool isSupportedFormat(librevenge::RVNGInputStream &input)
{
WPSKind kind = WPS_TEXT;
- WPSConfidence confidence = WPSDocument::isFileFormatSupported(&input, kind);
+ WPSCreator creator = WPS_MSWORKS;
+ bool needsEncoding = false;
+ WPSConfidence confidence = WPSDocument::isFileFormatSupported(&input, kind, creator, needsEncoding);
if (confidence == WPS_CONFIDENCE_NONE || kind != WPS_TEXT)
return false;
return true;
--
2.4.2