diff --git a/community/qpid-proton/PKGBUILD b/community/qpid-proton/PKGBUILD
index cbaaed89a..5d24a1320 100644
--- a/community/qpid-proton/PKGBUILD
+++ b/community/qpid-proton/PKGBUILD
@@ -4,16 +4,17 @@
 #  - disable LTO
 
 pkgname=qpid-proton
-pkgver=0.30.0
-pkgrel=5
+pkgver=0.31.0
+pkgrel=1
 pkgdesc='High-performance, lightweight messaging library'
 arch=('x86_64')
 url='https://qpid.apache.org/proton'
 license=('Apache')
-depends=('libjsoncpp.so' 'python' 'ruby')
-makedepends=('cmake' 'doxygen' 'python-setuptools' 'swig')
+depends=('libjsoncpp.so' 'python')
+makedepends=('cmake' 'doxygen' 'go' 'python-setuptools' 'python-sphinx' 'python-wheel' 'swig')
+checkdepends=('python-tox')
 source=("https://www.apache.org/dist/qpid/proton/${pkgver}/qpid-proton-${pkgver}.tar.gz")
-sha512sums=('0e55d6a2c9803ef72604c50c7b934379092680b5edd52e3641a851f50ba1136bfa83cd30328d2b3235152331109d3204aa32168aa626d6e8e34a590d82553cc8')
+sha512sums=('39487c34ae6ae1cc0c2f57f2ffb2bdf48a554e9ba8439a5c3f9776205cdb138f71284c9fc7626e4bbee3110ccce7da61ddb45f51ebddfede981ada0872074202')
 
 build() {
     cd ${pkgname}-${pkgver}
@@ -29,6 +30,12 @@ build() {
     make
 }
 
+check() {
+    cd ${pkgname}-${pkgver}/build
+
+    make test
+}
+
 package() {
     cd ${pkgname}-${pkgver}/build