extra/qt5-webengine to 5.15.8-1

This commit is contained in:
David Beauchamp 2022-01-04 14:02:02 -05:00
parent deec1e4090
commit 7ac05882a3
3 changed files with 1083 additions and 25 deletions

View file

@ -10,9 +10,9 @@ buildarch=12
highmem=1
pkgname=qt5-webengine
_qtver=5.15.7
_qtver=5.15.8
pkgver=${_qtver/-/}
pkgrel=2
pkgrel=1
arch=('x86_64')
url='https://www.qt.io'
license=('LGPL3' 'LGPL2.1' 'BSD')
@ -35,8 +35,8 @@ source=(git+https://code.qt.io/qt/qtwebengine.git#tag=v${pkgver}-lts
sha256sums=('SKIP'
'SKIP'
'SKIP'
'45ccf4ff981a26656e5105259f71a3ce386d4a7112cbf09e41cb61615b355435'
'8d0327615c6b6a340122640a9ddeb56be185621297a4ead8da4211e37feeaa75'
'398c996cb5b606695ac93645143df39e23fa67e768b09e0da6dbd37342a43f32'
'cf7be86f1d301001f91b89455b7edbbd269041e2e196355940c38afc84400826'
'81b7a62368f40d757b165b88df4813413f30db797e4f93a84dd75e12e1ebd679'
'298037fcbc132f1539616cdf6149ad5da104f8e2345a9c1af1e7bf8b0dd52c70'
'b878770648437c9bc24023b1d5a47bcd51382d7142b695864c3379826511bcd9'

File diff suppressed because it is too large Load diff

View file

@ -1,18 +1,29 @@
diff --git a/configure.pri b/configure.pri
index e072961f..5efe30bc 100644
index 8705ad93..6723bffe 100644
--- a/configure.pri
+++ b/configure.pri
@@ -12,10 +12,6 @@ defineTest(isPythonVersionSupported) {
python_version ~= s/[()]//g
python_version = $$split(python_version, ',')
python_major_version = $$first(python_version)
@@ -7,20 +7,7 @@ QTWEBENGINE_SOURCE_TREE = $$PWD
equals(QMAKE_HOST.os, Windows): EXE_SUFFIX = .exe
defineTest(isPythonVersionSupported) {
- python = $$system_quote($$system_path($$1))
- python_version = $$system('$$python -c "import sys; print(sys.version_info[0:3])"')
- python_version ~= s/[()]//g
- python_version = $$split(python_version, ',')
- python_major_version = $$first(python_version)
- greaterThan(python_major_version, 2) {
- qtLog("Python version 3 is not supported by Chromium.")
- return(false)
- }
python_minor_version = $$member(python_version, 1)
python_patch_version = $$member(python_version, 2)
greaterThan(python_major_version, 1): greaterThan(python_minor_version, 6): greaterThan(python_patch_version, 4): return(true)
- python_minor_version = $$member(python_version, 1)
- python_patch_version = $$member(python_version, 2)
- greaterThan(python_major_version, 1): greaterThan(python_minor_version, 6): greaterThan(python_patch_version, 4): return(true)
- qtLog("Unsupported python version: $${python_major_version}.$${python_minor_version}.$${python_patch_version}.")
- return(false)
+ return(true)
}
defineTest(qtConfTest_detectJumboBuild) {
@@ -52,10 +48,10 @@ defineTest(qtConfReport_jumboBuild) {
qtConfReportPadded($${1}, $$mergeLimit)
}