mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-03-19 00:21:40 +00:00
Added tightvnc to [extra]
This commit is contained in:
parent
7cd42951c5
commit
7ac3fe3cc7
4 changed files with 2760 additions and 0 deletions
2621
core/kernel26-dockstar/aholler-2.6.35.4-config
Normal file
2621
core/kernel26-dockstar/aholler-2.6.35.4-config
Normal file
File diff suppressed because it is too large
Load diff
81
extra/tightvnc/LinuxMachineDefines-arm.patch
Normal file
81
extra/tightvnc/LinuxMachineDefines-arm.patch
Normal file
|
@ -0,0 +1,81 @@
|
|||
--- vnc_unixsrc/Xvnc/config/cf/linux.cf.orig 2010-09-21 20:00:26.000000000 +0000
|
||||
+++ vnc_unixsrc/Xvnc/config/cf/linux.cf 2010-09-21 20:02:08.000000000 +0000
|
||||
@@ -249,42 +249,36 @@
|
||||
|
||||
#ifdef i386Architecture
|
||||
#define OptimizedCDebugFlags DefaultGcc2i386Opt
|
||||
-#define LinuxMachineDefines -D__i386__
|
||||
#define ServerOSDefines XFree86ServerOSDefines -DDDXTIME -DPART_NET
|
||||
#define ServerExtraDefines -DGCCUSESGAS XFree86ServerDefines
|
||||
#endif /* i386Architecture */
|
||||
|
||||
#ifdef x86_64Architecture
|
||||
#define OptimizedCDebugFlags -O2
|
||||
-#define LinuxMachineDefines -D__x86_64__
|
||||
#define ServerOSDefines XFree86ServerOSDefines -DDDXTIME -DPART_NET
|
||||
#define ServerExtraDefines -DGCCUSESGAS XFree86ServerDefines -D_XSERVER64
|
||||
#endif /* x86_64Architecture */
|
||||
|
||||
#ifdef AlphaArchitecture
|
||||
#define OptimizedCDebugFlags -O2
|
||||
-#define LinuxMachineDefines -D__alpha__
|
||||
#define ServerOSDefines XFree86ServerOSDefines -DDDXTIME -DPART_NET
|
||||
#define ServerExtraDefines -DGCCUSESGAS XFree86ServerDefines -D_XSERVER64
|
||||
#endif /* AlphaArchitecture */
|
||||
|
||||
#ifdef Mc68020Architecture
|
||||
#define OptimizedCDebugFlags -O2
|
||||
-#define LinuxMachineDefines -D__mc68000__
|
||||
#define ServerOSDefines XFree86ServerOSDefines -DDDXTIME -DPART_NET
|
||||
#define ServerExtraDefines -DGCCUSESGAS XFree86ServerDefines
|
||||
#endif /* Mc68020Architecture */
|
||||
|
||||
#ifdef s390Architecture
|
||||
#define OptimzedCDebugFlags -O2
|
||||
-#define LinuxMachineDefines -D__s390__
|
||||
#define ServerOSDefines XFree86ServerOSDefines -DDDXTIME -DPART_NET
|
||||
#define ServerExtraDefines -DGCCUSESGAS XFree86ServerDefines
|
||||
#endif /* s390Architecture */
|
||||
|
||||
#ifdef s390xArchitecture
|
||||
#define OptimzedCDebugFlags -O2
|
||||
-#define LinuxMachineDefines -D__s390x__
|
||||
#define ServerOSDefines XFree86ServerOSDefines -DDDXTIME -DPART_NET
|
||||
#define ServerExtraDefines -DGCCUSESGAS XFree86ServerDefines
|
||||
#endif /* s390xArchitecture */
|
||||
@@ -292,7 +286,6 @@
|
||||
#ifdef PowerPCArchitecture
|
||||
#define DefaultCCOptions -fsigned-char
|
||||
#define OptimizedCDebugFlags -O2
|
||||
-#define LinuxMachineDefines -D__powerpc__
|
||||
#define ServerOSDefines XFree86ServerOSDefines -DDDXTIME -DPART_NET
|
||||
#define ServerExtraDefines -DGCCUSESGAS XFree86ServerDefines
|
||||
#endif /* PowerPCArchitecture */
|
||||
@@ -300,14 +293,12 @@
|
||||
#ifdef ArmArchitecture
|
||||
#define DefaultCCOptions -fsigned-char
|
||||
#define OptimizedCDebugFlags -O2
|
||||
-#define LinuxMachineDefines -D__arm__
|
||||
#define ServerOSDefines XFree86ServerOSDefines -DDDXTIME -DPART_NET
|
||||
#define ServerExtraDefines -DGCCUSESGAS XFree86ServerDefines
|
||||
#endif /* Arm */
|
||||
|
||||
#ifdef SparcArchitecture
|
||||
#define OptimizedCDebugFlags -O2
|
||||
-#define LinuxMachineDefines -D__sparc__
|
||||
#define ServerOSDefines -DDDXOSINIT
|
||||
#define ServerExtraDefines -DGCCUSESGAS XFree86ServerDefines
|
||||
#define AsVISOption -Av9a
|
||||
@@ -327,10 +318,10 @@
|
||||
Always define _REENTRANT since we may use threaded libraries */
|
||||
|
||||
/* REMOVE
|
||||
-#define StandardDefines -Dlinux LinuxMachineDefines LinuxSourceDefines
|
||||
+#define StandardDefines -Dlinux LinuxSourceDefines
|
||||
*/
|
||||
|
||||
-#define StandardDefines -Dlinux LinuxMachineDefines \
|
||||
+#define StandardDefines -Dlinux \
|
||||
LinuxSourceDefines -D_REENTRANT
|
||||
|
||||
/* END ORL VNC modification
|
45
extra/tightvnc/PKGBUILD
Normal file
45
extra/tightvnc/PKGBUILD
Normal file
|
@ -0,0 +1,45 @@
|
|||
# $Id: PKGBUILD 64786 2010-01-22 07:44:39Z eric $
|
||||
# Maintainer: Paul Mattal <paul@archlinux.org>
|
||||
pkgname=tightvnc
|
||||
pkgver=1.3.10
|
||||
pkgrel=5
|
||||
pkgdesc="VNC Unix server && viewer"
|
||||
arch=('i686' 'x86_64')
|
||||
license=('GPL')
|
||||
url="http://www.tightvnc.com"
|
||||
depends=('libjpeg>=7' 'zlib' 'libxaw' 'libxp' 'xorg-xauth')
|
||||
makedepends=('imake')
|
||||
conflicts=('vnc')
|
||||
options=(!makeflags)
|
||||
source=(http://downloads.sf.net/sourceforge/vnc-tight/$pkgname-${pkgver}_unixsrc.tar.bz2
|
||||
tightvnc-fontpath-xcolors.patch
|
||||
LinuxMachineDefines-arm.patch)
|
||||
|
||||
build() {
|
||||
cd $srcdir/vnc_unixsrc || return 1
|
||||
patch -Np1 -i ../tightvnc-fontpath-xcolors.patch || return 1
|
||||
sed -i 's|/usr/local/|/usr/share/|' vncserver || return 1
|
||||
# The following patch allows the package to compile on ARM. It may not
|
||||
# be the best way to do it, but it works. A more elegant solution
|
||||
# is welcomed.
|
||||
patch -Np1 -i ../LinuxMachineDefines-arm.patch || return 1
|
||||
|
||||
xmkmf || return 1
|
||||
make World || return 1
|
||||
cd Xvnc || return 1
|
||||
./configure || return 1
|
||||
sed 's|PROTO_DEFINES =|PROTO_DEFINES = -D_XOPEN_SOURCE=500L|' \
|
||||
-i programs/Xserver/os/Makefile lib/font/fc/Makefile || return 1
|
||||
make || return 1
|
||||
cd .. || return 1
|
||||
mkdir -p $pkgdir/usr/bin $pkgdir/usr/share/man/man1 || return 1
|
||||
./vncinstall $pkgdir/usr/bin $pkgdir/usr/share/man || return 1
|
||||
|
||||
# install java classes
|
||||
mkdir -p $pkgdir/usr/share/vnc/classes || return 1
|
||||
install -Dm644 $srcdir/vnc_unixsrc/classes/* \
|
||||
$pkgdir/usr/share/vnc/classes || return 1
|
||||
}
|
||||
md5sums=('397b35faad32d5246b6d44b142f8304f'
|
||||
'21aa7f3376ec3c608ff22d199a19c601'
|
||||
'48a419227940ef3dcd92fab7f8809845')
|
13
extra/tightvnc/tightvnc-fontpath-xcolors.patch
Normal file
13
extra/tightvnc/tightvnc-fontpath-xcolors.patch
Normal file
|
@ -0,0 +1,13 @@
|
|||
diff -urN vnc_unixsrc/vncserver vnc_unixsrc.fixed/vncserver
|
||||
--- vnc_unixsrc/vncserver 2009-02-11 23:27:18.000000000 -0500
|
||||
+++ vnc_unixsrc.fixed/vncserver 2009-04-23 21:46:46.000000000 -0400
|
||||
@@ -34,7 +34,8 @@
|
||||
$desktopName = "X";
|
||||
$vncClasses = "/usr/local/vnc/classes";
|
||||
$vncUserDir = "$ENV{HOME}/.vnc";
|
||||
-$fontPath = "unix/:7100";
|
||||
+$fontPath = "/usr/share/fonts/misc/,/usr/share/fonts/75dpi/,/usr/share/fonts/100dpi/,/usr/share/fonts/Type1/";
|
||||
+$colorPath = "/usr/share/X11/rgb";
|
||||
$authType = "-rfbauth $vncUserDir/passwd";
|
||||
|
||||
# Read configuration from the system-wide and user files if present.
|
Loading…
Reference in a new issue