mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-01-17 23:34:07 +00:00
removed extra/lirc
This commit is contained in:
parent
2181216157
commit
7ad0d0cf6c
7 changed files with 0 additions and 291 deletions
|
@ -1,92 +0,0 @@
|
|||
# $Id$
|
||||
# Maintainer: Paul Mattal <paul@archlinux.org>
|
||||
|
||||
# ALARM: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
# - removed dependencies to the kernel
|
||||
|
||||
pkgbase=lirc
|
||||
pkgname=('lirc' 'lirc-utils')
|
||||
_pkgver=0.9.1a
|
||||
[[ $_pkgver =~ [a-z]$ ]] && pkgver="${_pkgver:0:-1}.${_pkgver: -1}" || pkgver="$_pkgver"
|
||||
pkgrel=12
|
||||
epoch=1
|
||||
arch=('i686' 'x86_64')
|
||||
url="http://www.lirc.org/"
|
||||
license=('GPL')
|
||||
makedepends=('help2man' 'alsa-lib' 'libx11' 'libftdi-compat' 'libirman' 'python2')
|
||||
options=('!makeflags' '!strip')
|
||||
source=("http://prdownloads.sourceforge.net/${pkgbase}/${pkgbase}-${_pkgver}.tar.bz2"
|
||||
wpc8769l-build-fix.patch
|
||||
lirc-0.9.1a-fix-segfaults.patch
|
||||
lirc.logrotate
|
||||
irexec.service
|
||||
lirc.tmpfiles)
|
||||
md5sums=('1f1fac162ed309dd50f307e96a292957'
|
||||
'9ec33169b3407f74264062d7679dd269'
|
||||
'cd00acf480e82a0bf050032732d0d733'
|
||||
'3deb02604b37811d41816e9b4385fcc3'
|
||||
'32df3b9bc859565d6acf5f0e5b747083'
|
||||
'febf25c154a7d36f01159e84f26c2d9a')
|
||||
|
||||
prepare() {
|
||||
cd "${srcdir}/lirc-${_pkgver}"
|
||||
|
||||
patch -Np1 -i "${srcdir}/wpc8769l-build-fix.patch"
|
||||
patch -Np1 -i "${srcdir}/lirc-0.9.1a-fix-segfaults.patch"
|
||||
|
||||
sed -i '/AC_PATH_XTRA/d' configure.ac
|
||||
sed -e 's/@X_CFLAGS@//g' \
|
||||
-e 's/@X_LIBS@//g' \
|
||||
-e 's/@X_PRE_LIBS@//g' \
|
||||
-e 's/@X_EXTRA_LIBS@//g' -i Makefile.am tools/Makefile.am
|
||||
|
||||
libtoolize
|
||||
autoreconf
|
||||
}
|
||||
|
||||
build() {
|
||||
cd "${srcdir}/lirc-${_pkgver}"
|
||||
|
||||
PYTHON=python2 ./configure --enable-sandboxed --prefix=/usr \
|
||||
--with-driver=userspace --sbindir=/usr/bin --with-transmitter
|
||||
|
||||
# Remove drivers already in kernel
|
||||
sed -e "s:lirc_dev::" -e "s:lirc_bt829::" -e "s:lirc_igorplugusb::" \
|
||||
-e "s:lirc_imon::" -e "s:lirc_parallel::" -e "s:lirc_sasem::" \
|
||||
-e "s:lirc_serial::" -e "s:lirc_sir::" -e "s:lirc_ttusbir::" \
|
||||
-e "s:lirc_atiusb::" -e "s:lirc_i2c::" \
|
||||
-i Makefile drivers/Makefile drivers/*/Makefile tools/Makefile
|
||||
make
|
||||
}
|
||||
|
||||
package_lirc() {
|
||||
pkgdesc="Linux Infrared Remote Control drivers"
|
||||
depends=('lirc-utils')
|
||||
replaces=('lirc+pctv')
|
||||
|
||||
cd "${srcdir}/lirc-${_pkgver}/drivers"
|
||||
|
||||
make DESTDIR="${pkgdir}" install
|
||||
}
|
||||
|
||||
package_lirc-utils() {
|
||||
pkgdesc="Linux Infrared Remote Control utils"
|
||||
depends=('alsa-lib' 'libx11' 'libftdi-compat' 'libirman')
|
||||
optdepends=('python2: pronto2lirc utility')
|
||||
options=('strip')
|
||||
backup=('etc/lirc/lirc_options.conf' 'etc/lirc/lircd.conf' 'etc/lirc/lircmd.conf')
|
||||
install=lirc-utils.install
|
||||
|
||||
cd "${srcdir}/lirc-${_pkgver}"
|
||||
|
||||
make DESTDIR="${pkgdir}" install
|
||||
|
||||
install -Dm644 "${srcdir}"/irexec.service "${pkgdir}"/usr/lib/systemd/system/irexec.service
|
||||
install -Dm644 "${srcdir}"/lirc.tmpfiles "${pkgdir}"/usr/lib/tmpfiles.d/lirc.conf
|
||||
|
||||
cp -rp remotes "${pkgdir}/usr/share/lirc"
|
||||
chmod -R go-w "${pkgdir}/usr/share/lirc/"
|
||||
|
||||
# install the logrotate config
|
||||
install -Dm644 "${srcdir}/lirc.logrotate" "${pkgdir}/etc/logrotate.d/lirc"
|
||||
}
|
|
@ -1,11 +0,0 @@
|
|||
[Unit]
|
||||
Description=LIRC command handler
|
||||
After=network.target
|
||||
|
||||
[Service]
|
||||
Type=forking
|
||||
ExecStart=/usr/bin/irexec --daemon
|
||||
|
||||
[Install]
|
||||
WantedBy=multi-user.target
|
||||
Wants=lircd.service
|
|
@ -1,79 +0,0 @@
|
|||
From 8459a881fd53525a47ae2f9180fa3644be5df343 Mon Sep 17 00:00:00 2001
|
||||
From: Alec Leamas <leamas@nowhere.net>
|
||||
Date: Mon, 18 Aug 2014 10:00:49 +0200
|
||||
Subject: [PATCH 1/3] Fix segfault when starting lircd (AUR 41581)
|
||||
|
||||
See https://bugs.archlinux.org/task/41581
|
||||
---
|
||||
lirc_options.conf | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/lirc_options.conf b/lirc_options.conf
|
||||
index d8ddedd..11293e2 100644
|
||||
--- a/lirc_options.conf
|
||||
+++ b/lirc_options.conf
|
||||
@@ -7,7 +7,7 @@ nodaemon = False
|
||||
permission = 666
|
||||
driver = default
|
||||
device = /dev/lirc0
|
||||
-output = /var/run/lirc/lircd
|
||||
+lircdfile = /var/run/lirc/lircd
|
||||
pidfile = /var/run/lirc/lircd.pid
|
||||
plugindir = /usr/lib/lirc/plugins
|
||||
allow-simulate = No
|
||||
--
|
||||
2.1.0
|
||||
|
||||
|
||||
From 4a9b45822890f50c5ed36660468e0a99cd4531e0 Mon Sep 17 00:00:00 2001
|
||||
From: Alec Leamas <leamas@nowhere.net>
|
||||
Date: Mon, 18 Aug 2014 10:05:44 +0200
|
||||
Subject: [PATCH 2/3] lircd: Fix bad default for lircdfile.
|
||||
|
||||
---
|
||||
daemons/lircd.c | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/daemons/lircd.c b/daemons/lircd.c
|
||||
index db8ea13..fa8cf17 100644
|
||||
--- a/daemons/lircd.c
|
||||
+++ b/daemons/lircd.c
|
||||
@@ -2147,7 +2147,7 @@ static void lircd_add_defaults(void)
|
||||
"lircd:device", LIRC_DRIVER_DEVICE,
|
||||
"lircd:listen", NULL ,
|
||||
"lircd:connect", NULL,
|
||||
- "lircd:output", LIRCD,
|
||||
+ "lircd:lircdfile", LIRCD,
|
||||
"lircd:pidfile", PIDFILE,
|
||||
"lircd:logfile", LOGFILE,
|
||||
"lircd:debug", "False",
|
||||
--
|
||||
2.1.0
|
||||
|
||||
|
||||
From 02252a9fe76c4a4fd809966971759c66af707f02 Mon Sep 17 00:00:00 2001
|
||||
From: Andreas Bader <andreasbader at badersystems.de>
|
||||
Date: Tue, 19 Aug 2014 16:58:21 +0200
|
||||
Subject: [PATCH 3/3] 0.9.1a: Bugfix: segfault when parsing --connect in config
|
||||
file.
|
||||
|
||||
---
|
||||
daemons/lircd.c | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/daemons/lircd.c b/daemons/lircd.c
|
||||
index fa8cf17..7af4265 100644
|
||||
--- a/daemons/lircd.c
|
||||
+++ b/daemons/lircd.c
|
||||
@@ -2311,7 +2311,7 @@ int main(int argc, char **argv)
|
||||
}
|
||||
opt = options_getstring("lircd:connect");
|
||||
if (opt != NULL) {
|
||||
- if (!add_peer_connection(optarg))
|
||||
+ if (!add_peer_connection(opt))
|
||||
return(EXIT_FAILURE);
|
||||
}
|
||||
# ifdef DEBUG
|
||||
--
|
||||
2.1.0
|
||||
|
|
@ -1,13 +0,0 @@
|
|||
post_install() {
|
||||
systemd-tmpfiles --create lirc.conf
|
||||
}
|
||||
|
||||
post_upgrade() {
|
||||
post_install
|
||||
|
||||
if [[ "$(vercmp $2 1:0.9.1-1)" -lt 0 ]]; then
|
||||
echo ':: lirc.service and lircm.service have been replaced'
|
||||
echo ' by the upstream unit files lircd.service and'
|
||||
echo ' lircmd.service.'
|
||||
fi
|
||||
}
|
|
@ -1,5 +0,0 @@
|
|||
/var/log/lircd {
|
||||
missingok
|
||||
notifempty
|
||||
delaycompress
|
||||
}
|
|
@ -1 +0,0 @@
|
|||
d /run/lirc 0755 root root -
|
|
@ -1,90 +0,0 @@
|
|||
diff --git a/drivers/lirc_wpc8769l/lirc_wpc8769l.c b/drivers/lirc_wpc8769l/lirc_wpc8769l.c
|
||||
index 790efa2..4248fe9 100644
|
||||
--- a/drivers/lirc_wpc8769l/lirc_wpc8769l.c
|
||||
+++ b/drivers/lirc_wpc8769l/lirc_wpc8769l.c
|
||||
@@ -51,17 +51,13 @@
|
||||
#include <linux/irq.h>
|
||||
|
||||
#include <linux/acpi.h>
|
||||
+#include <linux/types.h>
|
||||
|
||||
#include <linux/platform_device.h>
|
||||
+#include <asm-generic/bitops/find.h>
|
||||
|
||||
-#include "drivers/kcompat.h"
|
||||
-#if LINUX_VERSION_CODE > KERNEL_VERSION(2, 6, 35)
|
||||
-#include <media/lirc.h>
|
||||
-#include <media/lirc_dev.h>
|
||||
-#else
|
||||
-#include "drivers/lirc.h"
|
||||
-#include "drivers/lirc_dev/lirc_dev.h"
|
||||
-#endif
|
||||
+#include "media/lirc_dev.h"
|
||||
+#include "media/lirc.h"
|
||||
|
||||
#include "lirc_wpc8769l.h"
|
||||
|
||||
@@ -105,11 +101,11 @@ static unsigned int baseport2;
|
||||
static unsigned int irq;
|
||||
|
||||
/* Debugging flag. */
|
||||
-static int debug;
|
||||
+static bool debug;
|
||||
|
||||
/* If true, we skip ACPI autodetection and use the parameter-supplied I/O and
|
||||
* IRQ. */
|
||||
-static int skip_probe;
|
||||
+static bool skip_probe;
|
||||
|
||||
/* Whether the device is open or not. */
|
||||
static int lirc_wpc8769l_is_open;
|
||||
@@ -360,14 +356,14 @@ static irqreturn_t irq_handler(int irqno, void *blah, struct pt_regs *regs)
|
||||
size = count << 3;
|
||||
|
||||
ldata = (unsigned long *) data_buf;
|
||||
- next_one = generic_find_next_le_bit(ldata, size, 0);
|
||||
+ next_one = find_next_bit(ldata, size, 0);
|
||||
|
||||
if (next_one > 0)
|
||||
put_pulse_bit(next_one
|
||||
* WPC8769L_USECS_PER_BIT);
|
||||
|
||||
while (next_one < size) {
|
||||
- next_zero = generic_find_next_zero_le_bit(ldata,
|
||||
+ next_zero = find_next_zero_bit(ldata,
|
||||
size, next_one + 1);
|
||||
|
||||
put_space_bit(
|
||||
@@ -375,7 +371,7 @@ static irqreturn_t irq_handler(int irqno, void *blah, struct pt_regs *regs)
|
||||
* WPC8769L_USECS_PER_BIT);
|
||||
|
||||
if (next_zero < size) {
|
||||
- next_one = generic_find_next_le_bit(ldata,
|
||||
+ next_one = find_next_bit(ldata,
|
||||
size, next_zero + 1);
|
||||
|
||||
put_pulse_bit(
|
||||
@@ -922,12 +918,12 @@ static int wpc8769l_acpi_detect(void)
|
||||
#ifdef MODULE
|
||||
static struct platform_device *lirc_wpc8769l_platform_dev;
|
||||
|
||||
-static int __devinit lirc_wpc8769l_probe(struct platform_device *dev)
|
||||
+static int lirc_wpc8769l_probe(struct platform_device *dev)
|
||||
{
|
||||
return 0;
|
||||
}
|
||||
|
||||
-static int __devexit lirc_wpc8769l_remove(struct platform_device *dev)
|
||||
+static int lirc_wpc8769l_remove(struct platform_device *dev)
|
||||
{
|
||||
return 0;
|
||||
}
|
||||
@@ -955,7 +951,7 @@ static int lirc_wpc8769l_resume(struct platform_device *dev)
|
||||
|
||||
static struct platform_driver lirc_wpc8769l_platform_driver = {
|
||||
.probe = lirc_wpc8769l_probe,
|
||||
- .remove = __devexit_p(lirc_wpc8769l_remove),
|
||||
+ .remove = lirc_wpc8769l_remove,
|
||||
.suspend = lirc_wpc8769l_suspend,
|
||||
.resume = lirc_wpc8769l_resume,
|
||||
.driver = {
|
Loading…
Reference in a new issue