mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-01-17 23:34:07 +00:00
added core/isdn4k-utils
This commit is contained in:
parent
e768a37705
commit
7ae6e4bd0c
4 changed files with 213 additions and 0 deletions
72
core/isdn4k-utils/PKGBUILD
Normal file
72
core/isdn4k-utils/PKGBUILD
Normal file
|
@ -0,0 +1,72 @@
|
||||||
|
# $Id$
|
||||||
|
# Contributor: Dennis "Gyroplast" Herbrich <dennis@archlinux.org>, dorphell <dorphell@archlinux.org>
|
||||||
|
# Maintainer: Tobias Powalowski <tpowa@archlinux.org>
|
||||||
|
|
||||||
|
# ALARM: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||||
|
# - copy current config.{sub,guess} for AArch64
|
||||||
|
# - don't patch va_list.patch, breaks ARM builds
|
||||||
|
# - autoreconf in capiinfo and rcapid as well to fix intermittent build failures
|
||||||
|
|
||||||
|
pkgname=isdn4k-utils
|
||||||
|
pkgver=3.27
|
||||||
|
pkgrel=2
|
||||||
|
pkgdesc="User space administration programs and tools for ISDN"
|
||||||
|
arch=('i686' 'x86_64')
|
||||||
|
url="http://www.isdn4linux.de/"
|
||||||
|
license=('GPL')
|
||||||
|
makedepends=('git')
|
||||||
|
depends=('ncurses' 'sh')
|
||||||
|
backup=(etc/isdn/{callerid.conf,isdn.conf,rate.conf,isdnlog.isdnctrl0.options})
|
||||||
|
options=('!makeflags')
|
||||||
|
source=(isdn4k-utils::git+git://git.misdn.eu/isdn4k-utils.git#tag=v${pkgver}
|
||||||
|
config
|
||||||
|
gnu89-inline.patch
|
||||||
|
va_list.patch)
|
||||||
|
replaces=('capi4k-utils')
|
||||||
|
md5sums=('SKIP'
|
||||||
|
'ea3c71054234f9ef6bcf9325e36c4a38'
|
||||||
|
'165084a9096cc1ad043cc00a5cc05c0b'
|
||||||
|
'81709ee10336a2df684a5398f42ef514')
|
||||||
|
|
||||||
|
prepare() {
|
||||||
|
find . -name config.sub -exec chmod +w {} \; -exec cp /usr/share/libtool/build-aux/config.sub {} \;
|
||||||
|
find . -name config.guess -exec chmod +w {} \; -exec cp /usr/share/libtool/build-aux/config.guess {} \;
|
||||||
|
CPPFLAGS="$CPPFLAGS -O2"
|
||||||
|
cd $srcdir/$pkgname
|
||||||
|
patch -Np1 -i $srcdir/gnu89-inline.patch
|
||||||
|
#patch -Np1 -i $srcdir/va_list.patch
|
||||||
|
cp $srcdir/config ./.config
|
||||||
|
cd capiinfo
|
||||||
|
aclocal
|
||||||
|
automake --add-missing
|
||||||
|
autoreconf
|
||||||
|
cd $srcdir/$pkgname
|
||||||
|
cd capifax
|
||||||
|
aclocal
|
||||||
|
automake --add-missing
|
||||||
|
autoreconf
|
||||||
|
cd $srcdir/$pkgname
|
||||||
|
cd capiinfo
|
||||||
|
aclocal
|
||||||
|
automake --add-missing
|
||||||
|
autoreconf
|
||||||
|
cd $srcdir/$pkgname
|
||||||
|
cd rcapid
|
||||||
|
aclocal
|
||||||
|
automake --add-missing
|
||||||
|
autoreconf
|
||||||
|
cd $srcdir/$pkgname
|
||||||
|
make subconfig
|
||||||
|
}
|
||||||
|
|
||||||
|
build() {
|
||||||
|
cd $srcdir/$pkgname
|
||||||
|
make
|
||||||
|
}
|
||||||
|
|
||||||
|
package() {
|
||||||
|
cd $srcdir/$pkgname
|
||||||
|
install -dm755 $pkgdir/usr/bin
|
||||||
|
make DESTDIR=$pkgdir install
|
||||||
|
chmod 755 $pkgdir/usr/bin/*
|
||||||
|
}
|
102
core/isdn4k-utils/config
Normal file
102
core/isdn4k-utils/config
Normal file
|
@ -0,0 +1,102 @@
|
||||||
|
#
|
||||||
|
# Automatically generated by make menuconfig: don't edit
|
||||||
|
#
|
||||||
|
|
||||||
|
#
|
||||||
|
# Code maturity level options
|
||||||
|
#
|
||||||
|
CONFIG_EXPERIMENTAL=y
|
||||||
|
|
||||||
|
#
|
||||||
|
# General configuration
|
||||||
|
#
|
||||||
|
# CONFIG_BUILDX11 is not set
|
||||||
|
CONFIG_KERNELDIR='/usr/src/linux'
|
||||||
|
CONFIG_BINDIR='/usr/bin'
|
||||||
|
CONFIG_SBINDIR='/usr/bin'
|
||||||
|
CONFIG_LIBDIR='/usr/lib'
|
||||||
|
CONFIG_MANDIR='/usr/share/man'
|
||||||
|
CONFIG_RUNDIR='/var/run'
|
||||||
|
CONFIG_LOCKDIR='/var/lock'
|
||||||
|
CONFIG_LOCKFILE='LCK..'
|
||||||
|
CONFIG_I4LCONFDIR='/etc/isdn'
|
||||||
|
CONFIG_CONFFILE='isdn.conf'
|
||||||
|
CONFIG_CALLERIDFILE='callerid.conf'
|
||||||
|
CONFIG_USERCONFFILE='~/.isdn'
|
||||||
|
CONFIG_COUNTRYCODE='49'
|
||||||
|
CONFIG_AREACODE=''
|
||||||
|
CONFIG_COUNTRY_PREFIX='+'
|
||||||
|
CONFIG_AREA_PREFIX='0'
|
||||||
|
CONFIG_DATADIR='/usr/lib/isdn'
|
||||||
|
CONFIG_LIB_AREACODE=y
|
||||||
|
|
||||||
|
|
||||||
|
#
|
||||||
|
# Runtime configuration tools
|
||||||
|
#
|
||||||
|
CONFIG_ISDNCTRL=y
|
||||||
|
CONFIG_ISDNCTRL_CONF=y
|
||||||
|
CONFIG_ISDNCTRL_TIMRU=y
|
||||||
|
CONFIG_IPROFD=y
|
||||||
|
|
||||||
|
#
|
||||||
|
# Card configuration tools
|
||||||
|
#
|
||||||
|
# CONFIG_TELESCTRL is not set
|
||||||
|
CONFIG_HISAXCTRL=y
|
||||||
|
CONFIG_ICNCTRL=y
|
||||||
|
# CONFIG_ICNCTRL_DEBUG is not set
|
||||||
|
CONFIG_PCBITCTL=y
|
||||||
|
CONFIG_AVMCAPICTRL=y
|
||||||
|
# CONFIG_LOOPCTRL is not set
|
||||||
|
# CONFIG_LOOPCTRL_LOOPDIR='/usr/src/linux/drivers/isdn/isdnloop'
|
||||||
|
# CONFIG_LOOPCTRL_DEBUG is not set
|
||||||
|
|
||||||
|
|
||||||
|
#
|
||||||
|
# Tools for monitoring activity
|
||||||
|
#
|
||||||
|
CONFIG_IMON=y
|
||||||
|
CONFIG_IMONTTY=y
|
||||||
|
CONFIG_ISDNLOG=y
|
||||||
|
|
||||||
|
#
|
||||||
|
# Options for isdnlog package
|
||||||
|
#
|
||||||
|
CONFIG_ISDNLOG_SERV_PORT=20011
|
||||||
|
CONFIG_ISDNLOG_USERFILE='isdnlog.users'
|
||||||
|
CONFIG_ISDNLOG_CHARGEFILE='charge.dat'
|
||||||
|
CONFIG_ISDNLOG_LOGFILE='/var/log/isdn.log'
|
||||||
|
CONFIG_ISDNLOG_RELOADCMD='reload'
|
||||||
|
CONFIG_ISDNLOG_STOPCMD='stop'
|
||||||
|
CONFIG_ISDNLOG_REBOOTCMD='/sbin/reboot'
|
||||||
|
CONFIG_ISDNLOG_OLDI4LCONFDIR='/etc/isdnlog'
|
||||||
|
CONFIG_ISDNLOG_OLDI4LCONFFILE='isdnlog.conf'
|
||||||
|
# CONFIG_ISDNLOG_POSTGRES is not set
|
||||||
|
# CONFIG_ISDNLOG_MYSQLDB is not set
|
||||||
|
CONFIG_ISDN_LOG_DE=y
|
||||||
|
CONFIG_IPPPSTATS=y
|
||||||
|
# CONFIG_XISDNLOAD is not set
|
||||||
|
# CONFIG_XMONISDN is not set
|
||||||
|
|
||||||
|
#
|
||||||
|
# Applications
|
||||||
|
#
|
||||||
|
# CONFIG_VBOX is not set
|
||||||
|
CONFIG_IPPPD=y
|
||||||
|
|
||||||
|
#
|
||||||
|
# Options for ipppd
|
||||||
|
#
|
||||||
|
CONFIG_IPPPD_MSCHAP=y
|
||||||
|
# CONFIG_IPPPD_RADIUS is not set
|
||||||
|
# CONFIG_RADIUS_WTMP_LOGGING is not set
|
||||||
|
RADIUS_CLIENT_CONFIG_FILE=''
|
||||||
|
CONFIG_CAPIFAX=y
|
||||||
|
CONFIG_RCAPID=y
|
||||||
|
|
||||||
|
#
|
||||||
|
# Documentation
|
||||||
|
#
|
||||||
|
CONFIG_GENMAN=y
|
||||||
|
# CONFIG_FAQ is not set
|
18
core/isdn4k-utils/gnu89-inline.patch
Normal file
18
core/isdn4k-utils/gnu89-inline.patch
Normal file
|
@ -0,0 +1,18 @@
|
||||||
|
Description: fix build failure with GCC5:
|
||||||
|
build isdnlog with -fgnu89-inline
|
||||||
|
Origin: vendor
|
||||||
|
Bug-Debian: https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=777920
|
||||||
|
Author: gregor herrmann <gregoa@debian.org>
|
||||||
|
Last-Update: 2015-07-20
|
||||||
|
|
||||||
|
--- a/isdnlog/Makefile.in
|
||||||
|
+++ b/isdnlog/Makefile.in
|
||||||
|
@@ -1719,7 +1719,7 @@
|
||||||
|
|
||||||
|
# export CFLAGS = -Wall -pipe -O6 -fomit-frame-pointer -fforce-mem -fforce-addr -funroll-loops -fstrength-reduce
|
||||||
|
|
||||||
|
-export CFLAGS = -Wall -pipe
|
||||||
|
+export CFLAGS = -Wall -pipe -fgnu89-inline
|
||||||
|
ifndef _CC
|
||||||
|
export _CC = gcc
|
||||||
|
endif
|
21
core/isdn4k-utils/va_list.patch
Normal file
21
core/isdn4k-utils/va_list.patch
Normal file
|
@ -0,0 +1,21 @@
|
||||||
|
diff -u -r -N isdn4k-utils-3.25_20130409.orig/ipppd/main.c isdn4k-utils-3.25_20130409/ipppd/main.c
|
||||||
|
--- isdn4k-utils-3.25_20130409.orig/ipppd/main.c 2013-01-05 14:59:12.000000000 +0100
|
||||||
|
+++ isdn4k-utils-3.25_20130409/ipppd/main.c 2014-09-21 13:36:09.104294210 +0200
|
||||||
|
@@ -1205,7 +1205,7 @@
|
||||||
|
unsigned long val=0;
|
||||||
|
char *str, *f, *buf0;
|
||||||
|
unsigned char *p;
|
||||||
|
- va_list a;
|
||||||
|
+ void *a;
|
||||||
|
char num[32];
|
||||||
|
time_t t;
|
||||||
|
static char hexchars[] = "0123456789abcdef";
|
||||||
|
@@ -1297,7 +1297,7 @@
|
||||||
|
break;
|
||||||
|
case 'r':
|
||||||
|
f = va_arg(args, char *);
|
||||||
|
- a = va_arg(args, va_list);
|
||||||
|
+ a = va_arg(args, void *);
|
||||||
|
#ifdef __alpha__ /* always do this? */
|
||||||
|
n = fmtmsg(buf, buflen + 1, f, a);
|
||||||
|
#else
|
Loading…
Reference in a new issue