mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-03-09 00:17:31 +00:00
core/linux-aarch64 to 4.4.1-1
This commit is contained in:
parent
d0f43154bf
commit
7afc8fd6d8
2 changed files with 5 additions and 88 deletions
|
@ -7,32 +7,31 @@ pkgbase=linux-aarch64
|
|||
_srcname=linux-4.4
|
||||
_kernelname=${pkgbase#linux}
|
||||
_desc="AArch64 multi-platform"
|
||||
pkgver=4.4.0
|
||||
pkgrel=2
|
||||
pkgver=4.4.1
|
||||
pkgrel=1
|
||||
arch=('aarch64')
|
||||
url="http://www.kernel.org/"
|
||||
license=('GPL2')
|
||||
makedepends=('xmlto' 'docbook-xsl' 'kmod' 'inetutils' 'bc' 'git')
|
||||
options=('!strip')
|
||||
source=("http://www.kernel.org/pub/linux/kernel/v4.x/${_srcname}.tar.xz"
|
||||
#"http://www.kernel.org/pub/linux/kernel/v4.x/patch-${pkgver}.xz"
|
||||
"http://www.kernel.org/pub/linux/kernel/v4.x/patch-${pkgver}.xz"
|
||||
'0001-amd-xgbe-a0-Add-support-for-XGBE-on-A0.patch'
|
||||
'0002-amd-xgbe-phy-a0-Add-support-for-XGBE-PHY-on-A0.patch'
|
||||
'0003-arm64-acpi-drop-expert-patch.patch'
|
||||
'0004-devicetree-bindings-Document-qcom-msm-id-and-qcom-bo.patch'
|
||||
'0005-arm64-dts-Add-Qualcomm-MSM8916-MTP8916-ids.patch'
|
||||
'0006-arm64-dts-qcom-Add-APQ8016-SBC-support.patch'
|
||||
'kernel-CVE-2016-0728.patch'
|
||||
'config'
|
||||
'linux.preset')
|
||||
md5sums=('9a78fa2eb6c68ca5a40ed5af08142599'
|
||||
'd9e951895c8c249f0bf52d85f3e63bce'
|
||||
'90e8c4300d263db370eb2155ee1a4b42'
|
||||
'51c4dcc18641b9c4dfb824b98213c080'
|
||||
'dd04cf22c2b1dc946884cdb55efc6424'
|
||||
'2a052b7347d21f8813c09931ea0ef495'
|
||||
'4166c1a8edeec7eb8c7e69f42e561332'
|
||||
'1891555762fc267cf2cd7a9a6d01f70d'
|
||||
'6470e9783bd1c7a8feddc2d67f07afd5'
|
||||
'bcb7c0c453729f95b54dec819ccd8fb6'
|
||||
'b5ef67d6086e20de7b82265f562f88b1')
|
||||
|
||||
|
@ -40,7 +39,7 @@ prepare() {
|
|||
cd "${srcdir}/${_srcname}"
|
||||
|
||||
# add upstream patch
|
||||
#git apply --whitespace=nowarn ../patch-${pkgver}
|
||||
git apply --whitespace=nowarn ../patch-${pkgver}
|
||||
|
||||
# ALARM patches
|
||||
git apply ../0001-amd-xgbe-a0-Add-support-for-XGBE-on-A0.patch
|
||||
|
@ -49,7 +48,6 @@ prepare() {
|
|||
git apply ../0004-devicetree-bindings-Document-qcom-msm-id-and-qcom-bo.patch
|
||||
git apply ../0005-arm64-dts-Add-Qualcomm-MSM8916-MTP8916-ids.patch
|
||||
git apply ../0006-arm64-dts-qcom-Add-APQ8016-SBC-support.patch
|
||||
git apply ../kernel-CVE-2016-0728.patch
|
||||
|
||||
cat "${srcdir}/config" > ./.config
|
||||
|
||||
|
|
|
@ -1,81 +0,0 @@
|
|||
From 23567fd052a9abb6d67fe8e7a9ccdd9800a540f2 Mon Sep 17 00:00:00 2001
|
||||
From: Yevgeny Pats <yevgeny@perception-point.io>
|
||||
Date: Tue, 19 Jan 2016 22:09:04 +0000
|
||||
Subject: KEYS: Fix keyring ref leak in join_session_keyring()
|
||||
|
||||
This fixes CVE-2016-0728.
|
||||
|
||||
If a thread is asked to join as a session keyring the keyring that's already
|
||||
set as its session, we leak a keyring reference.
|
||||
|
||||
This can be tested with the following program:
|
||||
|
||||
#include <stddef.h>
|
||||
#include <stdio.h>
|
||||
#include <sys/types.h>
|
||||
#include <keyutils.h>
|
||||
|
||||
int main(int argc, const char *argv[])
|
||||
{
|
||||
int i = 0;
|
||||
key_serial_t serial;
|
||||
|
||||
serial = keyctl(KEYCTL_JOIN_SESSION_KEYRING,
|
||||
"leaked-keyring");
|
||||
if (serial < 0) {
|
||||
perror("keyctl");
|
||||
return -1;
|
||||
}
|
||||
|
||||
if (keyctl(KEYCTL_SETPERM, serial,
|
||||
KEY_POS_ALL | KEY_USR_ALL) < 0) {
|
||||
perror("keyctl");
|
||||
return -1;
|
||||
}
|
||||
|
||||
for (i = 0; i < 100; i++) {
|
||||
serial = keyctl(KEYCTL_JOIN_SESSION_KEYRING,
|
||||
"leaked-keyring");
|
||||
if (serial < 0) {
|
||||
perror("keyctl");
|
||||
return -1;
|
||||
}
|
||||
}
|
||||
|
||||
return 0;
|
||||
}
|
||||
|
||||
If, after the program has run, there something like the following line in
|
||||
/proc/keys:
|
||||
|
||||
3f3d898f I--Q--- 100 perm 3f3f0000 0 0 keyring leaked-keyring: empty
|
||||
|
||||
with a usage count of 100 * the number of times the program has been run,
|
||||
then the kernel is malfunctioning. If leaked-keyring has zero usages or
|
||||
has been garbage collected, then the problem is fixed.
|
||||
|
||||
Reported-by: Yevgeny Pats <yevgeny@perception-point.io>
|
||||
Signed-off-by: David Howells <dhowells@redhat.com>
|
||||
Acked-by: Don Zickus <dzickus@redhat.com>
|
||||
Acked-by: Prarit Bhargava <prarit@redhat.com>
|
||||
Acked-by: Jarod Wilson <jarod@redhat.com>
|
||||
Signed-off-by: James Morris <james.l.morris@oracle.com>
|
||||
---
|
||||
security/keys/process_keys.c | 1 +
|
||||
1 file changed, 1 insertion(+)
|
||||
|
||||
diff --git a/security/keys/process_keys.c b/security/keys/process_keys.c
|
||||
index a3f85d2..e6d50172 100644
|
||||
--- a/security/keys/process_keys.c
|
||||
+++ b/security/keys/process_keys.c
|
||||
@@ -794,6 +794,7 @@ long join_session_keyring(const char *name)
|
||||
ret = PTR_ERR(keyring);
|
||||
goto error2;
|
||||
} else if (keyring == new->session_keyring) {
|
||||
+ key_put(keyring);
|
||||
ret = 0;
|
||||
goto error2;
|
||||
}
|
||||
--
|
||||
cgit v0.12
|
||||
|
Loading…
Reference in a new issue