mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-03-19 00:21:40 +00:00
community/docker to 1.10.0-1
This commit is contained in:
parent
77e0733b96
commit
7b36248c5d
2 changed files with 4 additions and 68 deletions
|
@ -2,11 +2,10 @@
|
|||
# Maintainer: Sébastien "Seblu" Luttringer
|
||||
|
||||
# ALARM: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
# - backport BoltDB fixes for AArch64
|
||||
|
||||
pkgname=docker
|
||||
pkgver=1.9.1
|
||||
pkgrel=2
|
||||
pkgver=1.10.0
|
||||
pkgrel=1
|
||||
epoch=1
|
||||
pkgdesc='Pack, ship and run any application as a lightweight container'
|
||||
arch=('x86_64')
|
||||
|
@ -21,12 +20,10 @@ options=('!strip')
|
|||
install=$pkgname.install
|
||||
source=("git+https://github.com/docker/docker.git#tag=v$pkgver"
|
||||
"$pkgname.sysusers"
|
||||
'02-fix-unified-cgroup.patch'
|
||||
'aarch64.patch')
|
||||
'02-fix-unified-cgroup.patch')
|
||||
md5sums=('SKIP'
|
||||
'8cf9900ebada61f352a03465a088da34'
|
||||
'7fd0504057a60e1275b8ce3e06d53c53'
|
||||
'1e8d574b55c43a76d5a1d69a7c557d4f')
|
||||
'7fd0504057a60e1275b8ce3e06d53c53')
|
||||
|
||||
prepare() {
|
||||
for _f in "${source[@]}"; do
|
||||
|
|
|
@ -1,61 +0,0 @@
|
|||
diff --git a/vendor/src/github.com/boltdb/bolt/bolt_386.go b/vendor/src/github.com/boltdb/bolt/bolt_386.go
|
||||
index 856f401..d2e04a0 100644
|
||||
--- a/vendor/src/github.com/boltdb/bolt/bolt_386.go
|
||||
+++ b/vendor/src/github.com/boltdb/bolt/bolt_386.go
|
||||
@@ -2,3 +2,6 @@ package bolt
|
||||
|
||||
// maxMapSize represents the largest mmap size supported by Bolt.
|
||||
const maxMapSize = 0xFFFFFFF // 256MB
|
||||
+
|
||||
+// maxAllocSize is the size used when creating array pointers.
|
||||
+const maxAllocSize = 0xFFFFFFF
|
||||
diff --git a/vendor/src/github.com/boltdb/bolt/bolt_amd64.go b/vendor/src/github.com/boltdb/bolt/bolt_amd64.go
|
||||
index 4262932..cca6b7e 100644
|
||||
--- a/vendor/src/github.com/boltdb/bolt/bolt_amd64.go
|
||||
+++ b/vendor/src/github.com/boltdb/bolt/bolt_amd64.go
|
||||
@@ -2,3 +2,6 @@ package bolt
|
||||
|
||||
// maxMapSize represents the largest mmap size supported by Bolt.
|
||||
const maxMapSize = 0xFFFFFFFFFFFF // 256TB
|
||||
+
|
||||
+// maxAllocSize is the size used when creating array pointers.
|
||||
+const maxAllocSize = 0x7FFFFFFF
|
||||
diff --git a/vendor/src/github.com/boltdb/bolt/bolt_arm.go b/vendor/src/github.com/boltdb/bolt/bolt_arm.go
|
||||
index 856f401..d2e04a0 100644
|
||||
--- a/vendor/src/github.com/boltdb/bolt/bolt_arm.go
|
||||
+++ b/vendor/src/github.com/boltdb/bolt/bolt_arm.go
|
||||
@@ -2,3 +2,6 @@ package bolt
|
||||
|
||||
// maxMapSize represents the largest mmap size supported by Bolt.
|
||||
const maxMapSize = 0xFFFFFFF // 256MB
|
||||
+
|
||||
+// maxAllocSize is the size used when creating array pointers.
|
||||
+const maxAllocSize = 0xFFFFFFF
|
||||
diff --git a/vendor/src/github.com/boltdb/bolt/bolt_arm64.go b/vendor/src/github.com/boltdb/bolt/bolt_arm64.go
|
||||
new file mode 100644
|
||||
index 0000000..6d23093
|
||||
--- /dev/null
|
||||
+++ b/vendor/src/github.com/boltdb/bolt/bolt_arm64.go
|
||||
@@ -0,0 +1,9 @@
|
||||
+// +build arm64
|
||||
+
|
||||
+package bolt
|
||||
+
|
||||
+// maxMapSize represents the largest mmap size supported by Bolt.
|
||||
+const maxMapSize = 0xFFFFFFFFFFFF // 256TB
|
||||
+
|
||||
+// maxAllocSize is the size used when creating array pointers.
|
||||
+const maxAllocSize = 0x7FFFFFFF
|
||||
diff --git a/vendor/src/github.com/boltdb/bolt/page.go b/vendor/src/github.com/boltdb/bolt/page.go
|
||||
index b3dc473..58e43c4 100644
|
||||
--- a/vendor/src/github.com/boltdb/bolt/page.go
|
||||
+++ b/vendor/src/github.com/boltdb/bolt/page.go
|
||||
@@ -8,7 +8,6 @@ import (
|
||||
|
||||
const pageHeaderSize = int(unsafe.Offsetof(((*page)(nil)).ptr))
|
||||
|
||||
-const maxAllocSize = 0xFFFFFFF
|
||||
const minKeysPerPage = 2
|
||||
|
||||
const branchPageElementSize = int(unsafe.Sizeof(branchPageElement{}))
|
||||
|
Loading…
Reference in a new issue