mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-03-09 00:17:31 +00:00
extra/thunderbird fix
This commit is contained in:
parent
95ea43b586
commit
7b6ad68297
2 changed files with 105 additions and 105 deletions
|
@ -36,7 +36,7 @@ sha256sums=('b742782965ce9c65b69c1dc470497ea456f11caeb8fda3ea593ee31ad496f556'
|
|||
'd506b771e765e09e2e039b975e25befade8eec97e8950813a32463604955ab4e'
|
||||
'9049ab3f9600a1592a54c41a166c76e046c393e1cfe7c4e769155b7317d197ee'
|
||||
'e4ea8e6788163d9f8db8f1f40023db3ea0a1358f9a4510169f2d4c4fe6a887ed'
|
||||
'014a2f160c2f21b854d21c0ae5cd6ad7493586f03cae4399960f75570ee2ce92')
|
||||
'8010bc3abff71cdaa3624ebbddbc7baaae4cda7ad093ad60d3c3e841c1141872')
|
||||
|
||||
prepare() {
|
||||
cd comm-esr31
|
||||
|
|
|
@ -1,107 +1,3 @@
|
|||
--- mozilla/configure.orig 2014-07-22 18:38:00.711218733 -0600
|
||||
+++ mozilla/configure 2014-07-22 18:40:37.355699369 -0600
|
||||
@@ -6970,98 +6970,10 @@
|
||||
|
||||
|
||||
|
||||
-if test "$CPU_ARCH" = "arm"; then
|
||||
- echo $ac_n "checking for ARM SIMD support in compiler""... $ac_c" 1>&6
|
||||
-echo "configure:6976: checking for ARM SIMD support in compiler" >&5
|
||||
- # We try to link so that this also fails when
|
||||
- # building with LTO.
|
||||
- cat > conftest.$ac_ext <<EOF
|
||||
-#line 6980 "configure"
|
||||
-#include "confdefs.h"
|
||||
-
|
||||
-int main() {
|
||||
-asm("uqadd8 r1, r1, r2");
|
||||
-; return 0; }
|
||||
-EOF
|
||||
-if { (eval echo configure:6987: \"$ac_link\") 1>&5; (eval $ac_link) 2>&5; } && test -s conftest${ac_exeext}; then
|
||||
- rm -rf conftest*
|
||||
- result="yes"
|
||||
-else
|
||||
- echo "configure: failed program was:" >&5
|
||||
- cat conftest.$ac_ext >&5
|
||||
- rm -rf conftest*
|
||||
- result="no"
|
||||
-fi
|
||||
-rm -f conftest*
|
||||
- echo "$ac_t"""$result"" 1>&6
|
||||
- if test "$result" = "yes"; then
|
||||
- cat >> confdefs.pytmp <<\EOF
|
||||
- (''' HAVE_ARM_SIMD ''', ' 1 ')
|
||||
-EOF
|
||||
-cat >> confdefs.h <<\EOF
|
||||
-#define HAVE_ARM_SIMD 1
|
||||
-EOF
|
||||
-
|
||||
- HAVE_ARM_SIMD=1
|
||||
- fi
|
||||
-
|
||||
- echo $ac_n "checking ARM version support in compiler""... $ac_c" 1>&6
|
||||
-echo "configure:7010: checking ARM version support in compiler" >&5
|
||||
- ARM_ARCH=`${CC-cc} ${CFLAGS} -dM -E - < /dev/null | sed -n 's/.*__ARM_ARCH_\([0-9][0-9]*\).*/\1/p'`
|
||||
- echo "$ac_t"""$ARM_ARCH"" 1>&6
|
||||
-
|
||||
- echo $ac_n "checking for ARM NEON support in compiler""... $ac_c" 1>&6
|
||||
-echo "configure:7015: checking for ARM NEON support in compiler" >&5
|
||||
- # We try to link so that this also fails when
|
||||
- # building with LTO.
|
||||
- cat > conftest.$ac_ext <<EOF
|
||||
-#line 7019 "configure"
|
||||
-#include "confdefs.h"
|
||||
-
|
||||
-int main() {
|
||||
-asm(".fpu neon\n vadd.i8 d0, d0, d0");
|
||||
-; return 0; }
|
||||
-EOF
|
||||
-if { (eval echo configure:7026: \"$ac_link\") 1>&5; (eval $ac_link) 2>&5; } && test -s conftest${ac_exeext}; then
|
||||
- rm -rf conftest*
|
||||
- result="yes"
|
||||
-else
|
||||
- echo "configure: failed program was:" >&5
|
||||
- cat conftest.$ac_ext >&5
|
||||
- rm -rf conftest*
|
||||
- result="no"
|
||||
-fi
|
||||
-rm -f conftest*
|
||||
- echo "$ac_t"""$result"" 1>&6
|
||||
- if test "$result" = "yes"; then
|
||||
- cat >> confdefs.pytmp <<\EOF
|
||||
- (''' HAVE_ARM_NEON ''', ' 1 ')
|
||||
-EOF
|
||||
-cat >> confdefs.h <<\EOF
|
||||
-#define HAVE_ARM_NEON 1
|
||||
-EOF
|
||||
-
|
||||
- HAVE_ARM_NEON=1
|
||||
-
|
||||
- if test -n "$ARM_ARCH"; then
|
||||
- if test "$ARM_ARCH" -lt 7; then
|
||||
- BUILD_ARM_NEON=
|
||||
- else
|
||||
- cat >> confdefs.pytmp <<\EOF
|
||||
- (''' BUILD_ARM_NEON ''', ' 1 ')
|
||||
-EOF
|
||||
-cat >> confdefs.h <<\EOF
|
||||
-#define BUILD_ARM_NEON 1
|
||||
-EOF
|
||||
-
|
||||
- BUILD_ARM_NEON=1
|
||||
- fi
|
||||
- fi
|
||||
- fi
|
||||
-
|
||||
-fi # CPU_ARCH = arm
|
||||
-
|
||||
|
||||
+HAVE_ARM_NEON=0
|
||||
+BUILD_ARM_NEON=0
|
||||
+HAVE_ARM_SIMD=0
|
||||
|
||||
|
||||
|
||||
--- mozilla/js/src/configure.orig 2014-07-22 18:38:00.736218651 -0600
|
||||
+++ mozilla/js/src/configure 2014-07-22 18:41:43.420479891 -0600
|
||||
@@ -6153,99 +6153,9 @@
|
||||
|
@ -207,3 +103,107 @@
|
|||
|
||||
|
||||
|
||||
--- mozilla/configure.orig 2014-12-17 17:29:25.130301121 -0700
|
||||
+++ mozilla/configure 2014-12-17 17:30:11.155242482 -0700
|
||||
@@ -6975,98 +6975,9 @@
|
||||
|
||||
|
||||
|
||||
-if test "$CPU_ARCH" = "arm"; then
|
||||
- echo $ac_n "checking for ARM SIMD support in compiler""... $ac_c" 1>&6
|
||||
-echo "configure:6981: checking for ARM SIMD support in compiler" >&5
|
||||
- # We try to link so that this also fails when
|
||||
- # building with LTO.
|
||||
- cat > conftest.$ac_ext <<EOF
|
||||
-#line 6985 "configure"
|
||||
-#include "confdefs.h"
|
||||
-
|
||||
-int main() {
|
||||
-asm("uqadd8 r1, r1, r2");
|
||||
-; return 0; }
|
||||
-EOF
|
||||
-if { (eval echo configure:6992: \"$ac_link\") 1>&5; (eval $ac_link) 2>&5; } && test -s conftest${ac_exeext}; then
|
||||
- rm -rf conftest*
|
||||
- result="yes"
|
||||
-else
|
||||
- echo "configure: failed program was:" >&5
|
||||
- cat conftest.$ac_ext >&5
|
||||
- rm -rf conftest*
|
||||
- result="no"
|
||||
-fi
|
||||
-rm -f conftest*
|
||||
- echo "$ac_t"""$result"" 1>&6
|
||||
- if test "$result" = "yes"; then
|
||||
- cat >> confdefs.pytmp <<\EOF
|
||||
- (''' HAVE_ARM_SIMD ''', ' 1 ')
|
||||
-EOF
|
||||
-cat >> confdefs.h <<\EOF
|
||||
-#define HAVE_ARM_SIMD 1
|
||||
-EOF
|
||||
-
|
||||
- HAVE_ARM_SIMD=1
|
||||
- fi
|
||||
-
|
||||
- echo $ac_n "checking ARM version support in compiler""... $ac_c" 1>&6
|
||||
-echo "configure:7015: checking ARM version support in compiler" >&5
|
||||
- ARM_ARCH=`${CC-cc} ${CFLAGS} -dM -E - < /dev/null | sed -n 's/.*__ARM_ARCH_\([0-9][0-9]*\).*/\1/p'`
|
||||
- echo "$ac_t"""$ARM_ARCH"" 1>&6
|
||||
-
|
||||
- echo $ac_n "checking for ARM NEON support in compiler""... $ac_c" 1>&6
|
||||
-echo "configure:7020: checking for ARM NEON support in compiler" >&5
|
||||
- # We try to link so that this also fails when
|
||||
- # building with LTO.
|
||||
- cat > conftest.$ac_ext <<EOF
|
||||
-#line 7024 "configure"
|
||||
-#include "confdefs.h"
|
||||
-
|
||||
-int main() {
|
||||
-asm(".fpu neon\n vadd.i8 d0, d0, d0");
|
||||
-; return 0; }
|
||||
-EOF
|
||||
-if { (eval echo configure:7031: \"$ac_link\") 1>&5; (eval $ac_link) 2>&5; } && test -s conftest${ac_exeext}; then
|
||||
- rm -rf conftest*
|
||||
- result="yes"
|
||||
-else
|
||||
- echo "configure: failed program was:" >&5
|
||||
- cat conftest.$ac_ext >&5
|
||||
- rm -rf conftest*
|
||||
- result="no"
|
||||
-fi
|
||||
-rm -f conftest*
|
||||
- echo "$ac_t"""$result"" 1>&6
|
||||
- if test "$result" = "yes"; then
|
||||
- cat >> confdefs.pytmp <<\EOF
|
||||
- (''' HAVE_ARM_NEON ''', ' 1 ')
|
||||
-EOF
|
||||
-cat >> confdefs.h <<\EOF
|
||||
-#define HAVE_ARM_NEON 1
|
||||
-EOF
|
||||
-
|
||||
- HAVE_ARM_NEON=1
|
||||
-
|
||||
- if test -n "$ARM_ARCH"; then
|
||||
- if test "$ARM_ARCH" -lt 7; then
|
||||
- BUILD_ARM_NEON=
|
||||
- else
|
||||
- cat >> confdefs.pytmp <<\EOF
|
||||
- (''' BUILD_ARM_NEON ''', ' 1 ')
|
||||
-EOF
|
||||
-cat >> confdefs.h <<\EOF
|
||||
-#define BUILD_ARM_NEON 1
|
||||
-EOF
|
||||
-
|
||||
- BUILD_ARM_NEON=1
|
||||
- fi
|
||||
- fi
|
||||
- fi
|
||||
-
|
||||
-fi # CPU_ARCH = arm
|
||||
-
|
||||
-
|
||||
+HAVE_ARM_NEON=0
|
||||
+BUILD_ARM_NEON=0
|
||||
+HAVE_ARM_SIMD=0
|
||||
|
||||
|
||||
|
||||
|
|
Loading…
Reference in a new issue