mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-02-16 23:57:11 +00:00
extra/qt5 to 5.5.1-9
This commit is contained in:
parent
0a0995f1a0
commit
7b9c61da3b
2 changed files with 1 additions and 54 deletions
|
@ -41,7 +41,7 @@ pkgname=('qt5-3d'
|
|||
'qt5-x11extras'
|
||||
'qt5-xmlpatterns')
|
||||
pkgver=5.5.1
|
||||
pkgrel=8
|
||||
pkgrel=9
|
||||
arch=('i686' 'x86_64')
|
||||
url='http://www.qt.io/developers'
|
||||
license=('GPL3' 'LGPL' 'FDL' 'custom')
|
||||
|
@ -56,7 +56,6 @@ groups=('qt' 'qt5')
|
|||
_pkgfqn="qt-everywhere-opensource-src-${pkgver}"
|
||||
source=("http://download.qt-project.org/official_releases/qt/${pkgver%.*}/${pkgver}/single/${_pkgfqn}.tar.xz"
|
||||
'assistant.desktop' 'designer.desktop' 'linguist.desktop' 'qdbusviewer.desktop'
|
||||
'fs47703.patch'
|
||||
'qt5webkit-0002-Fix-QtWebKit-build-on-ARM-softfp.patch'
|
||||
'0001-Add-ARM-64-support.patch')
|
||||
md5sums=('65d5282f3dee0336da9ed1f77148952f'
|
||||
|
@ -64,14 +63,11 @@ md5sums=('65d5282f3dee0336da9ed1f77148952f'
|
|||
'76e150b20178d2d43801f7367232e5f7'
|
||||
'188da8f4c87316e730ebf1c6217bf5a0'
|
||||
'322b419b16c75d4de0ee7ad0a246caa1'
|
||||
'e710bb841ba2919bd3c9e10c80d67b0b'
|
||||
'd55ad1f1c90725834b44eada5db4e401')
|
||||
|
||||
prepare() {
|
||||
cd ${_pkgfqn}
|
||||
|
||||
(cd qtbase; patch -p1 -i "$srcdir"/fs47703.patch)
|
||||
|
||||
# Build qmake using Arch {C,LD}FLAGS
|
||||
# This also sets default {C,CXX,LD}FLAGS for projects built using qmake
|
||||
sed -i -e "s|^\(QMAKE_CFLAGS_RELEASE.*\)|\1 ${CFLAGS}|" \
|
||||
|
|
|
@ -1,49 +0,0 @@
|
|||
From f6ba546d57018ddd2bfdc226db498f12a0c2d8bf Mon Sep 17 00:00:00 2001
|
||||
From: =?utf8?q?D=C4=81vis=20Mos=C4=81ns?= <davispuh@gmail.com>
|
||||
Date: Fri, 8 Jan 2016 04:12:13 +0200
|
||||
Subject: [PATCH] Don't pass NULL Display to glXGetClientString
|
||||
|
||||
glXGetCurrentDisplay can return NULL so need to check
|
||||
for that.
|
||||
|
||||
Change-Id: I1b85a5c575d1deb24dcce4719b6f737283adeabe
|
||||
---
|
||||
.../platforms/xcb/gl_integrations/xcb_glx/qglxintegration.cpp | 5 ++++-
|
||||
.../platforms/xcb/gl_integrations/xcb_glx/qxcbglxintegration.cpp | 5 ++++-
|
||||
2 files changed, 8 insertions(+), 2 deletions(-)
|
||||
|
||||
diff --git a/src/plugins/platforms/xcb/gl_integrations/xcb_glx/qglxintegration.cpp b/src/plugins/platforms/xcb/gl_integrations/xcb_glx/qglxintegration.cpp
|
||||
index 8b14fc7..3412f3f 100644
|
||||
--- a/src/plugins/platforms/xcb/gl_integrations/xcb_glx/qglxintegration.cpp
|
||||
+++ b/src/plugins/platforms/xcb/gl_integrations/xcb_glx/qglxintegration.cpp
|
||||
@@ -644,7 +644,10 @@ void QGLXContext::queryDummyContext()
|
||||
oldSurface = oldContext->surface();
|
||||
|
||||
QScopedPointer<QSurface> surface;
|
||||
- const char *glxvendor = glXGetClientString(glXGetCurrentDisplay(), GLX_VENDOR);
|
||||
+ Display *display = glXGetCurrentDisplay();
|
||||
+ const char *glxvendor = 0;
|
||||
+ if (display)
|
||||
+ glxvendor = glXGetClientString(display, GLX_VENDOR);
|
||||
if (glxvendor && !strcmp(glxvendor, "ATI")) {
|
||||
QWindow *window = new QWindow;
|
||||
window->resize(64, 64);
|
||||
diff --git a/src/plugins/platforms/xcb/gl_integrations/xcb_glx/qxcbglxintegration.cpp b/src/plugins/platforms/xcb/gl_integrations/xcb_glx/qxcbglxintegration.cpp
|
||||
index ce72cb6..cd4949af 100644
|
||||
--- a/src/plugins/platforms/xcb/gl_integrations/xcb_glx/qxcbglxintegration.cpp
|
||||
+++ b/src/plugins/platforms/xcb/gl_integrations/xcb_glx/qxcbglxintegration.cpp
|
||||
@@ -195,7 +195,10 @@ QPlatformOffscreenSurface *QXcbGlxIntegration::createPlatformOffscreenSurface(QO
|
||||
static bool glxPbufferUsable = true;
|
||||
if (!vendorChecked) {
|
||||
vendorChecked = true;
|
||||
- const char *glxvendor = glXGetClientString(glXGetCurrentDisplay(), GLX_VENDOR);
|
||||
+ Display *display = glXGetCurrentDisplay();
|
||||
+ const char *glxvendor = 0;
|
||||
+ if (display)
|
||||
+ glxvendor = glXGetClientString(display, GLX_VENDOR);
|
||||
if (glxvendor && !strcmp(glxvendor, "ATI"))
|
||||
glxPbufferUsable = false;
|
||||
}
|
||||
--
|
||||
2.6.2.2.g1b5ffa3
|
||||
|
Loading…
Reference in a new issue