mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-01-17 23:34:07 +00:00
extra/ffmpeg to 2.2-3
This commit is contained in:
parent
e32864d505
commit
7bf3cd21d3
2 changed files with 60 additions and 3 deletions
50
extra/ffmpeg/0001-libx265-Support-API-version-9.patch
Normal file
50
extra/ffmpeg/0001-libx265-Support-API-version-9.patch
Normal file
|
@ -0,0 +1,50 @@
|
|||
From d67dbfa7c195fabce706ca03c439419450f9bd8a Mon Sep 17 00:00:00 2001
|
||||
From: Derek Buitenhuis <derek.buitenhuis@gmail.com>
|
||||
Date: Thu, 6 Mar 2014 20:01:17 +0000
|
||||
Subject: [PATCH] libx265: Support API version 9
|
||||
|
||||
Signed-off-by: Derek Buitenhuis <derek.buitenhuis@gmail.com>
|
||||
---
|
||||
configure | 4 ++--
|
||||
libavcodec/libx265.c | 10 +++++-----
|
||||
2 files changed, 7 insertions(+), 7 deletions(-)
|
||||
|
||||
diff --git a/configure b/configure
|
||||
index d3f5f33..4d7382a 100755
|
||||
--- a/configure
|
||||
+++ b/configure
|
||||
@@ -3980,8 +3980,8 @@ enabled libx264 && require libx264 x264.h x264_encoder_encode -lx264 &
|
||||
{ check_cpp_condition x264.h "X264_BUILD >= 118" ||
|
||||
die "ERROR: libx264 version must be >= 0.118."; }
|
||||
enabled libx265 && require_pkg_config x265 x265.h x265_encoder_encode &&
|
||||
- { check_cpp_condition x265.h "X265_BUILD >= 7" ||
|
||||
- die "ERROR: libx265 version must be >= 7."; }
|
||||
+ { check_cpp_condition x265.h "X265_BUILD >= 9" ||
|
||||
+ die "ERROR: libx265 version must be >= 9."; }
|
||||
enabled libxavs && require libxavs xavs.h xavs_encoder_encode -lxavs
|
||||
enabled libxvid && require libxvid xvid.h xvid_global -lxvidcore
|
||||
enabled openssl && { check_lib openssl/ssl.h SSL_library_init -lssl -lcrypto ||
|
||||
diff --git a/libavcodec/libx265.c b/libavcodec/libx265.c
|
||||
index 961fc74..a6e4193 100644
|
||||
--- a/libavcodec/libx265.c
|
||||
+++ b/libavcodec/libx265.c
|
||||
@@ -121,11 +121,11 @@ static av_cold int libx265_encode_init(AVCodecContext *avctx)
|
||||
av_reduce(&sar_num, &sar_den,
|
||||
avctx->sample_aspect_ratio.num,
|
||||
avctx->sample_aspect_ratio.den, 4096);
|
||||
- ctx->params->bEnableVuiParametersPresentFlag = 1;
|
||||
- ctx->params->bEnableAspectRatioIdc = 1;
|
||||
- ctx->params->aspectRatioIdc = 255;
|
||||
- ctx->params->sarWidth = sar_num;
|
||||
- ctx->params->sarHeight = sar_den;
|
||||
+ ctx->params->vui.bEnableVuiParametersPresentFlag = 1;
|
||||
+ ctx->params->vui.bEnableAspectRatioIdc = 1;
|
||||
+ ctx->params->vui.aspectRatioIdc = 255;
|
||||
+ ctx->params->vui.sarWidth = sar_num;
|
||||
+ ctx->params->vui.sarHeight = sar_den;
|
||||
|
||||
if (x265_max_bit_depth == 8)
|
||||
ctx->params->internalBitDepth = 8;
|
||||
--
|
||||
1.7.10.4
|
||||
|
|
@ -9,7 +9,7 @@
|
|||
|
||||
pkgname=ffmpeg
|
||||
pkgver=2.2
|
||||
pkgrel=2
|
||||
pkgrel=3
|
||||
epoch=1
|
||||
pkgdesc='Complete and free Internet live audio and video broadcasting solution'
|
||||
arch=('i686' 'x86_64')
|
||||
|
@ -22,9 +22,16 @@ depends=(
|
|||
'v4l-utils' 'x264' 'xvidcore' 'zlib'
|
||||
)
|
||||
makedepends=('libvdpau' 'yasm')
|
||||
source=(http://ffmpeg.org/releases/$pkgname-$pkgver.tar.bz2{,.asc})
|
||||
source=(http://ffmpeg.org/releases/$pkgname-$pkgver.tar.bz2{,.asc}
|
||||
0001-libx265-Support-API-version-9.patch)
|
||||
md5sums=('744febca199548c9393b1f1ed05ccdd8'
|
||||
'SKIP')
|
||||
'SKIP'
|
||||
'4cbf9b13dc013e96be36445b4a2bfdac')
|
||||
|
||||
prepare() {
|
||||
cd $pkgname-$pkgver
|
||||
patch -p1 -i ../0001-libx265-Support-API-version-9.patch
|
||||
}
|
||||
|
||||
build() {
|
||||
cd $pkgname-$pkgver
|
||||
|
|
Loading…
Reference in a new issue