mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-02-16 23:57:11 +00:00
core/nss: fixes
This commit is contained in:
parent
a3672d062a
commit
7c21ed9a80
4 changed files with 39 additions and 75 deletions
|
@ -1,26 +1,27 @@
|
|||
From 2c0b3e4dd3a9552a91ec641fe8c8653575200221 Mon Sep 17 00:00:00 2001
|
||||
From 3b781b8f1dba56fc7782e6837defc7d77ffa5a2f Mon Sep 17 00:00:00 2001
|
||||
From: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
Date: Fri, 24 Jan 2020 17:43:14 -0700
|
||||
Date: Sun, 3 May 2020 13:15:03 -0600
|
||||
Subject: [PATCH 1/2] Don't USE_ARM_GCM
|
||||
|
||||
---
|
||||
lib/freebl/gcm.c | 3 ---
|
||||
1 file changed, 3 deletions(-)
|
||||
lib/freebl/gcm.c | 4 ----
|
||||
1 file changed, 4 deletions(-)
|
||||
|
||||
diff --git a/lib/freebl/gcm.c b/lib/freebl/gcm.c
|
||||
index 2a42f74c0..e0051fa11 100644
|
||||
index c2cc18d91..c599031f1 100644
|
||||
--- a/lib/freebl/gcm.c
|
||||
+++ b/lib/freebl/gcm.c
|
||||
@@ -21,9 +21,6 @@
|
||||
@@ -22,10 +22,6 @@
|
||||
#if defined(__aarch64__) && defined(IS_LITTLE_ENDIAN) && \
|
||||
(defined(__clang__) || defined(__GNUC__) && __GNUC__ > 6)
|
||||
#define USE_ARM_GCM
|
||||
-#elif defined(__arm__) && defined(IS_LITTLE_ENDIAN)
|
||||
-#elif defined(__arm__) && defined(IS_LITTLE_ENDIAN) && \
|
||||
- !defined(NSS_DISABLE_ARM32_NEON)
|
||||
-/* We don't test on big endian platform, so disable this on big endian. */
|
||||
-#define USE_ARM_GCM
|
||||
#endif
|
||||
|
||||
/* Forward declarations */
|
||||
--
|
||||
2.24.1
|
||||
2.26.2
|
||||
|
||||
|
|
|
@ -1,62 +0,0 @@
|
|||
From f62b1533d570b867a817c5361b9d205f616fb2be Mon Sep 17 00:00:00 2001
|
||||
From: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
Date: Fri, 24 Jan 2020 17:52:55 -0700
|
||||
Subject: [PATCH 2/2] disable arm neon
|
||||
|
||||
---
|
||||
coreconf/config.gypi | 1 +
|
||||
lib/freebl/freebl.gyp | 8 ++++----
|
||||
2 files changed, 5 insertions(+), 4 deletions(-)
|
||||
|
||||
diff --git a/coreconf/config.gypi b/coreconf/config.gypi
|
||||
index c07a59ab2..28fd8cd48 100644
|
||||
--- a/coreconf/config.gypi
|
||||
+++ b/coreconf/config.gypi
|
||||
@@ -97,6 +97,7 @@
|
||||
'cc_use_gnu_ld%': '<(cc_use_gnu_ld)',
|
||||
# Some defaults
|
||||
'disable_arm_hw_aes%': 0,
|
||||
+ 'disable_arm_neon%': 0,
|
||||
'disable_tests%': 0,
|
||||
'disable_chachapoly%': 0,
|
||||
'disable_dbm%': 1,
|
||||
diff --git a/lib/freebl/freebl.gyp b/lib/freebl/freebl.gyp
|
||||
index d01531ad1..4835dcc60 100644
|
||||
--- a/lib/freebl/freebl.gyp
|
||||
+++ b/lib/freebl/freebl.gyp
|
||||
@@ -101,7 +101,7 @@
|
||||
],
|
||||
},
|
||||
}],
|
||||
- [ 'target_arch=="arm"', {
|
||||
+ [ 'disable_arm_neon==0 and target_arch=="arm"', {
|
||||
# Gecko doesn't support non-NEON platform on Android, but tier-3
|
||||
# platform such as Linux/arm will need it
|
||||
'cflags_mozilla': [
|
||||
@@ -264,7 +264,7 @@
|
||||
'armv8_c_lib'
|
||||
],
|
||||
}],
|
||||
- [ 'target_arch=="arm"', {
|
||||
+ [ 'disable_arm_neon==0 and target_arch=="arm"', {
|
||||
'dependencies': [
|
||||
'gcm-aes-arm32-neon_c_lib',
|
||||
],
|
||||
@@ -315,12 +315,12 @@
|
||||
'dependencies': [
|
||||
'gcm-aes-x86_c_lib',
|
||||
]
|
||||
- }, 'target_arch=="arm" or target_arch=="arm64" or target_arch=="aarch64"', {
|
||||
+ }, 'disable_arm_hw_aes==0 and (target_arch=="arm" or target_arch=="arm64" or target_arch=="aarch64")', {
|
||||
'dependencies': [
|
||||
'armv8_c_lib',
|
||||
],
|
||||
}],
|
||||
- [ 'target_arch=="arm"', {
|
||||
+ [ 'disable_arm_neon==0 and target_arch=="arm"', {
|
||||
'dependencies': [
|
||||
'gcm-aes-arm32-neon_c_lib',
|
||||
],
|
||||
--
|
||||
2.24.1
|
||||
|
25
core/nss/0002-fix-armv8_c_lib-dependency.patch
Normal file
25
core/nss/0002-fix-armv8_c_lib-dependency.patch
Normal file
|
@ -0,0 +1,25 @@
|
|||
From 17aba1ccad12ea361d04fd60cda1b12f75cbd8ac Mon Sep 17 00:00:00 2001
|
||||
From: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
Date: Sun, 3 May 2020 13:08:54 -0600
|
||||
Subject: [PATCH 2/2] fix armv8_c_lib dependency
|
||||
|
||||
---
|
||||
lib/freebl/freebl.gyp | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/lib/freebl/freebl.gyp b/lib/freebl/freebl.gyp
|
||||
index dd9446da6..779c8951e 100644
|
||||
--- a/lib/freebl/freebl.gyp
|
||||
+++ b/lib/freebl/freebl.gyp
|
||||
@@ -452,7 +452,7 @@
|
||||
'dependencies': [
|
||||
'gcm-aes-x86_c_lib',
|
||||
]
|
||||
- }, 'target_arch=="arm" or target_arch=="arm64" or target_arch=="aarch64"', {
|
||||
+ }, 'disable_arm_hw_aes==0 and (target_arch=="arm" or target_arch=="arm64" or target_arch=="aarch64")', {
|
||||
'dependencies': [
|
||||
'armv8_c_lib',
|
||||
],
|
||||
--
|
||||
2.26.2
|
||||
|
|
@ -18,12 +18,12 @@ makedepends=(perl python gyp)
|
|||
source=("https://ftp.mozilla.org/pub/security/nss/releases/NSS_${pkgver//./_}_RTM/src/nss-${pkgver}.tar.gz"
|
||||
certdata2pem.py bundle.sh
|
||||
0001-Don-t-USE_ARM_GCM.patch
|
||||
0002-disable-arm-neon.patch)
|
||||
0002-fix-armv8_c_lib-dependency.patch)
|
||||
sha256sums=('0a0aeb0cdda65ddcb64f746223df58b150f6803f4bfa1a4e876bbe6f9c4c1561'
|
||||
'd2a1579dae05fd16175fac27ef08b54731ecefdf414085c610179afcf62b096c'
|
||||
'3bfadf722da6773bdabdd25bdf78158648043d1b7e57615574f189a88ca865dd'
|
||||
'a25f7dc6c9233d729e3d8f2c30e839371feec63dcd2f805d138fe51ca54637a4'
|
||||
'cb34218332a4a4a84436f3a805caec92fc6ece6ae33759a82117b3cd30719408')
|
||||
'eccc7447d4fdbd1975bf65aef648df3a483d7bb4e458849ddd5dcaf4697771d2'
|
||||
'19bfdc8b1226ce1483280a7c7d8c700f18d3dd3689f9e1e96b448b61dd000c09')
|
||||
|
||||
prepare() {
|
||||
mkdir certs
|
||||
|
@ -34,7 +34,7 @@ prepare() {
|
|||
|
||||
cd nss
|
||||
patch -p1 -i "${srcdir}"/0001-Don-t-USE_ARM_GCM.patch
|
||||
patch -p1 -i "${srcdir}"/0002-disable-arm-neon.patch
|
||||
patch -p1 -i "${srcdir}"/0002-fix-armv8_c_lib-dependency.patch
|
||||
}
|
||||
|
||||
build() {
|
||||
|
@ -47,7 +47,7 @@ build() {
|
|||
./bundle.sh
|
||||
|
||||
cd nss-$pkgver/nss
|
||||
./build.sh -v --opt --system-sqlite --system-nspr --enable-libpkix --disable-tests -Ddisable_arm_neon=1 -Ddisable_arm_hw_aes=1
|
||||
./build.sh -v --opt --system-sqlite --system-nspr --enable-libpkix --disable-tests -Ddisable_arm32_neon=1 -Ddisable_arm_hw_aes=1
|
||||
}
|
||||
|
||||
package_nss() {
|
||||
|
|
Loading…
Reference in a new issue