mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-02-16 23:57:11 +00:00
community/python-autobahn to 19.11.2-1
This commit is contained in:
parent
5fe622cda2
commit
7c5f64d1c2
2 changed files with 27 additions and 9 deletions
|
@ -6,8 +6,8 @@
|
|||
# - removed AUTOBAHN_USE_NVX=1 from python build/install commands
|
||||
|
||||
pkgname=python-autobahn
|
||||
pkgver=19.11.1
|
||||
pkgrel=2
|
||||
pkgver=19.11.2
|
||||
pkgrel=1
|
||||
pkgdesc='Real-time framework for Web, Mobile & Internet of Things'
|
||||
arch=(x86_64)
|
||||
url='https://crossbar.io/autobahn/'
|
||||
|
@ -29,15 +29,16 @@ optdepends=(
|
|||
'python-pytrie: WAMP-cryptobox support'
|
||||
)
|
||||
|
||||
source=(https://files.pythonhosted.org/packages/source/a/autobahn/autobahn-$pkgver.tar.gz)
|
||||
sha256sums=('201b9879b49c6e259d4126dbafe9e3c73807de0c242d50065fbebc62c6ccb181')
|
||||
source=(https://files.pythonhosted.org/packages/source/a/autobahn/autobahn-$pkgver.tar.gz
|
||||
pytest-compatibility.diff)
|
||||
sha256sums=('64fa063b3a1ab16588037d4713f13f66167f7ad2a2e95fd675decbc3bc85c089'
|
||||
'07af16d4f41f5cccb269ccce0c887d347f9158e25002a638071b178130add8c4')
|
||||
|
||||
prepare() {
|
||||
cd "$srcdir/autobahn-$pkgver"
|
||||
# test_depleting checks whether the entropy on the running machine can be depleted or not.
|
||||
# Unrelated to autobahn and makes the test suite flaky
|
||||
sed -i -r 's/^(\s*)(def test_depleting)/\1@unittest.skip("flaky")\n\1\2/' autobahn/test/test_rng.py
|
||||
patch -Np1 -i ../pytest-compatibility.diff
|
||||
}
|
||||
|
||||
build() {
|
||||
cd "$srcdir/autobahn-$pkgver"
|
||||
python setup.py build
|
||||
|
@ -46,8 +47,12 @@ build() {
|
|||
check() {
|
||||
cd "$srcdir/autobahn-$pkgver"
|
||||
pyver=$(python -c "import sys; print('{}.{}'.format(*sys.version_info[:2]))")
|
||||
USE_TWISTED=1 PYTHONPATH=.:build/lib.linux-$CARCH-$pyver trial3 autobahn
|
||||
USE_ASYNCIO=1 PYTHONPATH=.:build/lib.linux-$CARCH-$pyver pytest -v autobahn
|
||||
# test_depleting checks whether the entropy on the running machine can be depleted or not.
|
||||
# Unrelated to autobahn and makes the test suite flaky
|
||||
# Now test_non_depleting is also flaky :(
|
||||
# https://github.com/crossbario/autobahn-python/issues/1278
|
||||
USE_TWISTED=1 PYTHONPATH=.:build/lib.linux-$CARCH-$pyver pytest -v autobahn --ignore=autobahn/test/test_rng.py
|
||||
USE_ASYNCIO=1 PYTHONPATH=.:build/lib.linux-$CARCH-$pyver pytest -v autobahn --ignore=autobahn/test/test_rng.py
|
||||
}
|
||||
|
||||
package() {
|
||||
|
|
13
community/python-autobahn/pytest-compatibility.diff
Normal file
13
community/python-autobahn/pytest-compatibility.diff
Normal file
|
@ -0,0 +1,13 @@
|
|||
diff --git a/autobahn/wamp/test/test_user_handler_errors.py b/autobahn/wamp/test/test_user_handler_errors.py
|
||||
index 35570bad..8f1b0181 100644
|
||||
--- a/autobahn/wamp/test/test_user_handler_errors.py
|
||||
+++ b/autobahn/wamp/test/test_user_handler_errors.py
|
||||
@@ -108,7 +108,7 @@ if os.environ.get('USE_TWISTED', False):
|
||||
# twice)...but that would mean switching all test-running over
|
||||
# to py-test
|
||||
|
||||
- skip = True
|
||||
+ skip = 'True'
|
||||
|
||||
def test_on_join(self):
|
||||
session = MockApplicationSession()
|
Loading…
Reference in a new issue