mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-01-27 23:44:04 +00:00
added core/libsecret
This commit is contained in:
parent
56f9d62b32
commit
7c64b4330d
2 changed files with 74 additions and 0 deletions
26
core/libsecret/0001-Fix-for-building-without-valgrind.patch
Normal file
26
core/libsecret/0001-Fix-for-building-without-valgrind.patch
Normal file
|
@ -0,0 +1,26 @@
|
|||
From 0fc0d0059e0b8c1548da797d4996e20427295401 Mon Sep 17 00:00:00 2001
|
||||
From: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
Date: Tue, 5 Mar 2019 20:05:09 -0700
|
||||
Subject: [PATCH] Fix for building without valgrind
|
||||
|
||||
---
|
||||
egg/egg-testing.c | 2 ++
|
||||
1 file changed, 2 insertions(+)
|
||||
|
||||
diff --git a/egg/egg-testing.c b/egg/egg-testing.c
|
||||
index 561e16a..85da119 100644
|
||||
--- a/egg/egg-testing.c
|
||||
+++ b/egg/egg-testing.c
|
||||
@@ -27,7 +27,9 @@
|
||||
|
||||
#include <glib-object.h>
|
||||
|
||||
+#ifdef WITH_VALGRIND
|
||||
#include <valgrind/valgrind.h>
|
||||
+#endif
|
||||
|
||||
#include <glib.h>
|
||||
#include <glib/gstdio.h>
|
||||
--
|
||||
2.21.0
|
||||
|
48
core/libsecret/PKGBUILD
Normal file
48
core/libsecret/PKGBUILD
Normal file
|
@ -0,0 +1,48 @@
|
|||
# Maintainer: Jan de Groot <jgc@archlinux.org>
|
||||
|
||||
# ALARM: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
# - remove makedepend on valgrind
|
||||
# - patch to fix building without valgrind
|
||||
|
||||
pkgname=libsecret
|
||||
pkgver=0.18.8
|
||||
pkgrel=2
|
||||
pkgdesc="Library for storing and retrieving passwords and other secrets"
|
||||
url="https://wiki.gnome.org/Projects/Libsecret"
|
||||
arch=(x86_64)
|
||||
license=(LGPL)
|
||||
depends=(glib2 libgcrypt)
|
||||
checkdepends=(python-dbus dbus-glib python-gobject gjs)
|
||||
makedepends=(docbook-xsl gobject-introspection vala git gtk-doc meson)
|
||||
optdepends=('gnome-keyring: key storage service, or use any other service implementing org.freedesktop.secrets')
|
||||
_commit=b5442654d483e959ac9ecd3a3fb9eebc8d9d8399 # tags/0.18.8^0
|
||||
source=("git+https://gitlab.gnome.org/GNOME/libsecret.git#commit=$_commit"
|
||||
'0001-Fix-for-building-without-valgrind.patch')
|
||||
sha256sums=('SKIP'
|
||||
'0dfdbe7bbccc388f7d76ac951c344aeec01f30e07fb64c3274d1b907c6b06ee8')
|
||||
|
||||
pkgver() {
|
||||
cd $pkgname
|
||||
git describe --tags | sed 's/-/+/g'
|
||||
}
|
||||
|
||||
prepare() {
|
||||
cd $pkgname
|
||||
patch -p1 -i ../0001-Fix-for-building-without-valgrind.patch
|
||||
}
|
||||
|
||||
build() {
|
||||
CFLAGS+=" -DHAVE_MLOCK" # https://gitlab.gnome.org/GNOME/libsecret/issues/23
|
||||
arch-meson $pkgname build
|
||||
ninja -C build
|
||||
}
|
||||
|
||||
check() {
|
||||
dbus-run-session meson test -C build
|
||||
}
|
||||
|
||||
package() {
|
||||
DESTDIR="$pkgdir" meson install -C build
|
||||
}
|
||||
|
||||
# vim:set sw=2 et:
|
Loading…
Reference in a new issue