mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-01-27 23:44:04 +00:00
core/linux-kirkwood-dt to 4.6.3-2
This commit is contained in:
parent
efab620d52
commit
7c69f78d3e
4 changed files with 36 additions and 5 deletions
25
core/linux-kirkwood-dt/0001-disable-mv643xx_eth-TSO.patch
Normal file
25
core/linux-kirkwood-dt/0001-disable-mv643xx_eth-TSO.patch
Normal file
|
@ -0,0 +1,25 @@
|
|||
From 311bb4a115f653ff9f3202873303483007906c8f Mon Sep 17 00:00:00 2001
|
||||
From: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
Date: Sun, 31 Aug 2014 08:45:13 -0600
|
||||
Subject: [PATCH] disable mv643xx_eth TSO
|
||||
|
||||
---
|
||||
drivers/net/ethernet/marvell/mv643xx_eth.c | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/drivers/net/ethernet/marvell/mv643xx_eth.c b/drivers/net/ethernet/marvell/mv643xx_eth.c
|
||||
index b151a94..e04af62 100644
|
||||
--- a/drivers/net/ethernet/marvell/mv643xx_eth.c
|
||||
+++ b/drivers/net/ethernet/marvell/mv643xx_eth.c
|
||||
@@ -3110,7 +3110,7 @@ static int mv643xx_eth_probe(struct platform_device *pdev)
|
||||
dev->watchdog_timeo = 2 * HZ;
|
||||
dev->base_addr = 0;
|
||||
|
||||
- dev->features = NETIF_F_SG | NETIF_F_IP_CSUM | NETIF_F_TSO;
|
||||
+ dev->features = NETIF_F_SG | NETIF_F_IP_CSUM;
|
||||
dev->vlan_features = dev->features;
|
||||
|
||||
dev->features |= NETIF_F_RXCSUM;
|
||||
--
|
||||
1.9.0
|
||||
|
|
@ -8,7 +8,7 @@ _kernelname=${pkgbase#linux}
|
|||
_desc="Marvell Kirkwood DT"
|
||||
pkgver=4.6.3
|
||||
srcver=${pkgver%.0}
|
||||
pkgrel=1
|
||||
pkgrel=2
|
||||
cryptodev_commit=7a3a9ee1329f7224b4fc564b80ef8160457caf76
|
||||
bfqver=v7r11
|
||||
|
||||
|
@ -29,6 +29,7 @@ options=('!strip')
|
|||
source=("https://kernel.org/pub/linux/kernel/v4.x/linux-${srcver}.tar.xz"
|
||||
'config'
|
||||
'archlinuxarm.patch'
|
||||
'0001-disable-mv643xx_eth-TSO.patch'
|
||||
"git+https://github.com/sfjro/aufs4-standalone.git#branch=${aufsbranch}"
|
||||
"cryptodev-${cryptodev_commit}.tar.gz::https://github.com/cryptodev-linux/cryptodev-linux/archive/${cryptodev_commit}.tar.gz"
|
||||
"ftp://teambelgium.net/bfq/patches/${bfqkern}.0-${bfqver}/0001-block-cgroups-kconfig-build-bits-for-BFQ-${bfqver}-${bfqkern}.0.patch"
|
||||
|
@ -39,8 +40,9 @@ source=("https://kernel.org/pub/linux/kernel/v4.x/linux-${srcver}.tar.xz"
|
|||
'cryptodev_linux_4.6_fix.patch')
|
||||
|
||||
md5sums=('f716e5587f8e6d1fdbda409eb8e1938f'
|
||||
'0bf194fa2c1afeefe4a018607b74f1c5'
|
||||
'e46c6ef7231618bb90b6eea994b2580b'
|
||||
'de4187921a51d4ec410abc764f6caccc'
|
||||
'09d44b9f07abfaeaf4f688ee52034786'
|
||||
'SKIP'
|
||||
'ad56ca4e2a29a3b76f3526c262d9fec1'
|
||||
'b3b845477eb2e62e745803685bde9057'
|
||||
|
@ -66,6 +68,10 @@ prepare() {
|
|||
patch -Np1 -i ../aufs4-standalone/aufs4-mmap.patch
|
||||
patch -Np1 -i ../aufs4-standalone/aufs4-standalone.patch
|
||||
|
||||
msg2 "Disable buggy TCP segmentation offload implementation"
|
||||
msg2 "http://archlinuxarm.org/forum/viewtopic.php?f=9&t=7692"
|
||||
patch -Np1 -i ${srcdir}/0001-disable-mv643xx_eth-TSO.patch
|
||||
|
||||
msg2 "Add Arch Linux ARM patch for ARMv5te plug computers"
|
||||
patch -Np1 -i "${srcdir}/archlinuxarm.patch"
|
||||
patch -Np1 -i "${srcdir}/goflexhome_fdt.patch"
|
||||
|
|
|
@ -1,6 +1,6 @@
|
|||
#
|
||||
# Automatically generated file; DO NOT EDIT.
|
||||
# Linux/arm 4.6.0-1 Kernel Configuration
|
||||
# Linux/arm 4.6.3-1 Kernel Configuration
|
||||
#
|
||||
CONFIG_ARM=y
|
||||
CONFIG_ARM_HAS_SG_CHAIN=y
|
||||
|
@ -5090,7 +5090,7 @@ CONFIG_QUOTACTL=y
|
|||
CONFIG_AUTOFS4_FS=y
|
||||
CONFIG_FUSE_FS=y
|
||||
CONFIG_CUSE=m
|
||||
# CONFIG_OVERLAY_FS is not set
|
||||
CONFIG_OVERLAY_FS=y
|
||||
|
||||
#
|
||||
# Caches
|
||||
|
|
|
@ -2,7 +2,7 @@
|
|||
# arg 2: the old package version
|
||||
|
||||
KERNEL_NAME=-kirkwood-dt
|
||||
KERNEL_VERSION=4.6.0-2-ARCH
|
||||
KERNEL_VERSION=4.6.3-2-ARCH
|
||||
|
||||
post_install () {
|
||||
# updating module dependencies
|
||||
|
|
Loading…
Reference in a new issue