removed community/rust

This commit is contained in:
Kevin Mihelich 2017-04-28 00:04:56 +00:00
parent 166788c797
commit 7c8586b958
2 changed files with 0 additions and 128 deletions

View file

@ -1,41 +0,0 @@
From 781561a6f26008a49572e156f80b577d6af60262 Mon Sep 17 00:00:00 2001
From: Tatsuyuki Ishi <ishitatsuyuki@gmail.com>
Date: Fri, 3 Feb 2017 16:15:34 +0900
Subject: [PATCH] liballoc_jemalloc: fix linking with system library
---
src/liballoc_jemalloc/build.rs | 11 ++++++-----
1 file changed, 6 insertions(+), 5 deletions(-)
diff --git a/src/liballoc_jemalloc/build.rs b/src/liballoc_jemalloc/build.rs
index 1143df0c63..297f5ce99f 100644
--- a/src/liballoc_jemalloc/build.rs
+++ b/src/liballoc_jemalloc/build.rs
@@ -42,6 +42,12 @@ fn main() {
return;
}
+ if target.contains("android") {
+ println!("cargo:rustc-link-lib=gcc");
+ } else if !target.contains("windows") && !target.contains("musl") {
+ println!("cargo:rustc-link-lib=pthread");
+ }
+
if let Some(jemalloc) = env::var_os("JEMALLOC_OVERRIDE") {
let jemalloc = PathBuf::from(jemalloc);
println!("cargo:rustc-link-search=native={}",
@@ -176,11 +182,6 @@ fn main() {
println!("cargo:rustc-link-lib=static=jemalloc_pic");
}
println!("cargo:rustc-link-search=native={}/lib", build_dir.display());
- if target.contains("android") {
- println!("cargo:rustc-link-lib=gcc");
- } else if !target.contains("windows") && !target.contains("musl") {
- println!("cargo:rustc-link-lib=pthread");
- }
// The pthread_atfork symbols is used by jemalloc on android but the really
// old android we're building on doesn't have them defined, so just make
--
2.12.0

View file

@ -1,87 +0,0 @@
# $Id$
# Maintainer: Johannes Löthberg <johannes@kyriasis.com>
# Contributor: Alexander F Rødseth <xyproto@archlinux.org>
# Contributor: Daniel Micay <danielmicay@gmail.com>
# Contributor: userwithuid <userwithuid@gmail.com>
# ALARM: Kevin Mihelich <kevin@archlinuxarm.org>
# - makedepend on rust, use local rust since bootstrapping is broken on ARM
buildarch=28
pkgname=('rust' 'rust-docs')
epoch=1
pkgver=1.16.0
pkgrel=1
pkgdesc='Systems programming language focused on safety, speed and concurrency'
url='https://www.rust-lang.org/'
arch=('x86_64' 'i686')
license=('MIT' 'Apache')
makedepends=('libffi' 'perl' 'python2' 'curl' 'llvm' 'jemalloc' 'cargo' 'rust')
options=('!emptydirs')
source=("https://static.rust-lang.org/dist/rustc-$pkgver-src.tar.gz"{,.asc}
0001-liballoc_jemalloc-fix-linking-with-system-library.patch)
sha256sums=('f966b31eb1cd9bd2df817c391a338eeb5b9253ae0a19bf8a11960c560f96e8b4'
'SKIP'
'b61d9aae58925b222cd44d7b41f0aa648fde89a48e7772aa659acd0d74dde612')
validpgpkeys=('108F66205EAEB0AAA8DD5E1C85AB96E6FA1BE5FE') # Rust Language (Tag and Release Signing Key) <rust-key@rust-lang.org>
prepare() {
cd "rustc-$pkgver-src"
# Backport of https://github.com/rust-lang/rust/pull/39481
patch -p1 <"$srcdir"/0001-liballoc_jemalloc-fix-linking-with-system-library.patch
}
build() {
cd "rustc-$pkgver-src"
./configure \
--prefix=/usr \
--release-channel=stable \
--llvm-root=/usr \
--disable-codegen-tests \
--jemalloc-root=/usr/lib \
--enable-local-rust \
--local-rust-root=/usr
export RUSTFLAGS="$RUSTFLAGS -C link-args=-lffi"
python2 ./x.py build --verbose
}
package_rust() {
depends=('gcc-libs' 'llvm-libs')
cd "rustc-$pkgver-src"
make DESTDIR="$pkgdir" install
for license in APACHE MIT; do install -Dm644 "LICENSE-$license" \
"$pkgdir/usr/share/licenses/$pkgname/LICENSE-$license"; done
cd "$pkgdir/usr/lib"
rm rustlib/{components,manifest-rustc,rust-installer-version}
ln -sf rustlib/$CARCH-unknown-linux-gnu/lib/*.so .
# move docs out of the way
mv "$pkgdir/usr/share/doc" "$srcdir/"
}
package_rust-docs() {
msg2 "Packaging documentation"
install -d "$pkgdir/usr/share/doc/"
mv "$srcdir"/doc/* "$pkgdir"/usr/share/doc/rust/
msg2 "Packaging license files for the documentation"
for license in APACHE MIT; do install -Dm644 "rustc-$pkgver-src/LICENSE-$license" \
"$pkgdir/usr/share/licenses/$pkgname/LICENSE-$license"; done
}
# vim:set ts=2 sw=2 et: