mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
extra/gstreamer to 1.22.6-1
This commit is contained in:
parent
1c25d6fe23
commit
7cac210ad2
3 changed files with 7 additions and 59 deletions
|
@ -12,7 +12,7 @@ Subject: [PATCH] HACK: meson: Disable broken tests
|
|||
5 files changed, 5 deletions(-)
|
||||
|
||||
diff --git a/subprojects/gst-editing-services/meson.build b/subprojects/gst-editing-services/meson.build
|
||||
index 48c6fed5fc2e..35714bee4a66 100644
|
||||
index 0d41498ddbeb..fc8a635a9bb7 100644
|
||||
--- a/subprojects/gst-editing-services/meson.build
|
||||
+++ b/subprojects/gst-editing-services/meson.build
|
||||
@@ -270,7 +270,6 @@ subdir('ges')
|
||||
|
@ -36,7 +36,7 @@ index 53a8e634e41a..f270c1d11bfb 100644
|
|||
tcase_add_test (tc_chain, test_video_caps_change_streamable);
|
||||
tcase_add_test (tc_chain, test_audio_caps_change_streamable_single);
|
||||
diff --git a/subprojects/gst-python/meson.build b/subprojects/gst-python/meson.build
|
||||
index 4c41baad2fc8..8a91267fc8fe 100644
|
||||
index a9bd36afe7cc..235cfb162a49 100644
|
||||
--- a/subprojects/gst-python/meson.build
|
||||
+++ b/subprojects/gst-python/meson.build
|
||||
@@ -107,5 +107,4 @@ if not get_option('plugin').disabled()
|
||||
|
@ -58,7 +58,7 @@ index 229af32f8117..b9372c125d77 100644
|
|||
'gst/sessionpool',
|
||||
'gst/stream',
|
||||
diff --git a/subprojects/gstreamer-vaapi/meson.build b/subprojects/gstreamer-vaapi/meson.build
|
||||
index 654b7e3fd2be..035e8e2c1cf0 100644
|
||||
index d6176f64b67e..e036fb966234 100644
|
||||
--- a/subprojects/gstreamer-vaapi/meson.build
|
||||
+++ b/subprojects/gstreamer-vaapi/meson.build
|
||||
@@ -219,7 +219,6 @@ plugins = []
|
||||
|
|
|
@ -1,47 +0,0 @@
|
|||
From 0000000000000000000000000000000000000000 Mon Sep 17 00:00:00 2001
|
||||
From: "Jan Alexander Steffens (heftig)" <heftig@archlinux.org>
|
||||
Date: Thu, 20 Jul 2023 19:13:36 +0200
|
||||
Subject: [PATCH] qt: Unbreak build with qt-egl enabled but viv_fb missing
|
||||
|
||||
Avoid an error message when the feature is explicitly enabled:
|
||||
|
||||
ERROR: Feature qt-egl cannot be enabled: gstreamer-gl-viv_fb-1.0 is required
|
||||
---
|
||||
subprojects/gst-plugins-good/ext/qt/meson.build | 17 ++++++-----------
|
||||
1 file changed, 6 insertions(+), 11 deletions(-)
|
||||
|
||||
diff --git a/subprojects/gst-plugins-good/ext/qt/meson.build b/subprojects/gst-plugins-good/ext/qt/meson.build
|
||||
index 442b7d5870e1..d1db2514653e 100644
|
||||
--- a/subprojects/gst-plugins-good/ext/qt/meson.build
|
||||
+++ b/subprojects/gst-plugins-good/ext/qt/meson.build
|
||||
@@ -120,6 +120,12 @@ if qt5_egl.allowed()
|
||||
qt_defines += ['-DHAVE_QT_EGLFS']
|
||||
optional_deps += gstglegl_dep
|
||||
have_qt_windowing = true
|
||||
+
|
||||
+ # EGL windowing for Vivante Framebuffer (e.g. i.MX6)
|
||||
+ if gstglviv_fb_dep.found()
|
||||
+ qt_defines += ['-DHAVE_QT_VIV_FB']
|
||||
+ optional_deps += gstglviv_fb_dep
|
||||
+ endif
|
||||
endif
|
||||
|
||||
# Android windowing
|
||||
@@ -184,17 +190,6 @@ if host_system == 'ios'
|
||||
endif
|
||||
endif
|
||||
|
||||
-# EGL windowing for Vivante Framebuffer (e.g. i.MX6)
|
||||
-qt5_viv_fb = qt5_egl \
|
||||
- .require(host_system == 'linux') \
|
||||
- .require(gstglviv_fb_dep.found(), error_message: 'gstreamer-gl-viv_fb-1.0 is required') \
|
||||
- .require(gst_gl_have_platform_egl, error_message: 'egl platform support in gstreamer-gl is required')
|
||||
-if qt5_viv_fb.allowed()
|
||||
- qt_defines += ['-DHAVE_QT_VIV_FB']
|
||||
- optional_deps += gstglviv_fb_dep
|
||||
- have_qt_windowing = true
|
||||
-endif
|
||||
-
|
||||
if qt5_option.require(have_qt_windowing).allowed()
|
||||
# rpath is needed to be able to load the plugin on macOS inside the devenv
|
||||
qmlgl_kwargs = {}
|
|
@ -31,8 +31,8 @@ pkgname=(
|
|||
gst-python
|
||||
gstreamer-docs
|
||||
)
|
||||
pkgver=1.22.5
|
||||
pkgrel=2
|
||||
pkgver=1.22.6
|
||||
pkgrel=1
|
||||
pkgdesc="Multimedia graph framework"
|
||||
url="https://gstreamer.freedesktop.org/"
|
||||
arch=(x86_64)
|
||||
|
@ -81,13 +81,11 @@ source=(
|
|||
"git+https://gitlab.freedesktop.org/gstreamer/gstreamer.git?signed#tag=$pkgver"
|
||||
"https://gstreamer.freedesktop.org/src/gstreamer-docs/gstreamer-docs-$pkgver.tar.xz"{,.asc}
|
||||
0001-HACK-meson-Disable-broken-tests.patch
|
||||
0002-qt-Unbreak-build-with-qt-egl-enabled-but-viv_fb-miss.patch
|
||||
)
|
||||
b2sums=('SKIP'
|
||||
'c35189d49f6091392ac368c848dfca47b185420f850c77ef145c8a9275123c920d5098ba7e75d302e5f278a8fd12197fd625c4aa755c9c17a98f595a533b78a8'
|
||||
'20d1879ecd9b183c5b9dc315356f9c3d855e6434af575a9d6d4269c4c6fbe1e4b3d4eb49e21876c83da43cacc47dc2b0d43c96a29dbeb806069344cc5a645a6c'
|
||||
'SKIP'
|
||||
'c64482a040ada8c2ba6433b6d9aa8619e53866b2d9b512cc91dff2e32d6c405339ec22e909dbce197595521c014b1bdad661e92b9d092f8e14c51c9cde7a74da'
|
||||
'829686c230d75bf4124366162c754ddc37d7ed49fb797e504ca5cf3e9a5db621d15911d9c8db3439348f442fb873c1c3e29683cfe9f47c1a0b00e7e48c4db21f')
|
||||
'3e59a5ae821b83ad20f5e39e52195aa6932d5877538ef63aef7205988482e2667d6d43fc7bce2b5eaaf2c280cd4369f63a0d0d9ae39094ee70ec4ecd318a64b5')
|
||||
validpgpkeys=(
|
||||
D637032E45B8C6585B9456565D2EEE6F6F349D7C # Tim Müller <tim@gstreamer-foundation.org>
|
||||
)
|
||||
|
@ -97,9 +95,6 @@ prepare() {
|
|||
|
||||
# Disable broken tests
|
||||
git apply -3 ../0001-HACK-meson-Disable-broken-tests.patch
|
||||
|
||||
# Unbreak qt-egl build
|
||||
git apply -3 ../0002-qt-Unbreak-build-with-qt-egl-enabled-but-viv_fb-miss.patch
|
||||
}
|
||||
|
||||
build() {
|
||||
|
|
Loading…
Reference in a new issue