mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-01-17 23:34:07 +00:00
removed community/unrealircd
This commit is contained in:
parent
6327e356df
commit
7cbc146964
6 changed files with 0 additions and 130 deletions
|
@ -1,27 +0,0 @@
|
|||
From 4d55db702344c906f2a5122c8319252eea08d510 Mon Sep 17 00:00:00 2001
|
||||
From: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
Date: Fri, 8 Jan 2016 17:57:41 -0700
|
||||
Subject: [PATCH] run autoreconf on TRE library
|
||||
|
||||
Fixes AArch64 build due to outdated config.{sub,guess}.
|
||||
|
||||
Signed-off-by: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
---
|
||||
configure | 1 +
|
||||
1 file changed, 1 insertion(+)
|
||||
|
||||
diff --git a/configure b/configure
|
||||
index 1bb7872..409df1e 100755
|
||||
--- a/configure
|
||||
+++ b/configure
|
||||
@@ -7541,6 +7541,7 @@ fi
|
||||
{ $as_echo "$as_me:${as_lineno-$LINENO}: result: configuring TRE regex library" >&5
|
||||
$as_echo "configuring TRE regex library" >&6; }
|
||||
cd tre-$tre_version
|
||||
+autoreconf -fi
|
||||
./configure --disable-agrep --enable-shared --disable-system-abi --disable-wchar --disable-multibyte --prefix=$cur_dir/extras/regexp --libdir=$PRIVATELIBDIR || exit 1
|
||||
{ $as_echo "$as_me:${as_lineno-$LINENO}: result: compiling TRE regex library" >&5
|
||||
$as_echo "compiling TRE regex library" >&6; }
|
||||
--
|
||||
2.10.2
|
||||
|
|
@ -1,74 +0,0 @@
|
|||
# $Id$
|
||||
# Maintainer: Sergej Pupykin <pupykin.s+arch@gmail.com>
|
||||
# Contributor: Zerial <fernando@zerial.org>
|
||||
|
||||
# ALAMR: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
# - patch to fix AArch64 FTBFS
|
||||
|
||||
pkgname=unrealircd
|
||||
pkgver=4.0.16
|
||||
pkgrel=1
|
||||
pkgdesc="Open Source IRC Server"
|
||||
arch=('i686' 'x86_64')
|
||||
url="http://unrealircd.com"
|
||||
license=('GPL2')
|
||||
depends=('openssl' 'curl' 'c-ares' 'tre' 'pcre2')
|
||||
conflicts=('ircd')
|
||||
provides=('ircd')
|
||||
backup=('etc/unrealircd/unrealircd.conf')
|
||||
install=unrealircd.install
|
||||
source=(https://www.unrealircd.org/unrealircd4/unrealircd-$pkgver.tar.gz
|
||||
unrealircd.service
|
||||
unrealircd.tmpfiles.d
|
||||
install.pl
|
||||
0001-run-autoreconf-on-TRE-library.patch)
|
||||
sha256sums=('40b43cbf1229550c663d73efa0e58e7353b78160087e3f80f0a5f180cb0da144'
|
||||
'0a6d3c269ba5379f967b2ec035ad4c6226d42ce22ffaaf8c3e5b37ba8ee02ddd'
|
||||
'2b2efb4b87b5b270e87fc0187ac1c559d41a41e6c81615182dc2bdd18bfcaccd'
|
||||
'43f07093ada8eb5c954f9e2e189610575906c690c0953fec041d4f2d31210d85'
|
||||
'425d6c1819375f8164998d49b4558396831efe36458c2d052927724494ae3961')
|
||||
|
||||
prepare() {
|
||||
cd "$srcdir"/unrealircd-$pkgver
|
||||
sed -i \
|
||||
-e 's|$(INSTALL) -m 0700|$(INSTALL) -m 0755|g' \
|
||||
-e 's|$(INSTALL) -m 0600|$(INSTALL) -m 0644|g' \
|
||||
Makefile.in
|
||||
patch -p1 -i ../0001-run-autoreconf-on-TRE-library.patch
|
||||
}
|
||||
|
||||
build() {
|
||||
cd "$srcdir"/unrealircd-$pkgver
|
||||
./configure \
|
||||
--with-pidfile=/run/unrealircd/ircd.pid \
|
||||
--with-showlistmodes \
|
||||
--enable-ssl=/usr \
|
||||
--with-bindir=/usr/bin \
|
||||
--with-datadir=/var/lib/unrealircd \
|
||||
--with-confdir=/etc/unrealircd \
|
||||
--with-modulesdir=/usr/lib/unrealircd \
|
||||
--with-logdir=/var/log/unrealircd \
|
||||
--with-cachedir=/var/cache/unrealircd \
|
||||
--with-docdir=/usr/share/doc/unrealircd \
|
||||
--with-tmpdir=/tmp \
|
||||
--with-scriptdir=/usr \
|
||||
--with-nick-history=2000 \
|
||||
--with-sendq=3000000 \
|
||||
--with-permissions=0644 \
|
||||
--with-fd-setsize=1024 \
|
||||
--enable-dynamic-linking
|
||||
make
|
||||
}
|
||||
|
||||
package() {
|
||||
cd "$srcdir"/unrealircd-$pkgver
|
||||
|
||||
export pkgdir
|
||||
make INSTALL="$srcdir"/install.pl install
|
||||
mv "$pkgdir"/usr/unrealircd "$pkgdir"/etc/unrealircd/unrealircd
|
||||
cp "$pkgdir"/etc/unrealircd/examples/example.conf "$pkgdir"/etc/unrealircd/unrealircd.conf
|
||||
rm -rf "$pkgdir"/tmp
|
||||
|
||||
install -Dm0644 "$srcdir"/unrealircd.service "$pkgdir"/usr/lib/systemd/system/unrealircd.service
|
||||
install -Dm0644 "$srcdir"/unrealircd.tmpfiles.d "$pkgdir"/usr/lib/tmpfiles.d/unrealircd.conf
|
||||
}
|
|
@ -1,5 +0,0 @@
|
|||
#!/usr/bin/perl -w
|
||||
use Env qw(pkgdir);
|
||||
my $last = pop @ARGV;
|
||||
my $cmd = "/usr/bin/install ".(join ' ',@ARGV)." $pkgdir/$last";
|
||||
system($cmd);
|
|
@ -1,11 +0,0 @@
|
|||
post_install() {
|
||||
getent passwd ircd >/dev/null || useradd -r ircd -d /var/empty
|
||||
chown -R ircd {etc,var/{cache,log,lib}}/unrealircd
|
||||
echo "SSL is enabled by default, so you need to create pem files"
|
||||
echo "unrealircd.conf needs adjustments"
|
||||
echo "See also: https://wiki.archlinux.org/index.php/UnrealIRCd"
|
||||
}
|
||||
|
||||
post_upgrade() {
|
||||
post_install
|
||||
}
|
|
@ -1,12 +0,0 @@
|
|||
[Unit]
|
||||
Description=IRC daemon
|
||||
After=network.target remote-fs.target nss-lookup.target
|
||||
|
||||
[Service]
|
||||
Type=forking
|
||||
User=ircd
|
||||
PIDFile=/run/unrealircd/ircd.pid
|
||||
ExecStart=/usr/bin/unrealircd
|
||||
|
||||
[Install]
|
||||
WantedBy=multi-user.target
|
|
@ -1 +0,0 @@
|
|||
d /run/unrealircd 0755 ircd root -
|
Loading…
Reference in a new issue