mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
extra/chmlib: v8 update
This commit is contained in:
parent
5e3e25df3c
commit
7cc2072609
2 changed files with 13 additions and 4 deletions
|
@ -17,7 +17,7 @@ depends=('glibc')
|
|||
source=("http://morte.jedrea.com/~jedwin/projects/${pkgname}/${pkgname}-${pkgver}.tar.bz2"
|
||||
"arm.patch")
|
||||
md5sums=('7ea49ed8c335215c1edc6fae83e6b912'
|
||||
'aae01483e3fc2d37ee1984cb936e58f3')
|
||||
'c955ee2709b5d4d1dc29751d941d5c81')
|
||||
build() {
|
||||
cd "${srcdir}"/${pkgname}-${pkgver}
|
||||
|
||||
|
|
|
@ -1,6 +1,6 @@
|
|||
diff -urN chmlib-0.40.orig/src/chm_lib.c chmlib-0.40/src/chm_lib.c
|
||||
--- chmlib-0.40.orig/src/chm_lib.c 2009-05-23 08:43:31.000000000 -0600
|
||||
+++ chmlib-0.40/src/chm_lib.c 2011-01-21 17:42:45.000000000 -0700
|
||||
diff -urN a/src/chm_lib.c b/src/chm_lib.c
|
||||
--- a/src/chm_lib.c 2009-05-23 08:43:31.000000000 -0600
|
||||
+++ b/src/chm_lib.c 2015-07-18 14:15:00.588557608 -0600
|
||||
@@ -153,7 +153,7 @@
|
||||
/* Sparc */
|
||||
/* MIPS */
|
||||
|
@ -10,3 +10,12 @@ diff -urN chmlib-0.40.orig/src/chm_lib.c chmlib-0.40/src/chm_lib.c
|
|||
typedef unsigned char UChar;
|
||||
typedef short Int16;
|
||||
typedef unsigned short UInt16;
|
||||
@@ -164,7 +164,7 @@
|
||||
|
||||
/* x86-64 */
|
||||
/* Note that these may be appropriate for other 64-bit machines. */
|
||||
-#elif __x86_64__ || __ia64__
|
||||
+#elif __x86_64__ || __ia64__ || __aarch64__
|
||||
typedef unsigned char UChar;
|
||||
typedef short Int16;
|
||||
typedef unsigned short UInt16;
|
||||
|
|
Loading…
Reference in a new issue