mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-18 22:54:00 +00:00
alarm/devtools-alarm to 20130408-1
This commit is contained in:
parent
dbbcbb90e6
commit
7ccf2e3c6b
4 changed files with 106 additions and 29 deletions
44
alarm/devtools-alarm/0001-makechrootpkg-cache-dir.patch
Normal file
44
alarm/devtools-alarm/0001-makechrootpkg-cache-dir.patch
Normal file
|
@ -0,0 +1,44 @@
|
||||||
|
diff -urN a/makechrootpkg.in b/makechrootpkg.in
|
||||||
|
--- a/makechrootpkg.in 2013-04-08 10:09:19.000000000 -0600
|
||||||
|
+++ b/makechrootpkg.in 2013-05-31 12:12:06.555461241 -0600
|
||||||
|
@@ -49,6 +49,7 @@
|
||||||
|
echo 'Flags:'
|
||||||
|
echo '-h This help'
|
||||||
|
echo '-c Clean the chroot before building'
|
||||||
|
+ echo '-C <dir> Set pacman cache to pass to mkarchroot'
|
||||||
|
echo '-u Update the working copy of the chroot before building'
|
||||||
|
echo ' This is useful for rebuilds without dirtying the pristine'
|
||||||
|
echo ' chroot'
|
||||||
|
@@ -63,10 +64,11 @@
|
||||||
|
exit 1
|
||||||
|
}
|
||||||
|
|
||||||
|
-while getopts 'hcudr:I:l:nT' arg; do
|
||||||
|
+while getopts 'hcudC:r:I:l:nT' arg; do
|
||||||
|
case "$arg" in
|
||||||
|
h) usage ;;
|
||||||
|
c) clean_first=true ;;
|
||||||
|
+ C) cache_dir="$OPTARG" ;;
|
||||||
|
u) update_first=true ;;
|
||||||
|
d) add_to_db=true ;;
|
||||||
|
r) passeddir="$OPTARG" ;;
|
||||||
|
@@ -116,6 +118,10 @@
|
||||||
|
|
||||||
|
umask 0022
|
||||||
|
|
||||||
|
+if [ -n "$cache_dir" ]; then
|
||||||
|
+ cache_dir="-c $cache_dir"
|
||||||
|
+fi
|
||||||
|
+
|
||||||
|
# Detect chrootdir filesystem type
|
||||||
|
chroottype=$(stat -f -c %T "$chrootdir")
|
||||||
|
|
||||||
|
@@ -288,7 +294,7 @@
|
||||||
|
EOF
|
||||||
|
chmod +x "$copydir/chrootbuild"
|
||||||
|
|
||||||
|
-if mkarchroot -r "/chrootbuild" "$copydir"; then
|
||||||
|
+if mkarchroot $cache_dir -r "/chrootbuild" "$copydir"; then
|
||||||
|
for pkgfile in "$copydir"/pkgdest/*.pkg.tar.?z; do
|
||||||
|
if $add_to_db; then
|
||||||
|
mkdir -p "$copydir/repo"
|
21
alarm/devtools-alarm/0002-mkarchroot-dont-change-confs.patch
Normal file
21
alarm/devtools-alarm/0002-mkarchroot-dont-change-confs.patch
Normal file
|
@ -0,0 +1,21 @@
|
||||||
|
diff -urN a/mkarchroot.in b/mkarchroot.in
|
||||||
|
--- a/mkarchroot.in 2013-04-08 10:09:19.000000000 -0600
|
||||||
|
+++ b/mkarchroot.in 2013-05-31 10:53:46.465229553 -0600
|
||||||
|
@@ -142,7 +142,7 @@
|
||||||
|
|
||||||
|
chroot_lock
|
||||||
|
build_mount_args
|
||||||
|
- copy_hostconf
|
||||||
|
+ #copy_hostconf
|
||||||
|
|
||||||
|
chroot_run "${working_dir}" ${RUN}
|
||||||
|
|
||||||
|
@@ -178,7 +178,7 @@
|
||||||
|
chroot_run "${working_dir}" locale-gen
|
||||||
|
echo 'LANG=C' > "${working_dir}/etc/locale.conf"
|
||||||
|
|
||||||
|
- copy_hostconf
|
||||||
|
+ #copy_hostconf
|
||||||
|
|
||||||
|
echo "${CHROOT_VERSION}" > "${working_dir}/.arch-chroot"
|
||||||
|
# }}}
|
14
alarm/devtools-alarm/0003-makechrootpkg-distcc.patch
Normal file
14
alarm/devtools-alarm/0003-makechrootpkg-distcc.patch
Normal file
|
@ -0,0 +1,14 @@
|
||||||
|
diff -urN a/makechrootpkg.in b/makechrootpkg.in
|
||||||
|
--- a/makechrootpkg.in 2013-05-31 10:49:38.866569102 -0600
|
||||||
|
+++ b/makechrootpkg.in 2013-05-31 10:57:39.183970506 -0600
|
||||||
|
@@ -280,7 +280,9 @@
|
||||||
|
export HOME=/build
|
||||||
|
|
||||||
|
cd /build
|
||||||
|
-sudo -u nobody makepkg $makepkg_args || exit 1
|
||||||
|
+mkdir .distcc
|
||||||
|
+chown nobody .distcc
|
||||||
|
+sudo -u nobody DISTCC_IO_TIMEOUT=0 DISTCC_DIR='/build/.distcc' makepkg $makepkg_args || exit 1
|
||||||
|
|
||||||
|
if $run_namcap; then
|
||||||
|
pacman -S --needed --noconfirm namcap
|
|
@ -1,44 +1,42 @@
|
||||||
# $Id: PKGBUILD 152237 2012-03-05 17:04:50Z pierre $
|
# $Id: PKGBUILD 182399 2013-04-10 05:34:09Z pierre $
|
||||||
# Maintainer: Pierre Schmitz <pierre@archlinux.de>
|
# Maintainer: Pierre Schmitz <pierre@archlinux.de>
|
||||||
|
|
||||||
# ALARM: Kevin Mihelich <kevin@archlinuxarm.org>
|
# ALARM: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||||
# - packaged using our git version
|
# - patches to fix issues with how we use the tools
|
||||||
|
|
||||||
plugrel=1
|
|
||||||
|
|
||||||
pkgname=devtools-alarm
|
pkgname=devtools-alarm
|
||||||
pkgver=20120516
|
_pkgname=devtools
|
||||||
|
pkgver=20130408
|
||||||
pkgrel=1
|
pkgrel=1
|
||||||
pkgdesc='Tools for Arch Linux ARM build system clients'
|
pkgdesc='Tools for Arch Linux package maintainers'
|
||||||
arch=('any')
|
arch=('any')
|
||||||
license=('GPL')
|
license=('GPL')
|
||||||
url='https://github.com/archlinuxarm/devtools'
|
url='http://projects.archlinux.org/devtools.git/'
|
||||||
depends=('namcap' 'openssh' 'subversion' 'rsync')
|
depends=('namcap' 'openssh' 'subversion' 'rsync' 'arch-install-scripts')
|
||||||
makedepends=('git')
|
source=("ftp://ftp.archlinux.org/other/${_pkgname}/${_pkgname}-${pkgver}.tar.gz"
|
||||||
conflicts=('devtools')
|
"ftp://ftp.archlinux.org/other/${_pkgname}/${_pkgname}-${pkgver}.tar.gz.sig"
|
||||||
provides=('devtools')
|
'0001-makechrootpkg-cache-dir.patch'
|
||||||
|
'0002-mkarchroot-dont-change-confs.patch'
|
||||||
|
'0003-makechrootpkg-distcc.patch')
|
||||||
|
md5sums=('12b42b429744af6517ae789f728e9f63'
|
||||||
|
'SKIP'
|
||||||
|
'1a85c2d42aa9aaa77847e303422bc11e'
|
||||||
|
'37d9d2ca96a3a5130d39b1441b7acb99'
|
||||||
|
'550d15ec4ee1803476424d60460b89ec')
|
||||||
|
|
||||||
_gitroot="git://github.com/archlinuxarm/devtools.git"
|
prepare() {
|
||||||
_gitname="devtools"
|
cd ${srcdir}/${_pkgname}-${pkgver}
|
||||||
|
patch -p1 -i "${srcdir}"/0001-makechrootpkg-cache-dir.patch
|
||||||
|
patch -p1 -i "${srcdir}"/0002-mkarchroot-dont-change-confs.patch
|
||||||
|
patch -p1 -i "${srcdir}"/0003-makechrootpkg-distcc.patch
|
||||||
|
}
|
||||||
|
|
||||||
build() {
|
build() {
|
||||||
cd "${srcdir}"
|
cd ${srcdir}/${_pkgname}-${pkgver}
|
||||||
msg "Connecting to GIT server...."
|
make PREFIX=/usr
|
||||||
|
|
||||||
if [ -d $_gitname ] ; then
|
|
||||||
cd $_gitname && git pull origin
|
|
||||||
msg "The local files are updated."
|
|
||||||
else
|
|
||||||
git clone $_gitroot
|
|
||||||
fi
|
|
||||||
|
|
||||||
msg "GIT checkout done or server timeout"
|
|
||||||
|
|
||||||
cd "${srcdir}/${_gitname}"
|
|
||||||
make PREFIX=/usr
|
|
||||||
}
|
}
|
||||||
|
|
||||||
package() {
|
package() {
|
||||||
cd "${srcdir}/${_gitname}"
|
cd ${srcdir}/${_pkgname}-${pkgver}
|
||||||
make PREFIX=/usr DESTDIR="${pkgdir}" install
|
make PREFIX=/usr DESTDIR=${pkgdir} install
|
||||||
}
|
}
|
||||||
|
|
Loading…
Reference in a new issue