mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-03-09 00:17:31 +00:00
core/linux-raspberrypi to 4.1.16-1
This commit is contained in:
parent
6b9e9c6d9a
commit
7d2c28328e
2 changed files with 4 additions and 90 deletions
|
@ -7,12 +7,12 @@
|
|||
buildarch=20
|
||||
|
||||
pkgbase=linux-raspberrypi
|
||||
_commit=d51c7d840b002a6b26089d8b45679d9331880060
|
||||
_commit=677aa0f74854a57081fe9392942ecae8bcfc3865
|
||||
_srcname=linux-${_commit}
|
||||
_kernelname=${pkgbase#linux}
|
||||
_desc="Raspberry Pi"
|
||||
pkgver=4.1.15
|
||||
pkgrel=5
|
||||
pkgver=4.1.16
|
||||
pkgrel=1
|
||||
bfqver=v7r8
|
||||
arch=('armv6h' 'armv7h')
|
||||
url="http://www.kernel.org/"
|
||||
|
@ -24,17 +24,15 @@ source=("https://github.com/raspberrypi/linux/archive/${_commit}.tar.gz"
|
|||
"ftp://teambelgium.net/bfq/patches/${pkgver%.*}.0-${bfqver}/0001-block-cgroups-kconfig-build-bits-for-BFQ-${bfqver}-${pkgver%.*}.patch"
|
||||
"ftp://teambelgium.net/bfq/patches/${pkgver%.*}.0-${bfqver}/0002-block-introduce-the-BFQ-${bfqver}-I-O-sched-for-${pkgver%.*}.patch"
|
||||
"ftp://teambelgium.net/bfq/patches/${pkgver%.*}.0-${bfqver}/0003-block-bfq-add-Early-Queue-Merge-EQM-to-BFQ-${bfqver}-for-${pkgver%.*}.0.patch"
|
||||
'kernel-CVE-2016-0728.patch'
|
||||
'config.txt'
|
||||
'cmdline.txt'
|
||||
'config.v6'
|
||||
'config.v7')
|
||||
md5sums=('e6fe76cb14ffec7c5b4e0d88a9b3099c'
|
||||
md5sums=('b234a8238bbb3c8e3a4762fc762b1ef9'
|
||||
'SKIP'
|
||||
'74bf103542cbdee0363819309adb97a2'
|
||||
'f09baae3c7add4ed9bedde22ae3efe19'
|
||||
'bd8cc19a31d1cf8aeeaf9245057c4f9b'
|
||||
'6470e9783bd1c7a8feddc2d67f07afd5'
|
||||
'9a3c82da627b317ec79c37fd6afba569'
|
||||
'60bc3624123c183305677097bcd56212'
|
||||
'db8c931027f6814822ad63424699524c'
|
||||
|
@ -43,9 +41,6 @@ md5sums=('e6fe76cb14ffec7c5b4e0d88a9b3099c'
|
|||
prepare() {
|
||||
cd "${srcdir}/${_srcname}"
|
||||
|
||||
msg2 "ALARM patches"
|
||||
patch -Np1 -i ../kernel-CVE-2016-0728.patch
|
||||
|
||||
msg2 "AUFS patches"
|
||||
cp -ru "${srcdir}/aufs4-standalone/Documentation" .
|
||||
cp -ru "${srcdir}/aufs4-standalone/fs" .
|
||||
|
|
|
@ -1,81 +0,0 @@
|
|||
From 23567fd052a9abb6d67fe8e7a9ccdd9800a540f2 Mon Sep 17 00:00:00 2001
|
||||
From: Yevgeny Pats <yevgeny@perception-point.io>
|
||||
Date: Tue, 19 Jan 2016 22:09:04 +0000
|
||||
Subject: KEYS: Fix keyring ref leak in join_session_keyring()
|
||||
|
||||
This fixes CVE-2016-0728.
|
||||
|
||||
If a thread is asked to join as a session keyring the keyring that's already
|
||||
set as its session, we leak a keyring reference.
|
||||
|
||||
This can be tested with the following program:
|
||||
|
||||
#include <stddef.h>
|
||||
#include <stdio.h>
|
||||
#include <sys/types.h>
|
||||
#include <keyutils.h>
|
||||
|
||||
int main(int argc, const char *argv[])
|
||||
{
|
||||
int i = 0;
|
||||
key_serial_t serial;
|
||||
|
||||
serial = keyctl(KEYCTL_JOIN_SESSION_KEYRING,
|
||||
"leaked-keyring");
|
||||
if (serial < 0) {
|
||||
perror("keyctl");
|
||||
return -1;
|
||||
}
|
||||
|
||||
if (keyctl(KEYCTL_SETPERM, serial,
|
||||
KEY_POS_ALL | KEY_USR_ALL) < 0) {
|
||||
perror("keyctl");
|
||||
return -1;
|
||||
}
|
||||
|
||||
for (i = 0; i < 100; i++) {
|
||||
serial = keyctl(KEYCTL_JOIN_SESSION_KEYRING,
|
||||
"leaked-keyring");
|
||||
if (serial < 0) {
|
||||
perror("keyctl");
|
||||
return -1;
|
||||
}
|
||||
}
|
||||
|
||||
return 0;
|
||||
}
|
||||
|
||||
If, after the program has run, there something like the following line in
|
||||
/proc/keys:
|
||||
|
||||
3f3d898f I--Q--- 100 perm 3f3f0000 0 0 keyring leaked-keyring: empty
|
||||
|
||||
with a usage count of 100 * the number of times the program has been run,
|
||||
then the kernel is malfunctioning. If leaked-keyring has zero usages or
|
||||
has been garbage collected, then the problem is fixed.
|
||||
|
||||
Reported-by: Yevgeny Pats <yevgeny@perception-point.io>
|
||||
Signed-off-by: David Howells <dhowells@redhat.com>
|
||||
Acked-by: Don Zickus <dzickus@redhat.com>
|
||||
Acked-by: Prarit Bhargava <prarit@redhat.com>
|
||||
Acked-by: Jarod Wilson <jarod@redhat.com>
|
||||
Signed-off-by: James Morris <james.l.morris@oracle.com>
|
||||
---
|
||||
security/keys/process_keys.c | 1 +
|
||||
1 file changed, 1 insertion(+)
|
||||
|
||||
diff --git a/security/keys/process_keys.c b/security/keys/process_keys.c
|
||||
index a3f85d2..e6d50172 100644
|
||||
--- a/security/keys/process_keys.c
|
||||
+++ b/security/keys/process_keys.c
|
||||
@@ -794,6 +794,7 @@ long join_session_keyring(const char *name)
|
||||
ret = PTR_ERR(keyring);
|
||||
goto error2;
|
||||
} else if (keyring == new->session_keyring) {
|
||||
+ key_put(keyring);
|
||||
ret = 0;
|
||||
goto error2;
|
||||
}
|
||||
--
|
||||
cgit v0.12
|
||||
|
Loading…
Reference in a new issue