mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
removed community/clementine
This commit is contained in:
parent
04a1125e7f
commit
7d2d37b96d
4 changed files with 0 additions and 195 deletions
|
@ -1,107 +0,0 @@
|
|||
# Maintainer: Maxime Gauduin <alucryd@archlinux.org>
|
||||
# Contributor: Stéphane Gaudreault <stephane@archlinux.org>
|
||||
# Contributor: BlackEagle <ike.devolder@gmail.com>
|
||||
# Contributor: Dany Martineau <dany.luc.martineau@gmail.com>
|
||||
|
||||
# ALARM: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
# - fix fPIC on AArch64
|
||||
|
||||
pkgname=clementine
|
||||
pkgver=1.3.1
|
||||
pkgrel=22
|
||||
pkgdesc='A modern music player and library organizer'
|
||||
url=https://www.clementine-player.org/
|
||||
license=(GPL)
|
||||
arch=(x86_64)
|
||||
depends=(
|
||||
chromaprint
|
||||
crypto++
|
||||
fftw
|
||||
glew
|
||||
glib2
|
||||
gst-plugins-base-libs
|
||||
gstreamer
|
||||
libcdio
|
||||
libechonest
|
||||
libgl
|
||||
libgpod
|
||||
liblastfm
|
||||
libmtp
|
||||
libpulse
|
||||
libx11
|
||||
protobuf
|
||||
qjson
|
||||
qt4
|
||||
sqlite
|
||||
taglib
|
||||
zlib
|
||||
)
|
||||
makedepends=(
|
||||
boost
|
||||
cmake
|
||||
git
|
||||
mesa
|
||||
sparsehash
|
||||
)
|
||||
optdepends=(
|
||||
'gst-plugins-base: "Base" plugin libraries'
|
||||
'gst-plugins-good: "Good" plugin libraries'
|
||||
'gst-plugins-bad: "Bad" plugin libraries'
|
||||
'gst-plugins-ugly: "Ugly" plugin libraries'
|
||||
'gst-libav: Libav plugin'
|
||||
'gvfs: Various devices support'
|
||||
)
|
||||
source=(
|
||||
git+https://github.com/clementine-player/Clementine.git#tag=${pkgver}
|
||||
clementine-gcc6.patch
|
||||
clementine-chromaprint1.4.0.patch
|
||||
clementine-cryptopp6.patch
|
||||
)
|
||||
sha256sums=(
|
||||
SKIP
|
||||
05bd4dc0138eed084332fa1a688a96858418731f337f54e0d8ab0853123f40ee
|
||||
4cc9c9df599df4a595c6acf4e129a54296c0a8e537627435e3df14e1e95447b0
|
||||
e9c09dca76ed8fae2ecb089571396c9293f546871fb2f27cc37010dd5cba9e46
|
||||
)
|
||||
|
||||
prepare() {
|
||||
if [[ -d build ]]; then
|
||||
rm -rf build
|
||||
fi
|
||||
mkdir build
|
||||
|
||||
cd Clementine
|
||||
|
||||
# Fix build with GCC 6
|
||||
patch -p1 -i ../clementine-gcc6.patch
|
||||
# https://github.com/clementine-player/Clementine/pull/5630
|
||||
git cherry-pick -n 8a6cc8b5069265e1e92e22def985e22c5955e503
|
||||
# Fix build with chromaprint 1.4.0
|
||||
patch -p1 -i ../clementine-chromaprint1.4.0.patch
|
||||
# Fix build with crypto++ 6.0.0 due to https://github.com/weidai11/cryptopp/issues/442
|
||||
patch -p1 -i ../clementine-cryptopp6.patch
|
||||
# FS#58413
|
||||
git cherry-pick -n -m 1 75f9439843a0e9cdc26cd739d5e1dbd93bd974bc
|
||||
# Fix DI.FM
|
||||
git cherry-pick -n ddfa5e63f1ef0e243a007efbe576fceb9b2442e8
|
||||
|
||||
if [[ $CARCH == "aarch64" ]]; then
|
||||
sed -i 's/fpic/fPIC/' 3rdparty/vreen/vreen/cmake/CommonUtils.cmake
|
||||
fi
|
||||
}
|
||||
|
||||
build() {
|
||||
cd build
|
||||
|
||||
cmake ../Clementine \
|
||||
-DCMAKE_BUILD_TYPE=Release \
|
||||
-DCMAKE_INSTALL_PREFIX=/usr\
|
||||
-DCMAKE_CXX_FLAGS="$CXXFLAGS -Wno-catch-value"
|
||||
make
|
||||
}
|
||||
|
||||
package() {
|
||||
make DESTDIR="${pkgdir}" -C build install
|
||||
}
|
||||
|
||||
# vim: ts=2 sw=2 et:
|
|
@ -1,41 +0,0 @@
|
|||
From ded312685735fc266d4154d355286eeb86db3bcd Mon Sep 17 00:00:00 2001
|
||||
From: Chocobozzz <florian.bigard@gmail.com>
|
||||
Date: Thu, 8 Dec 2016 23:12:17 +0100
|
||||
Subject: [PATCH] Add compatibility with chromaprint >= 1.4
|
||||
|
||||
---
|
||||
src/musicbrainz/chromaprinter.cpp | 14 +++++++++++---
|
||||
1 file changed, 11 insertions(+), 3 deletions(-)
|
||||
|
||||
diff --git a/src/musicbrainz/chromaprinter.cpp b/src/musicbrainz/chromaprinter.cpp
|
||||
index 9579b62ae..c7ad99e2e 100644
|
||||
--- a/src/musicbrainz/chromaprinter.cpp
|
||||
+++ b/src/musicbrainz/chromaprinter.cpp
|
||||
@@ -143,16 +143,24 @@ QString Chromaprinter::CreateFingerprint() {
|
||||
ChromaprintContext* chromaprint =
|
||||
chromaprint_new(CHROMAPRINT_ALGORITHM_DEFAULT);
|
||||
chromaprint_start(chromaprint, kDecodeRate, kDecodeChannels);
|
||||
- chromaprint_feed(chromaprint, reinterpret_cast<void*>(data.data()),
|
||||
+ chromaprint_feed(chromaprint, reinterpret_cast<int16_t *>(data.data()),
|
||||
data.size() / 2);
|
||||
chromaprint_finish(chromaprint);
|
||||
|
||||
- void* fprint = nullptr;
|
||||
int size = 0;
|
||||
+
|
||||
+#if CHROMAPRINT_VERSION_MAJOR >= 1 && CHROMAPRINT_VERSION_MINOR >= 4
|
||||
+ u_int32_t *fprint = nullptr;
|
||||
+ char *encoded = nullptr;
|
||||
+#else
|
||||
+ void *fprint = nullptr;
|
||||
+ void *encoded = nullptr;
|
||||
+#endif
|
||||
+
|
||||
int ret = chromaprint_get_raw_fingerprint(chromaprint, &fprint, &size);
|
||||
+
|
||||
QByteArray fingerprint;
|
||||
if (ret == 1) {
|
||||
- void* encoded = nullptr;
|
||||
int encoded_size = 0;
|
||||
chromaprint_encode_fingerprint(fprint, size, CHROMAPRINT_ALGORITHM_DEFAULT,
|
||||
&encoded, &encoded_size, 1);
|
|
@ -1,25 +0,0 @@
|
|||
diff --git a/src/internet/spotify/spotifyblobdownloader.cpp b/src/internet/spotify/spotifyblobdownloader.cpp
|
||||
index e34577f5d..045aeeb8a 100644
|
||||
--- a/src/internet/spotify/spotifyblobdownloader.cpp
|
||||
+++ b/src/internet/spotify/spotifyblobdownloader.cpp
|
||||
@@ -189,7 +189,7 @@ bool SpotifyBlobDownloader::CheckSignature(
|
||||
|
||||
try {
|
||||
CryptoPP::ByteQueue bytes;
|
||||
- bytes.Put(reinterpret_cast<const byte*>(public_key_data.constData()),
|
||||
+ bytes.Put(reinterpret_cast<const CryptoPP::byte*>(public_key_data.constData()),
|
||||
public_key_data.size());
|
||||
bytes.MessageEnd();
|
||||
|
||||
@@ -204,9 +204,9 @@ bool SpotifyBlobDownloader::CheckSignature(
|
||||
actual_filename.remove(kSignatureSuffix);
|
||||
|
||||
const bool result = verifier.VerifyMessage(
|
||||
- reinterpret_cast<const byte*>(file_data[actual_filename].constData()),
|
||||
+ reinterpret_cast<const CryptoPP::byte*>(file_data[actual_filename].constData()),
|
||||
file_data[actual_filename].size(),
|
||||
- reinterpret_cast<const byte*>(
|
||||
+ reinterpret_cast<const CryptoPP::byte*>(
|
||||
file_data[signature_filename].constData()),
|
||||
file_data[signature_filename].size());
|
||||
qLog(Debug) << "Verifying" << actual_filename << "against"
|
|
@ -1,22 +0,0 @@
|
|||
From e31278c05666f8ae0e819bd831c65e8766ba2679 Mon Sep 17 00:00:00 2001
|
||||
From: Bigard Florian <florian.bigard@gmail.com>
|
||||
Date: Mon, 9 May 2016 11:55:34 +0200
|
||||
Subject: [PATCH] Fix projectm compilation with GCC 6 (#5371)
|
||||
|
||||
---
|
||||
3rdparty/libprojectm/CMakeLists.txt | 2 ++
|
||||
1 file changed, 2 insertions(+)
|
||||
|
||||
diff --git a/3rdparty/libprojectm/CMakeLists.txt b/3rdparty/libprojectm/CMakeLists.txt
|
||||
index e6287f176..0ef785c49 100644
|
||||
--- a/3rdparty/libprojectm/CMakeLists.txt
|
||||
+++ b/3rdparty/libprojectm/CMakeLists.txt
|
||||
@@ -24,6 +24,8 @@ set(BUILD_PROJECTM_STATIC ON)
|
||||
set(DISABLE_NATIVE_PRESETS ON)
|
||||
set(DISABLE_MILKDROP_PRESETS OFF)
|
||||
|
||||
+set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -std=gnu++98")
|
||||
+
|
||||
if(DISABLE_NATIVE_PRESETS)
|
||||
ADD_DEFINITIONS(-DDISABLE_NATIVE_PRESETS)
|
||||
endif(DISABLE_NATIVE_PRESETS)
|
Loading…
Reference in a new issue