mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-02-16 23:57:11 +00:00
extra/mutter to 3.12.0-1
This commit is contained in:
parent
a13d3708f1
commit
7d40c2aa4e
2 changed files with 6 additions and 44 deletions
|
@ -1,29 +0,0 @@
|
|||
From 6b150b3e9f1d16e6c374e178107ab490a18346dd Mon Sep 17 00:00:00 2001
|
||||
From: Asad Mehmood <asad78611@googlemail.com>
|
||||
Date: Thu, 17 Oct 2013 16:05:59 +0100
|
||||
Subject: [PATCH] monitor: expose min-backlight-step
|
||||
|
||||
Expose min-backlight-step so that gnome-settings-daemon can
|
||||
support backlights with less than 10 steps without mutter
|
||||
normalizing the brightness back to its original value
|
||||
---
|
||||
src/core/monitor.c | 3 +++
|
||||
1 file changed, 3 insertions(+)
|
||||
|
||||
diff --git a/src/core/monitor.c b/src/core/monitor.c
|
||||
index 9ec0c2a..6d65f9e 100644
|
||||
--- a/src/core/monitor.c
|
||||
+++ b/src/core/monitor.c
|
||||
@@ -806,6 +806,9 @@ meta_monitor_manager_handle_get_resources (MetaDBusDisplayConfig *skeleton,
|
||||
g_variant_new_take_string (make_display_name (manager, output)));
|
||||
g_variant_builder_add (&properties, "{sv}", "backlight",
|
||||
g_variant_new_int32 (output->backlight));
|
||||
+ g_variant_builder_add (&properties, "{sv}", "min-backlight-step",
|
||||
+ g_variant_new_int32 ((output->backlight_max - output->backlight_min) ?
|
||||
+ 100 / (output->backlight_max - output->backlight_min) : -1));
|
||||
g_variant_builder_add (&properties, "{sv}", "primary",
|
||||
g_variant_new_boolean (output->is_primary));
|
||||
g_variant_builder_add (&properties, "{sv}", "presentation",
|
||||
--
|
||||
1.8.4.1
|
||||
|
|
@ -1,4 +1,4 @@
|
|||
# $Id: PKGBUILD 170001 2012-10-30 23:01:35Z heftig $
|
||||
# $Id$
|
||||
# Maintainer: Jan Alexander Steffens (heftig) <jan.steffens@gmail.com>
|
||||
# Maintainer: Ionut Biru <ibiru@archlinux.org>
|
||||
# Contributor: Michael Kanis <mkanis_at_gmx_dot_de>
|
||||
|
@ -6,8 +6,8 @@
|
|||
# ALARM: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
# - set --enable-compile-warnings=no in configure
|
||||
|
||||
pkgname=mutter
|
||||
pkgver=3.10.4
|
||||
ppkgname=mutter
|
||||
pkgver=3.12.0
|
||||
pkgrel=1
|
||||
pkgdesc="A window manager for GNOME"
|
||||
arch=(i686 x86_64)
|
||||
|
@ -16,19 +16,10 @@ depends=('clutter' 'dconf' 'gobject-introspection' 'gsettings-desktop-schemas' '
|
|||
makedepends=('intltool' 'gnome-doc-utils')
|
||||
url="http://www.gnome.org"
|
||||
groups=('gnome')
|
||||
options=('!libtool' '!emptydirs')
|
||||
options=('!emptydirs')
|
||||
install=mutter.install
|
||||
source=(http://ftp.gnome.org/pub/gnome/sources/$pkgname/${pkgver:0:4}/$pkgname-$pkgver.tar.xz
|
||||
0001-monitor-expose-min-backlight-step.patch)
|
||||
sha256sums=('9159c40ea9f5c5e3d1e67cc12ebcbd6328a7b732274195b4e5bdacb3cb1771e6'
|
||||
'f1ef173d96ac27abdcf765972d2ac434f63bf4629b8bd51c177e8963d07f5eb7')
|
||||
|
||||
prepare() {
|
||||
cd "$pkgname-$pkgver"
|
||||
|
||||
# FS#37224
|
||||
patch -Np1 -i ../0001-monitor-expose-min-backlight-step.patch
|
||||
}
|
||||
source=(http://ftp.gnome.org/pub/gnome/sources/$pkgname/${pkgver:0:4}/$pkgname-$pkgver.tar.xz)
|
||||
sha256sums=('1dcc5c71a80b74c48e8a3f1ce90bd718ab53b267cd20fe28b1543c358bb42ac6')
|
||||
|
||||
build() {
|
||||
cd "$pkgname-$pkgver"
|
||||
|
|
Loading…
Reference in a new issue