extra/chromium to 97.0.4692.99-2

This commit is contained in:
Kevin Mihelich 2022-01-23 13:03:06 +00:00
parent 0f8ebe3771
commit 7d58afd3b0
2 changed files with 687 additions and 1 deletions

View file

@ -18,7 +18,7 @@ highmem=1
pkgname=chromium
pkgver=97.0.4692.99
pkgrel=1
pkgrel=2
_launcher_ver=8
_gcc_patchset=4
pkgdesc="A web browser built for speed, simplicity, and security"
@ -38,6 +38,7 @@ options=('!lto') # Chromium adds its own flags for ThinLTO
source=(https://commondatastorage.googleapis.com/chromium-browser-official/$pkgname-$pkgver.tar.xz
https://github.com/foutrelis/chromium-launcher/archive/v$_launcher_ver/chromium-launcher-$_launcher_ver.tar.gz
https://github.com/stha09/chromium-patches/releases/download/chromium-${pkgver%%.*}-patchset-$_gcc_patchset/chromium-${pkgver%%.*}-patchset-$_gcc_patchset.tar.xz
wayland-fix-binding-to-wrong-version.patch
sql-make-VirtualCursor-standard-layout-type.patch
chromium-93-ffmpeg-4.4.patch
unbundle-ffmpeg-av_stream_get_first_dts.patch
@ -49,6 +50,7 @@ source=(https://commondatastorage.googleapis.com/chromium-browser-official/$pkgn
sha256sums=('c91bae205705b367f2cfc1f72ce1ee99b2ceb5edfc584e15c60a6ab5ff01ecba'
'213e50f48b67feb4441078d50b0fd431df34323be15be97c55302d3fdac4483a'
'7af5c0a55a20c0fb496b2f4448d89203a83bb1914754d864460e55e68731ef0b'
'29541840921302060f712838ba460cd7e988148af3ce3c9dc45437fc78442a67'
'dd317f85e5abfdcfc89c6f23f4c8edbcdebdd5e083dcec770e5da49ee647d150'
'1a9e074f417f8ffd78bcd6874d8e2e74a239905bf662f76a7755fa40dc476b57'
'1f0c1a7a1eb67d91765c9f28df815f58e1c6dc7b37d0acd4d68cac8e5515786c'
@ -142,6 +144,7 @@ prepare() {
patch -Np0 -i ../unexpire-accelerated-video-decode-flag.patch
# Upstream fixes
patch -Np1 -i ../wayland-fix-binding-to-wrong-version.patch
# https://chromium-review.googlesource.com/c/chromium/src/+/2862724
patch -Np1 -i ../sql-make-VirtualCursor-standard-layout-type.patch

View file

@ -0,0 +1,683 @@
From 5e3ed3d015d0ddae5e4d813204616d89d2f859c7 Mon Sep 17 00:00:00 2001
From: Alexander Dunaev <adunaev@igalia.com>
Date: Tue, 14 Dec 2021 09:54:52 +0000
Subject: [PATCH 1/2] [linux/wayland] Fixed terminate caused by binding to
wrong version.
The Ozone/Wayland implementation had a few places where the Wayland
objects were bound without proper checking for their versions. That was
part of the technical debt not addressed before, and ended up causing
the issue explained in the linked crbug: the compositor terminates the
client that binds to the protocol that it does not actually support.
This patch fixes the issue by adding the necessary checks in all places
where they were missing. Also a convenience macro for validating the
version is proposed.
Bug: 1279574
Change-Id: I74efa97f64b480bed47372d8d559593ae84eeb18
Reviewed-on: https://chromium-review.googlesource.com/c/chromium/src/+/3337037
Reviewed-by: Maksim Sisov <msisov@igalia.com>
Commit-Queue: Alexander Dunaev <adunaev@igalia.com>
Cr-Commit-Position: refs/heads/main@{#951428}
(cherry picked from commit dd4c3ddadbb9869f59cee201a38e9ca3b9154f4d)
---
.../platform/wayland/common/wayland_object.cc | 21 +++++++++++++++++++
.../platform/wayland/common/wayland_object.h | 11 ++++++++++
.../gtk_primary_selection_device_manager.cc | 11 +++++-----
ui/ozone/platform/wayland/host/gtk_shell1.cc | 12 ++++++-----
.../wayland/host/org_kde_kwin_idle.cc | 9 ++++----
.../wayland/host/overlay_prioritizer.cc | 9 ++++----
.../wayland/host/surface_augmenter.cc | 11 ++++++----
.../host/wayland_data_device_manager.cc | 9 +++++---
ui/ozone/platform/wayland/host/wayland_drm.cc | 6 ++++--
.../platform/wayland/host/wayland_output.cc | 10 ++++-----
ui/ozone/platform/wayland/host/wayland_shm.cc | 9 ++++----
.../wayland/host/wayland_zaura_shell.cc | 9 +++++---
.../wayland/host/wayland_zcr_cursor_shapes.cc | 10 +++++----
.../wayland/host/wayland_zwp_linux_dmabuf.cc | 9 +++++---
.../host/wayland_zwp_pointer_constraints.cc | 6 +++---
.../host/wayland_zwp_pointer_gestures.cc | 7 ++++---
.../wayland_zwp_relative_pointer_manager.cc | 8 ++++---
.../wayland/host/xdg_foreign_wrapper.cc | 14 ++++++++-----
.../wayland/host/zwp_idle_inhibit_manager.cc | 10 +++++----
.../zwp_primary_selection_device_manager.cc | 9 ++++----
20 files changed, 131 insertions(+), 69 deletions(-)
diff --git a/ui/ozone/platform/wayland/common/wayland_object.cc b/ui/ozone/platform/wayland/common/wayland_object.cc
index 0374cb9d874..8faa648120d 100644
--- a/ui/ozone/platform/wayland/common/wayland_object.cc
+++ b/ui/ozone/platform/wayland/common/wayland_object.cc
@@ -35,6 +35,8 @@
#include <xdg-shell-client-protocol.h>
#include <xdg-shell-unstable-v6-client-protocol.h>
+#include "base/logging.h"
+
namespace wl {
namespace {
@@ -77,6 +79,25 @@ void delete_touch(wl_touch* touch) {
} // namespace
+bool CanBind(const std::string& interface,
+ uint32_t available_version,
+ uint32_t min_version,
+ uint32_t max_version) {
+ if (available_version < min_version) {
+ LOG(WARNING) << "Unable to bind to " << interface << " version "
+ << available_version << ". The minimum supported version is "
+ << min_version << ".";
+ return false;
+ }
+
+ if (available_version > max_version) {
+ LOG(WARNING) << "Binding to " << interface << " version " << max_version
+ << " but version " << available_version << " is available.";
+ }
+
+ return true;
+}
+
void (*ObjectTraits<wl_cursor_theme>::deleter)(wl_cursor_theme*) =
&wl_cursor_theme_destroy;
diff --git a/ui/ozone/platform/wayland/common/wayland_object.h b/ui/ozone/platform/wayland/common/wayland_object.h
index 3a8bb9e494d..ce787bf8805 100644
--- a/ui/ozone/platform/wayland/common/wayland_object.h
+++ b/ui/ozone/platform/wayland/common/wayland_object.h
@@ -79,6 +79,17 @@ struct ObjectTraits<wl_proxy> {
static void (*deleter)(void*);
};
+// Checks the given |available_version| exposed by the server against
+// |min_version| and |max_version| supported by the client.
+// Returns false (with rendering a warning) if |available_version| is less than
+// the minimum supported version.
+// Returns true otherwise, renders an info message if |available_version| is
+// greater than the maximum supported one.
+bool CanBind(const std::string& interface,
+ uint32_t available_version,
+ uint32_t min_version,
+ uint32_t max_version);
+
} // namespace wl
// Puts the forward declaration for struct TYPE and declares the template
diff --git a/ui/ozone/platform/wayland/host/gtk_primary_selection_device_manager.cc b/ui/ozone/platform/wayland/host/gtk_primary_selection_device_manager.cc
index af3087d1891..2991233fe6e 100644
--- a/ui/ozone/platform/wayland/host/gtk_primary_selection_device_manager.cc
+++ b/ui/ozone/platform/wayland/host/gtk_primary_selection_device_manager.cc
@@ -16,7 +16,7 @@
namespace ui {
namespace {
-constexpr uint32_t kMaxGtkPrimarySelectionDeviceManagerVersion = 1;
+constexpr uint32_t kMinVersion = 1;
}
// static
@@ -31,12 +31,13 @@ void GtkPrimarySelectionDeviceManager::Instantiate(
uint32_t version) {
DCHECK_EQ(interface, kInterfaceName);
- if (connection->gtk_primary_selection_device_manager())
+ if (connection->gtk_primary_selection_device_manager() ||
+ !wl::CanBind(interface, version, kMinVersion, kMinVersion)) {
return;
+ }
- auto manager = wl::Bind<gtk_primary_selection_device_manager>(
- registry, name,
- std::min(version, kMaxGtkPrimarySelectionDeviceManagerVersion));
+ auto manager = wl::Bind<gtk_primary_selection_device_manager>(registry, name,
+ kMinVersion);
if (!manager) {
LOG(ERROR) << "Failed to bind gtk_primary_selection_device_manager";
return;
diff --git a/ui/ozone/platform/wayland/host/gtk_shell1.cc b/ui/ozone/platform/wayland/host/gtk_shell1.cc
index cb3b0c8fa02..26dfd7fbf3f 100644
--- a/ui/ozone/platform/wayland/host/gtk_shell1.cc
+++ b/ui/ozone/platform/wayland/host/gtk_shell1.cc
@@ -17,8 +17,8 @@ namespace {
// gtk_shell1 exposes request_focus() since version 3. Below that, it is not
// interesting for us, although it provides some shell integration that might be
// useful.
-constexpr uint32_t kMinGtkShell1Version = 3;
-constexpr uint32_t kMaxGtkShell1Version = 4;
+constexpr uint32_t kMinVersion = 3;
+constexpr uint32_t kMaxVersion = 4;
} // namespace
// static
@@ -32,11 +32,13 @@ void GtkShell1::Instantiate(WaylandConnection* connection,
uint32_t version) {
DCHECK_EQ(interface, kInterfaceName);
- if (connection->gtk_shell1_ || version < kMinGtkShell1Version)
+ if (connection->gtk_shell1_ ||
+ !wl::CanBind(interface, version, kMinVersion, kMaxVersion)) {
return;
+ }
- auto gtk_shell1 = wl::Bind<::gtk_shell1>(
- registry, name, std::min(version, kMaxGtkShell1Version));
+ auto gtk_shell1 =
+ wl::Bind<::gtk_shell1>(registry, name, std::min(version, kMaxVersion));
if (!gtk_shell1) {
LOG(ERROR) << "Failed to bind gtk_shell1";
return;
diff --git a/ui/ozone/platform/wayland/host/org_kde_kwin_idle.cc b/ui/ozone/platform/wayland/host/org_kde_kwin_idle.cc
index 4746aa798c0..8b7a7416d95 100644
--- a/ui/ozone/platform/wayland/host/org_kde_kwin_idle.cc
+++ b/ui/ozone/platform/wayland/host/org_kde_kwin_idle.cc
@@ -13,7 +13,7 @@ namespace ui {
namespace {
-constexpr uint32_t kMaxOrgKdeKwinIdleVersion = 1;
+constexpr uint32_t kMinVersion = 1;
// After the system has gone idle, it will wait for this time before notifying
// us. This reduces "jitter" of the idle/active state, but also adds some lag
@@ -58,11 +58,12 @@ void OrgKdeKwinIdle::Instantiate(WaylandConnection* connection,
uint32_t version) {
DCHECK_EQ(interface, kInterfaceName);
- if (connection->org_kde_kwin_idle_)
+ if (connection->org_kde_kwin_idle_ ||
+ !wl::CanBind(interface, version, kMinVersion, kMinVersion)) {
return;
+ }
- auto idle = wl::Bind<struct org_kde_kwin_idle>(
- registry, name, std::min(version, kMaxOrgKdeKwinIdleVersion));
+ auto idle = wl::Bind<struct org_kde_kwin_idle>(registry, name, kMinVersion);
if (!idle) {
LOG(ERROR) << "Failed to bind to org_kde_kwin_idle global";
return;
diff --git a/ui/ozone/platform/wayland/host/overlay_prioritizer.cc b/ui/ozone/platform/wayland/host/overlay_prioritizer.cc
index e8aaf39a337..11496b52324 100644
--- a/ui/ozone/platform/wayland/host/overlay_prioritizer.cc
+++ b/ui/ozone/platform/wayland/host/overlay_prioritizer.cc
@@ -12,7 +12,7 @@
namespace ui {
namespace {
-constexpr uint32_t kMaxOverlayPrioritizerVersion = 1;
+constexpr uint32_t kMinVersion = 1;
}
// static
@@ -26,11 +26,12 @@ void OverlayPrioritizer::Instantiate(WaylandConnection* connection,
uint32_t version) {
DCHECK_EQ(interface, kInterfaceName);
- if (connection->overlay_prioritizer_)
+ if (connection->overlay_prioritizer_ ||
+ !wl::CanBind(interface, version, kMinVersion, kMinVersion)) {
return;
+ }
- auto prioritizer = wl::Bind<overlay_prioritizer>(
- registry, name, std::min(version, kMaxOverlayPrioritizerVersion));
+ auto prioritizer = wl::Bind<overlay_prioritizer>(registry, name, kMinVersion);
if (!prioritizer) {
LOG(ERROR) << "Failed to bind overlay_prioritizer";
return;
diff --git a/ui/ozone/platform/wayland/host/surface_augmenter.cc b/ui/ozone/platform/wayland/host/surface_augmenter.cc
index 8294897bcd5..0589076bcf5 100644
--- a/ui/ozone/platform/wayland/host/surface_augmenter.cc
+++ b/ui/ozone/platform/wayland/host/surface_augmenter.cc
@@ -13,7 +13,8 @@
namespace ui {
namespace {
-constexpr uint32_t kMaxSurfaceAugmenterVersion = 1;
+constexpr uint32_t kMinVersion = 1;
+constexpr uint32_t kMaxVersion = 1;
}
// static
@@ -27,11 +28,13 @@ void SurfaceAugmenter::Instantiate(WaylandConnection* connection,
uint32_t version) {
DCHECK_EQ(interface, kInterfaceName);
- if (connection->surface_augmenter_)
+ if (connection->surface_augmenter_ ||
+ !wl::CanBind(interface, version, kMinVersion, kMaxVersion)) {
return;
+ }
- auto augmenter = wl::Bind<surface_augmenter>(
- registry, name, std::min(version, kMaxSurfaceAugmenterVersion));
+ auto augmenter = wl::Bind<surface_augmenter>(registry, name,
+ std::min(version, kMaxVersion));
if (!augmenter) {
LOG(ERROR) << "Failed to bind overlay_prioritizer";
return;
diff --git a/ui/ozone/platform/wayland/host/wayland_data_device_manager.cc b/ui/ozone/platform/wayland/host/wayland_data_device_manager.cc
index 408cb1c72f4..0f03942e699 100644
--- a/ui/ozone/platform/wayland/host/wayland_data_device_manager.cc
+++ b/ui/ozone/platform/wayland/host/wayland_data_device_manager.cc
@@ -14,7 +14,8 @@
namespace ui {
namespace {
-constexpr uint32_t kMaxDeviceManagerVersion = 3;
+constexpr uint32_t kMinVersion = 1;
+constexpr uint32_t kMaxVersion = 3;
}
// static
@@ -28,11 +29,13 @@ void WaylandDataDeviceManager::Instantiate(WaylandConnection* connection,
uint32_t version) {
DCHECK_EQ(interface, kInterfaceName);
- if (connection->data_device_manager_)
+ if (connection->data_device_manager_ ||
+ !wl::CanBind(interface, version, kMinVersion, kMaxVersion)) {
return;
+ }
auto data_device_manager = wl::Bind<wl_data_device_manager>(
- registry, name, std::min(version, kMaxDeviceManagerVersion));
+ registry, name, std::min(version, kMaxVersion));
if (!data_device_manager) {
LOG(ERROR) << "Failed to bind to wl_data_device_manager global";
return;
diff --git a/ui/ozone/platform/wayland/host/wayland_drm.cc b/ui/ozone/platform/wayland/host/wayland_drm.cc
index d806e8e9f5d..a7ed2e20ffe 100644
--- a/ui/ozone/platform/wayland/host/wayland_drm.cc
+++ b/ui/ozone/platform/wayland/host/wayland_drm.cc
@@ -17,7 +17,7 @@
namespace ui {
namespace {
-constexpr uint32_t kMinWlDrmVersion = 2;
+constexpr uint32_t kMinVersion = 2;
}
// static
@@ -31,8 +31,10 @@ void WaylandDrm::Instantiate(WaylandConnection* connection,
uint32_t version) {
DCHECK_EQ(interface, kInterfaceName);
- if (connection->drm_ || version < kMinWlDrmVersion)
+ if (connection->drm_ ||
+ !!wl::CanBind(interface, version, kMinVersion, kMinVersion)) {
return;
+ }
auto wl_drm = wl::Bind<struct wl_drm>(registry, name, version);
if (!wl_drm) {
diff --git a/ui/ozone/platform/wayland/host/wayland_output.cc b/ui/ozone/platform/wayland/host/wayland_output.cc
index 2d481d1167e..13e2b2ea685 100644
--- a/ui/ozone/platform/wayland/host/wayland_output.cc
+++ b/ui/ozone/platform/wayland/host/wayland_output.cc
@@ -16,7 +16,8 @@
namespace ui {
namespace {
-constexpr uint32_t kMinWlOutputVersion = 2;
+// TODO(crbug.com/1279681): support newer versions.
+constexpr uint32_t kMinVersion = 2;
}
// static
@@ -30,14 +31,11 @@ void WaylandOutput::Instantiate(WaylandConnection* connection,
uint32_t version) {
DCHECK_EQ(interface, kInterfaceName);
- if (version < kMinWlOutputVersion) {
- LOG(ERROR)
- << "Unable to bind to the unsupported wl_output object with version= "
- << version << ". Minimum supported version is " << kMinWlOutputVersion;
+ if (!wl::CanBind(interface, version, kMinVersion, kMinVersion)) {
return;
}
- auto output = wl::Bind<wl_output>(registry, name, version);
+ auto output = wl::Bind<wl_output>(registry, name, kMinVersion);
if (!output) {
LOG(ERROR) << "Failed to bind to wl_output global";
return;
diff --git a/ui/ozone/platform/wayland/host/wayland_shm.cc b/ui/ozone/platform/wayland/host/wayland_shm.cc
index 7c6cd40569d..de97ad1c2b2 100644
--- a/ui/ozone/platform/wayland/host/wayland_shm.cc
+++ b/ui/ozone/platform/wayland/host/wayland_shm.cc
@@ -10,7 +10,7 @@
namespace ui {
namespace {
-constexpr uint32_t kMaxShmVersion = 1;
+constexpr uint32_t kMinVersion = 1;
constexpr uint32_t kShmFormat = WL_SHM_FORMAT_ARGB8888;
} // namespace
@@ -25,11 +25,12 @@ void WaylandShm::Instantiate(WaylandConnection* connection,
uint32_t version) {
DCHECK_EQ(interface, kInterfaceName);
- if (connection->shm_)
+ if (connection->shm_ ||
+ !wl::CanBind(interface, version, kMinVersion, kMinVersion)) {
return;
+ }
- auto shm =
- wl::Bind<wl_shm>(registry, name, std::min(version, kMaxShmVersion));
+ auto shm = wl::Bind<wl_shm>(registry, name, kMinVersion);
if (!shm) {
LOG(ERROR) << "Failed to bind to wl_shm global";
return;
diff --git a/ui/ozone/platform/wayland/host/wayland_zaura_shell.cc b/ui/ozone/platform/wayland/host/wayland_zaura_shell.cc
index b1ae436db08..1b5585f7c18 100644
--- a/ui/ozone/platform/wayland/host/wayland_zaura_shell.cc
+++ b/ui/ozone/platform/wayland/host/wayland_zaura_shell.cc
@@ -19,7 +19,8 @@
namespace ui {
namespace {
-constexpr uint32_t kMaxAuraShellVersion = 28;
+constexpr uint32_t kMinVersion = 1;
+constexpr uint32_t kMaxVersion = 28;
}
// static
@@ -33,11 +34,13 @@ void WaylandZAuraShell::Instantiate(WaylandConnection* connection,
uint32_t version) {
DCHECK_EQ(interface, kInterfaceName);
- if (connection->zaura_shell_)
+ if (connection->zaura_shell_ ||
+ !wl::CanBind(interface, version, kMinVersion, kMaxVersion)) {
return;
+ }
auto zaura_shell = wl::Bind<struct zaura_shell>(
- registry, name, std::min(version, kMaxAuraShellVersion));
+ registry, name, std::min(version, kMaxVersion));
if (!zaura_shell) {
LOG(ERROR) << "Failed to bind zaura_shell";
return;
diff --git a/ui/ozone/platform/wayland/host/wayland_zcr_cursor_shapes.cc b/ui/ozone/platform/wayland/host/wayland_zcr_cursor_shapes.cc
index 094a2f98686..84d847eea16 100644
--- a/ui/ozone/platform/wayland/host/wayland_zcr_cursor_shapes.cc
+++ b/ui/ozone/platform/wayland/host/wayland_zcr_cursor_shapes.cc
@@ -16,7 +16,7 @@
namespace ui {
namespace {
-constexpr uint32_t kMaxCursorShapesVersion = 1;
+constexpr uint32_t kMinVersion = 1;
}
using mojom::CursorType;
@@ -32,11 +32,13 @@ void WaylandZcrCursorShapes::Instantiate(WaylandConnection* connection,
uint32_t version) {
DCHECK_EQ(interface, kInterfaceName);
- if (connection->zcr_cursor_shapes_)
+ if (connection->zcr_cursor_shapes_ ||
+ !wl::CanBind(interface, version, kMinVersion, kMinVersion)) {
return;
+ }
- auto zcr_cursor_shapes = wl::Bind<zcr_cursor_shapes_v1>(
- registry, name, std::min(version, kMaxCursorShapesVersion));
+ auto zcr_cursor_shapes =
+ wl::Bind<zcr_cursor_shapes_v1>(registry, name, kMinVersion);
if (!zcr_cursor_shapes) {
LOG(ERROR) << "Failed to bind zcr_cursor_shapes_v1";
return;
diff --git a/ui/ozone/platform/wayland/host/wayland_zwp_linux_dmabuf.cc b/ui/ozone/platform/wayland/host/wayland_zwp_linux_dmabuf.cc
index 7035dc4ed26..cee793b9ae8 100644
--- a/ui/ozone/platform/wayland/host/wayland_zwp_linux_dmabuf.cc
+++ b/ui/ozone/platform/wayland/host/wayland_zwp_linux_dmabuf.cc
@@ -14,7 +14,8 @@
namespace ui {
namespace {
-constexpr uint32_t kMaxLinuxDmabufVersion = 3;
+constexpr uint32_t kMinVersion = 1;
+constexpr uint32_t kMaxVersion = 3;
}
// static
@@ -28,11 +29,13 @@ void WaylandZwpLinuxDmabuf::Instantiate(WaylandConnection* connection,
uint32_t version) {
DCHECK_EQ(interface, kInterfaceName);
- if (connection->zwp_dmabuf())
+ if (connection->zwp_dmabuf() ||
+ !wl::CanBind(interface, version, kMinVersion, kMaxVersion)) {
return;
+ }
auto zwp_linux_dmabuf = wl::Bind<zwp_linux_dmabuf_v1>(
- registry, name, std::min(version, kMaxLinuxDmabufVersion));
+ registry, name, std::min(version, kMaxVersion));
if (!zwp_linux_dmabuf) {
LOG(ERROR) << "Failed to bind zwp_linux_dmabuf_v1";
return;
diff --git a/ui/ozone/platform/wayland/host/wayland_zwp_pointer_constraints.cc b/ui/ozone/platform/wayland/host/wayland_zwp_pointer_constraints.cc
index 24e4dacc7ee..c1aca770ff5 100644
--- a/ui/ozone/platform/wayland/host/wayland_zwp_pointer_constraints.cc
+++ b/ui/ozone/platform/wayland/host/wayland_zwp_pointer_constraints.cc
@@ -15,7 +15,7 @@
namespace ui {
namespace {
-constexpr uint32_t kMinZwpPointerConstraintsVersion = 1;
+constexpr uint32_t kMinVersion = 1;
}
// static
@@ -30,12 +30,12 @@ void WaylandZwpPointerConstraints::Instantiate(WaylandConnection* connection,
DCHECK_EQ(interface, kInterfaceName);
if (connection->wayland_zwp_pointer_constraints_ ||
- version < kMinZwpPointerConstraintsVersion) {
+ !wl::CanBind(interface, version, kMinVersion, kMinVersion)) {
return;
}
auto zwp_pointer_constraints_v1 =
- wl::Bind<struct zwp_pointer_constraints_v1>(registry, name, version);
+ wl::Bind<struct zwp_pointer_constraints_v1>(registry, name, kMinVersion);
if (!zwp_pointer_constraints_v1) {
LOG(ERROR) << "Failed to bind wp_pointer_constraints_v1";
return;
diff --git a/ui/ozone/platform/wayland/host/wayland_zwp_pointer_gestures.cc b/ui/ozone/platform/wayland/host/wayland_zwp_pointer_gestures.cc
index 5d96c8923fd..31bffb726c6 100644
--- a/ui/ozone/platform/wayland/host/wayland_zwp_pointer_gestures.cc
+++ b/ui/ozone/platform/wayland/host/wayland_zwp_pointer_gestures.cc
@@ -19,7 +19,7 @@
namespace ui {
namespace {
-constexpr uint32_t kMinZwpPointerGesturesVersion = 1;
+constexpr uint32_t kMinVersion = 1;
}
// static
@@ -34,11 +34,12 @@ void WaylandZwpPointerGestures::Instantiate(WaylandConnection* connection,
DCHECK_EQ(interface, kInterfaceName);
if (connection->wayland_zwp_pointer_gestures_ ||
- version < kMinZwpPointerGesturesVersion)
+ !wl::CanBind(interface, version, kMinVersion, kMinVersion)) {
return;
+ }
auto zwp_pointer_gestures_v1 =
- wl::Bind<struct zwp_pointer_gestures_v1>(registry, name, version);
+ wl::Bind<struct zwp_pointer_gestures_v1>(registry, name, kMinVersion);
if (!zwp_pointer_gestures_v1) {
LOG(ERROR) << "Failed to bind wp_pointer_gestures_v1";
return;
diff --git a/ui/ozone/platform/wayland/host/wayland_zwp_relative_pointer_manager.cc b/ui/ozone/platform/wayland/host/wayland_zwp_relative_pointer_manager.cc
index 3a8ef4c7f96..c84a891dfe7 100644
--- a/ui/ozone/platform/wayland/host/wayland_zwp_relative_pointer_manager.cc
+++ b/ui/ozone/platform/wayland/host/wayland_zwp_relative_pointer_manager.cc
@@ -14,7 +14,7 @@
namespace ui {
namespace {
-constexpr uint32_t kMinZwpRelativePointerManagerVersion = 1;
+constexpr uint32_t kMinVersion = 1;
}
// static
@@ -30,11 +30,13 @@ void WaylandZwpRelativePointerManager::Instantiate(
DCHECK_EQ(interface, kInterfaceName);
if (connection->wayland_zwp_relative_pointer_manager_ ||
- version < kMinZwpRelativePointerManagerVersion)
+ !wl::CanBind(interface, version, kMinVersion, kMinVersion)) {
return;
+ }
auto zwp_relative_pointer_manager_v1 =
- wl::Bind<struct zwp_relative_pointer_manager_v1>(registry, name, version);
+ wl::Bind<struct zwp_relative_pointer_manager_v1>(registry, name,
+ kMinVersion);
if (!zwp_relative_pointer_manager_v1) {
LOG(ERROR) << "Failed to bind zwp_relative_pointer_manager_v1";
return;
diff --git a/ui/ozone/platform/wayland/host/xdg_foreign_wrapper.cc b/ui/ozone/platform/wayland/host/xdg_foreign_wrapper.cc
index a34b684d128..2586adf9b85 100644
--- a/ui/ozone/platform/wayland/host/xdg_foreign_wrapper.cc
+++ b/ui/ozone/platform/wayland/host/xdg_foreign_wrapper.cc
@@ -19,6 +19,8 @@ constexpr char XdgForeignWrapper::kInterfaceNameV1[];
// static
constexpr char XdgForeignWrapper::kInterfaceNameV2[];
+constexpr uint32_t kMinVersion = 1;
+
using OnHandleExported = XdgForeignWrapper::OnHandleExported;
namespace {
@@ -185,15 +187,17 @@ void XdgForeignWrapper::Instantiate(WaylandConnection* connection,
uint32_t name,
const std::string& interface,
uint32_t version) {
- if (connection->xdg_foreign_)
+ if (connection->xdg_foreign_ ||
+ !wl::CanBind(interface, version, kMinVersion, kMinVersion)) {
return;
+ }
if (interface == kInterfaceNameV1) {
- connection->xdg_foreign_ =
- CreateWrapper<zxdg_exporter_v1>(connection, registry, name, version);
+ connection->xdg_foreign_ = CreateWrapper<zxdg_exporter_v1>(
+ connection, registry, name, kMinVersion);
} else if (interface == kInterfaceNameV2) {
- connection->xdg_foreign_ =
- CreateWrapper<zxdg_exporter_v2>(connection, registry, name, version);
+ connection->xdg_foreign_ = CreateWrapper<zxdg_exporter_v2>(
+ connection, registry, name, kMinVersion);
} else {
NOTREACHED() << " unexpected interface name: " << interface;
}
diff --git a/ui/ozone/platform/wayland/host/zwp_idle_inhibit_manager.cc b/ui/ozone/platform/wayland/host/zwp_idle_inhibit_manager.cc
index 47121293acb..fc05de68778 100644
--- a/ui/ozone/platform/wayland/host/zwp_idle_inhibit_manager.cc
+++ b/ui/ozone/platform/wayland/host/zwp_idle_inhibit_manager.cc
@@ -12,7 +12,7 @@
namespace ui {
namespace {
-constexpr uint32_t kMaxZwpIdleInhibitManagerVersion = 1;
+constexpr uint32_t kMinVersion = 1;
}
// static
@@ -26,11 +26,13 @@ void ZwpIdleInhibitManager::Instantiate(WaylandConnection* connection,
uint32_t version) {
DCHECK_EQ(interface, kInterfaceName);
- if (connection->zwp_idle_inhibit_manager_)
+ if (connection->zwp_idle_inhibit_manager_ ||
+ !wl::CanBind(interface, version, kMinVersion, kMinVersion)) {
return;
+ }
- auto manager = wl::Bind<zwp_idle_inhibit_manager_v1>(
- registry, name, std::min(version, kMaxZwpIdleInhibitManagerVersion));
+ auto manager =
+ wl::Bind<zwp_idle_inhibit_manager_v1>(registry, name, kMinVersion);
if (!manager) {
LOG(ERROR) << "Failed to bind zwp_idle_inhibit_manager_v1";
return;
diff --git a/ui/ozone/platform/wayland/host/zwp_primary_selection_device_manager.cc b/ui/ozone/platform/wayland/host/zwp_primary_selection_device_manager.cc
index f6f9fd23c35..795a09c0565 100644
--- a/ui/ozone/platform/wayland/host/zwp_primary_selection_device_manager.cc
+++ b/ui/ozone/platform/wayland/host/zwp_primary_selection_device_manager.cc
@@ -16,7 +16,7 @@
namespace ui {
namespace {
-constexpr uint32_t kMaxGtkPrimarySelectionDeviceManagerVersion = 1;
+constexpr uint32_t kMinVersion = 1;
} // namespace
// static
@@ -31,12 +31,13 @@ void ZwpPrimarySelectionDeviceManager::Instantiate(
uint32_t version) {
DCHECK_EQ(interface, kInterfaceName);
- if (connection->zwp_primary_selection_device_manager_)
+ if (connection->zwp_primary_selection_device_manager_ ||
+ !wl::CanBind(interface, version, kMinVersion, kMinVersion)) {
return;
+ }
auto manager = wl::Bind<zwp_primary_selection_device_manager_v1>(
- registry, name,
- std::min(version, kMaxGtkPrimarySelectionDeviceManagerVersion));
+ registry, name, kMinVersion);
if (!manager) {
LOG(ERROR) << "Failed to bind zwp_primary_selection_device_manager_v1";
return;
From cd9eae3117ccc930f0cfae6d24bba1d6d66d769c Mon Sep 17 00:00:00 2001
From: Alexander Dunaev <adunaev@igalia.com>
Date: Tue, 28 Dec 2021 14:02:05 +0000
Subject: [PATCH 2/2] [linux/wayland] Fixed terminate caused by binding to
wrong version.
This is a fixup to [1] where a typo creeped in.
[1] https://chromium-review.googlesource.com/c/chromium/src/+/3337037
Bug: 1279574
Change-Id: If8f1a308ce8d27b51a9cd4d52ad8eec2e29edf95
Reviewed-on: https://chromium-review.googlesource.com/c/chromium/src/+/3358254
Reviewed-by: Antonio Gomes <tonikitoo@igalia.com>
Commit-Queue: Alexander Dunaev <adunaev@igalia.com>
Auto-Submit: Alexander Dunaev <adunaev@igalia.com>
Cr-Commit-Position: refs/heads/main@{#954286}
(cherry picked from commit a84b79daa8897b822336b8f348ef4daaae07af37)
---
ui/ozone/platform/wayland/host/wayland_drm.cc | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/ui/ozone/platform/wayland/host/wayland_drm.cc b/ui/ozone/platform/wayland/host/wayland_drm.cc
index a7ed2e20ffe..b10b79412e5 100644
--- a/ui/ozone/platform/wayland/host/wayland_drm.cc
+++ b/ui/ozone/platform/wayland/host/wayland_drm.cc
@@ -32,7 +32,7 @@ void WaylandDrm::Instantiate(WaylandConnection* connection,
DCHECK_EQ(interface, kInterfaceName);
if (connection->drm_ ||
- !!wl::CanBind(interface, version, kMinVersion, kMinVersion)) {
+ !wl::CanBind(interface, version, kMinVersion, kMinVersion)) {
return;
}