removed extra/clamav

This commit is contained in:
Kevin Mihelich 2014-05-08 13:14:58 +00:00
parent 6b4b55d30f
commit 7d62a420d9
9 changed files with 0 additions and 140 deletions

View file

@ -1,72 +0,0 @@
# $Id$
# Contributor: Dale Blount <dale@archlinux.org>
# Contributor: Gregor Ibic <gregor.ibic@intelicom.si>
# Maintainer: Gaetan Bisson <bisson@archlinux.org>
# ALARM: Kevin Mihelich <kevin@archlinuxarm.org>
# - add ARM fanotify system call numbers
pkgname=clamav
pkgver=0.98.1
pkgrel=2
pkgdesc='Anti-virus toolkit for Unix'
url='http://www.clamav.net/'
license=('GPL')
options=('!libtool')
arch=('i686' 'x86_64')
depends=('bzip2' 'libltdl')
backup=('etc/logrotate.d/clamav')
source=("http://downloads.sourceforge.net/project/${pkgname}/${pkgname}/${pkgver}/${pkgname}-${pkgver}.tar.gz"{,.sig}
'logrotate'
'tmpfiles.d'
'clamd.conf'
'freshclam.conf'
'clamd.service'
'freshclamd.service'
'arm.patch')
sha1sums=('9f04c0e81463c36f7e58d18f16d1b88f3332dcb8' 'SKIP'
'bb488a56b0f6a0760446cde89c1e3321e2717b78'
'a224ea9b4d0f4f196827347d54bed51e11c197ea'
'887f624eb305f2446f55d8339e2972ad0cfe2b79'
'b767837d0279ad30b92c314cb762b73e5ad0415e'
'b6ac0c5de1e5b41232b10d4f84e86201c370eaeb'
'cda9a087e5593992150cb456e34c5f6f589aca82'
'7855de9eb13c1ec7623375d36f184a2c0b208fcc')
backup=('etc/clamav/clamd.conf'
'etc/clamav/freshclam.conf'
'etc/logrotate.d/clamav')
install=install
prepare() {
cd "${srcdir}/${pkgname}-${pkgver}"
patch -p1 -i ../arm.patch
}
build() {
cd "${srcdir}/${pkgname}-${pkgver}"
./configure \
--prefix=/usr \
--sbindir=/usr/bin \
--sysconfdir=/etc/clamav \
--with-dbdir=/var/lib/clamav \
--disable-clamav \
make
}
package() {
cd "${srcdir}/${pkgname}-${pkgver}"
make DESTDIR="${pkgdir}" install
install -Dm644 ../clamd.conf "${pkgdir}"/etc/clamav/clamd.conf
install -Dm644 ../freshclam.conf "${pkgdir}"/etc/clamav/freshclam.conf
install -Dm644 ../freshclamd.service "${pkgdir}"/usr/lib/systemd/system/freshclamd.service
install -Dm644 ../clamd.service "${pkgdir}"/usr/lib/systemd/system/clamd.service
install -Dm644 ../tmpfiles.d "${pkgdir}"/usr/lib/tmpfiles.d/clamav.conf
install -Dm644 ../logrotate "${pkgdir}"/etc/logrotate.d/clamav
install -d -o 64 -g 64 "${pkgdir}"/var/log/clamav
install -d -o 64 -g 64 "${pkgdir}"/var/lib/clamav
}

View file

@ -1,13 +0,0 @@
diff -urN a/clamd/fan-syscalllib.h b/clamd/fan-syscalllib.h
--- a/clamd/fan-syscalllib.h 2013-09-16 13:28:14.000000000 -0600
+++ b/clamd/fan-syscalllib.h 2013-09-19 21:29:47.314868930 -0600
@@ -10,6 +10,9 @@
#elif defined(__i386__)
# define __NR_fanotify_init 338
# define __NR_fanotify_mark 339
+#elif defined(__ARM_EABI__)
+# define __NR_fanotify_init 367
+# define __NR_fanotify_mark 368
#else
# error "System call numbers not defined for this architecture"
#endif

View file

@ -1,6 +0,0 @@
LogFile /var/log/clamav/clamd.log
LogTime yes
PidFile /run/clamav/clamd.pid
TemporaryDirectory /tmp
LocalSocket /var/lib/clamav/clamd.sock
User clamav

View file

@ -1,10 +0,0 @@
[Unit]
Description=clamav daemon
[Service]
Type=forking
PIDFile=/run/clamav/clamd.pid
ExecStart=/usr/bin/clamd
[Install]
WantedBy=multi-user.target

View file

@ -1,3 +0,0 @@
UpdateLogFile /var/log/clamav/freshclam.log
DatabaseMirror database.clamav.net
NotifyClamd /etc/clamav/clamd.conf

View file

@ -1,10 +0,0 @@
[Unit]
Description=clamav updater
[Service]
Type=forking
PIDFile=/run/clamav/freshclam.pid
ExecStart=/usr/bin/freshclam -d -p /run/clamav/freshclam.pid
[Install]
WantedBy=multi-user.target

View file

@ -1,15 +0,0 @@
post_upgrade() {
systemd-tmpfiles --create clamav.conf
}
post_install() {
getent group clamav &>/dev/null || groupadd -r -g 64 clamav >/dev/null
getent passwd clamav &>/dev/null || useradd -r -u 64 -g clamav -d /dev/null -s /bin/false -c "Clam AntiVirus" clamav >/dev/null
post_upgrade
}
post_remove() {
getent passwd clamav &>/dev/null && userdel clamav >/dev/null
getent group clamav &>/dev/null && groupdel clamav >/dev/null
return 0
}

View file

@ -1,10 +0,0 @@
/var/log/clamav/clamd.log /var/log/clamav/freshclam.log {
create 644 clamav clamav
sharedscripts
missingok
notifempty
postrotate
/bin/kill -HUP `cat /run/clamav/clamd.pid 2>/dev/null` 2> /dev/null || true
/bin/kill -HUP `cat /run/clamav/freshclam.pid 2>/dev/null` 2> /dev/null || true
endscript
}

View file

@ -1 +0,0 @@
d /run/clamav 0755 clamav clamav