mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-02-16 23:57:11 +00:00
community/tachyon to 0.98.9-6
This commit is contained in:
parent
53f41504d2
commit
7d8699e0df
2 changed files with 32 additions and 15 deletions
|
@ -7,16 +7,18 @@
|
||||||
|
|
||||||
pkgname=tachyon
|
pkgname=tachyon
|
||||||
pkgver=0.98.9
|
pkgver=0.98.9
|
||||||
pkgrel=5
|
pkgrel=6
|
||||||
pkgdesc="Multithreaded ray tracing software"
|
pkgdesc="Multithreaded ray tracing software"
|
||||||
arch=(x86_64)
|
arch=(x86_64)
|
||||||
url="http://jedi.ks.uiuc.edu/~johns/raytracer/"
|
url="http://jedi.ks.uiuc.edu/~johns/raytracer/"
|
||||||
license=(BSD)
|
license=(BSD)
|
||||||
depends=(libjpeg-turbo libpng)
|
depends=(libjpeg-turbo libpng)
|
||||||
makedepends=()
|
makedepends=()
|
||||||
source=("http://jedi.ks.uiuc.edu/~johns/raytracer/files/$pkgver/$pkgname-$pkgver.tar.gz" 'enable-jpeg-png.patch')
|
#source=("http://jedi.ks.uiuc.edu/~johns/raytracer/files/$pkgver/$pkgname-$pkgver.tar.gz" 'enable-jpeg-png.patch')
|
||||||
sha256sums=('c6a3298ded4dc3e9390447819e1dac59b62c3d2d46d4154312ffe71549ee40d7'
|
source=("https://mirrors.mit.edu/sage/spkg/upstream/tachyon/tachyon-$pkgver.tar.bz2" enable-jpeg-png.patch tachyon-system-cflags.patch)
|
||||||
'ecd6ab6274879e0f971e2eba17871fffe2e24dcc9a332013a0b100ee4857cc2c')
|
sha256sums=('e8888a410610e2726dca32f40f31ff34a83cb474b41e5a1e0ac8bbb175e1a466'
|
||||||
|
'ecd6ab6274879e0f971e2eba17871fffe2e24dcc9a332013a0b100ee4857cc2c'
|
||||||
|
'34f703af96afe117c851a5825b7fd6b71211c09e4a8c3b836d012d250bb6918f')
|
||||||
|
|
||||||
case "$CARCH" in
|
case "$CARCH" in
|
||||||
arm*) _target=linux-thr ;;
|
arm*) _target=linux-thr ;;
|
||||||
|
@ -26,9 +28,12 @@ case "$CARCH" in
|
||||||
esac
|
esac
|
||||||
|
|
||||||
prepare(){
|
prepare(){
|
||||||
cd $pkgname
|
cd $pkgname-$pkgver
|
||||||
# enable JPEG and PNG support
|
# enable JPEG and PNG support
|
||||||
patch -p0 -i "$srcdir"/enable-jpeg-png.patch
|
patch -p0 -i ../enable-jpeg-png.patch
|
||||||
|
# use system build flags
|
||||||
|
patch -p1 -i ../tachyon-system-cflags.patch
|
||||||
|
sed -e 's|${CC} ${CFLAGS}|${CC} ${CFLAGS} ${LDFLAGS}|g' -i unix/Makefile
|
||||||
|
|
||||||
# remove -m32 and -m64 for ARM
|
# remove -m32 and -m64 for ARM
|
||||||
sed -i 's/-m32//g' unix/Make-arch
|
sed -i 's/-m32//g' unix/Make-arch
|
||||||
|
@ -36,20 +41,15 @@ prepare(){
|
||||||
}
|
}
|
||||||
|
|
||||||
build() {
|
build() {
|
||||||
cd $pkgname/unix
|
cd $pkgname-$pkgver/unix
|
||||||
make $_target
|
make $_target CC="gcc ${CFLAGS} ${LDFLAGS}"
|
||||||
}
|
}
|
||||||
|
|
||||||
package() {
|
package() {
|
||||||
cd $pkgname/compile/$_target
|
cd $pkgname-$pkgver/compile/$_target
|
||||||
install -D -m 755 tachyon $pkgdir/usr/bin/tachyon
|
install -D -m 755 tachyon $pkgdir/usr/bin/tachyon
|
||||||
install -D -m 644 libtachyon.a $pkgdir/usr/lib/libtachyon.a
|
install -D -m 644 libtachyon.a $pkgdir/usr/lib/libtachyon.a
|
||||||
|
|
||||||
cd $srcdir/$pkgname/scenes
|
|
||||||
install -d "$pkgdir"/usr/share/tachyon/scenes/imaps
|
|
||||||
install -m 644 README *.dat *.cam *.ac "$pkgdir"/usr/share/tachyon/scenes
|
|
||||||
install -m 644 imaps/* "$pkgdir"/usr/share/tachyon/scenes/imaps
|
|
||||||
|
|
||||||
install -d "$pkgdir"/usr/share/licenses/tachyon
|
install -d "$pkgdir"/usr/share/licenses/tachyon
|
||||||
install $srcdir/$pkgname/Copyright "$pkgdir"/usr/share/licenses/tachyon
|
install "$srcdir"/$pkgname-$pkgver/Copyright "$pkgdir"/usr/share/licenses/tachyon
|
||||||
}
|
}
|
||||||
|
|
17
community/tachyon/tachyon-system-cflags.patch
Normal file
17
community/tachyon/tachyon-system-cflags.patch
Normal file
|
@ -0,0 +1,17 @@
|
||||||
|
--- tachyon/unix/Make-arch.orig 2019-08-24 23:13:05.136655180 +0000
|
||||||
|
+++ tachyon/unix/Make-arch 2019-08-24 23:13:36.057062493 +0000
|
||||||
|
@@ -1217,12 +1217,12 @@
|
||||||
|
$(MAKE) all \
|
||||||
|
"ARCH = linux-64-thr" \
|
||||||
|
"CC = gcc" \
|
||||||
|
- "CFLAGS = -m64 -Wall -O3 -fomit-frame-pointer -ffast-math -DLinux -DLP64 -DTHR -D_REENTRANT $(MISCFLAGS)" \
|
||||||
|
+ "CFLAGS = $(CFLAGS) -DLinux -DLP64 -DTHR -D_REENTRANT $(MISCFLAGS)" \
|
||||||
|
"AR = ar" \
|
||||||
|
"ARFLAGS = r" \
|
||||||
|
"STRIP = strip" \
|
||||||
|
"RANLIB = ranlib" \
|
||||||
|
- "LIBS = -L. -ltachyon $(MISCLIB) -lm -lpthread"
|
||||||
|
+ "LIBS = -L. -ltachyon $(MISCLIB) -lm -lpthread" "LDFLAGS = $(LDFLAGS)"
|
||||||
|
|
||||||
|
# Linux x86, on AMD Athlon, using gcc
|
||||||
|
linux-p4:
|
Loading…
Reference in a new issue