added extra/rhythmbox

This commit is contained in:
Kevin Mihelich 2017-02-08 03:02:24 +00:00
parent 508b9f54ae
commit 7d90389bc5
2 changed files with 118 additions and 0 deletions

View file

@ -0,0 +1,39 @@
From 054925add713e715134f340dd7c873c928ad762f Mon Sep 17 00:00:00 2001
From: Jan de Groot <jgc@archlinux.org>
Date: Sun, 5 Feb 2017 13:10:30 +0000
Subject: [PATCH] Port to clutter-gst-3.0
---
configure.ac | 2 +-
plugins/visualizer/rb-visualizer-page.c | 2 +-
2 files changed, 2 insertions(+), 2 deletions(-)
diff --git a/configure.ac b/configure.ac
index 16afcfff6..effbd44d0 100644
--- a/configure.ac
+++ b/configure.ac
@@ -681,7 +681,7 @@ if test "x$enable_visualizer" != "xno"; then
PKG_CHECK_MODULES(CLUTTER,
clutter-1.0 >= 1.8 \
clutter-x11-1.0 >= 1.8 \
- clutter-gst-2.0 \
+ clutter-gst-3.0 \
clutter-gtk-1.0 >= 1.0 \
mx-1.0 >= 1.0.1,
have_clutter=yes,
diff --git a/plugins/visualizer/rb-visualizer-page.c b/plugins/visualizer/rb-visualizer-page.c
index 417984335..5b03e7748 100644
--- a/plugins/visualizer/rb-visualizer-page.c
+++ b/plugins/visualizer/rb-visualizer-page.c
@@ -352,7 +352,7 @@ impl_constructed (GObject *object)
g_object_ref (page->sink);
/* actual sink */
- realsink = gst_element_factory_make ("cluttersink", NULL);
+ realsink = GST_ELEMENT (clutter_gst_video_sink_new ());
g_object_set (realsink, "texture", page->texture, NULL);
videoconvert = gst_element_factory_make ("videoconvert", NULL);
--
2.11.1

79
extra/rhythmbox/PKGBUILD Normal file
View file

@ -0,0 +1,79 @@
# $Id$
# Maintainer: Jan de Groot <jgc@archlinux.org>
# Contributor: Giovanni Scafora <giovanni@archlinux.org>
# ALARM: Kevin Mihelich <kevin@archlinuxarm.org>
# - configure with --disable-more-warnings to silence -Wcast-align on 32bit
pkgname=rhythmbox
pkgver=3.4.1
pkgrel=2
pkgdesc="Music playback and management application"
arch=(i686 x86_64)
license=(GPL)
url="https://wiki.gnome.org/Apps/Rhythmbox"
depends=(dconf gst-plugins-base gst-plugins-good libsoup json-glib libnotify libpeas
media-player-info totem-plparser tdb python-gobject libgudev grilo)
makedepends=(itstool intltool brasero gobject-introspection vala grilo libdmapsharing lirc libgpod
libmtp gtk-doc clutter-gst clutter-gtk mx yelp-tools git)
checkdepends=(check xorg-server-xvfb)
optdepends=('gst-plugins-ugly: Extra media codecs'
'gst-plugins-bad: Extra media codecs'
'gst-libav: Extra media codecs'
'brasero: Audio CD Recorder plugin'
'libdmapsharing: DAAP Music Sharing plugin'
'grilo-plugins: Grilo media browser plugin'
'lirc: LIRC plugin'
'libgpod: Portable Players - iPod plugin'
'libmtp: Portable Players - MTP plugin'
'gvfs-mtp: Portable Players - Android plugin'
'mx: Visualiser plugin'
'clutter-gtk: Visualiser plugin'
'clutter-gst: Visualiser plugin')
options=('!emptydirs')
_commit=7f3624b6b4902932dc9df87ac55f5c71651260f7 # tags/v3.4.1^0
source=("git+https://git.gnome.org/browse/rhythmbox#commit=$_commit"
0001-Port-to-clutter-gst-3.0.patch)
sha256sums=('SKIP'
'996e654effda4f1d081377c837d600fdca6b97319e7f4f55f0307d046aab6a59')
pkgver() {
cd $pkgname
git describe --tags | sed 's/^v//;s/-/+/g'
}
prepare() {
cd $pkgname
patch -Np1 -i ../0001-Port-to-clutter-gst-3.0.patch
NOCONFIGURE=1 ./autogen.sh
}
build() {
cd $pkgname
./configure --prefix=/usr --sysconfdir=/etc \
--libexecdir=/usr/lib/rhythmbox \
--localstatedir=/var --disable-static \
--enable-daap --enable-python --enable-vala \
--enable-gtk-doc --disable-more-warnings
# https://bugzilla.gnome.org/show_bug.cgi?id=655517
sed -i -e 's/ -shared / -Wl,-O1,--as-needed\0/g' libtool
make
}
check() {
cd $pkgname
glib-compile-schemas --targetdir=tests --schema-file=data/org.gnome.rhythmbox.gschema.xml
GSETTINGS_BACKEND=memory \
GSETTINGS_SCHEMA_DIR="$PWD/tests" \
CK_TIMEOUT_MULTIPLIER=3 \
xvfb-run -a -n 63 -s '-extension GLX' make check
}
package() {
cd $pkgname
make DESTDIR="$pkgdir" install
rm -r "$pkgdir/usr/lib/rhythmbox/sample-plugins"
rm -r "$pkgdir/usr/lib/rhythmbox/plugins/rbzeitgeist"
}