community/nspluginwrapper to 1.4.4-3

This commit is contained in:
Kevin Mihelich 2014-07-12 19:45:18 +00:00
parent ca2c541e5e
commit 7da60ba606
2 changed files with 28 additions and 4 deletions

View file

@ -1,4 +1,4 @@
# $Id: PKGBUILD 60062 2011-12-04 15:25:13Z bluewind $
# $Id$
# Maintainer: Thomas Bächler <thomas@archlinux.org>
# ALARM: Kevin Mihelich <kevin@archlinuxarm.org>
@ -6,7 +6,7 @@
pkgname=nspluginwrapper
pkgver=1.4.4
pkgrel=2
pkgrel=3
pkgdesc="Cross-platform NPAPI compatible plugin viewer"
arch=('i686' 'x86_64')
url="http://nspluginwrapper.davidben.net/"
@ -19,12 +19,16 @@ depends=(
)
makedepends=('gcc-multilib')
install="install"
source=(http://nspluginwrapper.davidben.net/download/$pkgname-$pkgver.tar.gz)
md5sums=('36f3e290fc4ce56f65ee695078961188')
source=(http://nspluginwrapper.davidben.net/download/$pkgname-$pkgver.tar.gz
'fix_missing_lib.patch')
md5sums=('36f3e290fc4ce56f65ee695078961188'
'00ca2d1ab0d7348e3157cb7b72f30e1a')
build() {
cd "$srcdir/$pkgname-$pkgver"
patch -p1 -i "$srcdir/fix_missing_lib.patch"
configure_args=""
if [[ $CARCH == x86_64 ]]; then
configure_args="$configure_args --with-lib32=lib32 --with-lib64=lib"

View file

@ -0,0 +1,20 @@
--- a/Makefile 2011-07-01 11:18:57.000000000 +0800
+++ b/Makefile 2014-07-13 01:21:41.887559397 +0800
@@ -128,7 +128,7 @@
ifeq ($(TARGET_OS):$(TARGET_ARCH),linux:i386)
npviewer_SOURCES += $(SRC_PATH)/src/cxxabi-compat.cpp
npviewer_OBJECTS += npviewer-cxxabi-compat.o
-npviewer_LIBS += -lsupc++
+npviewer_LIBS += -lsupc++ -lgthread-2.0
endif
ifeq ($(TARGET_OS):$(TARGET_ARCH),solaris:i386)
npviewer_LIBS += $(libsocket_LIBS)
@@ -142,7 +142,7 @@
npplayer_LDFLAGS = $(LDFLAGS)
npplayer_LDFLAGS += $(libpthread_LDFLAGS)
npplayer_LIBS = $(GTK_LIBS) $(GLIB_LIBS) $(CURL_LIBS) $(X_LIBS)
-npplayer_LIBS += $(libpthread_LIBS) $(libsocket_LIBS)
+npplayer_LIBS += $(libpthread_LIBS) $(libsocket_LIBS) -ldl -lgthread-2.0
libnoxshm_LIBRARY = libnoxshm.so
libnoxshm_RAWSRCS = libnoxshm.c