alarm/uboot-raspberrypi to 2020.07-2

This commit is contained in:
Kevin Mihelich 2020-08-09 00:55:01 +00:00
parent 5ad3dcbe97
commit 7de2430c01
3 changed files with 37 additions and 9 deletions

View file

@ -0,0 +1,32 @@
From a8956f99a655204a633440f9cac8558bae00df49 Mon Sep 17 00:00:00 2001
From: Kevin Mihelich <kevin@archlinuxarm.org>
Date: Sat, 8 Aug 2020 18:51:00 -0600
Subject: [PATCH] rpi: increase space for kernel
Signed-off-by: Kevin Mihelich <kevin@archlinuxarm.org>
---
include/configs/rpi.h | 8 ++++----
1 file changed, 4 insertions(+), 4 deletions(-)
diff --git a/include/configs/rpi.h b/include/configs/rpi.h
index 834f1cd236..7a34049a10 100644
--- a/include/configs/rpi.h
+++ b/include/configs/rpi.h
@@ -163,10 +163,10 @@
"fdt_high=" FDT_HIGH "\0" \
"initrd_high=" INITRD_HIGH "\0" \
"kernel_addr_r=0x00080000\0" \
- "scriptaddr=0x02400000\0" \
- "pxefile_addr_r=0x02500000\0" \
- "fdt_addr_r=0x02600000\0" \
- "ramdisk_addr_r=0x02700000\0"
+ "scriptaddr=0x02C00000\0" \
+ "pxefile_addr_r=0x02D00000\0" \
+ "fdt_addr_r=0x02E00000\0" \
+ "ramdisk_addr_r=0x02F00000\0"
#if CONFIG_IS_ENABLED(CMD_MMC)
#define BOOT_TARGET_MMC(func) \
--
2.24.1

View file

@ -5,7 +5,7 @@ buildarch=12
pkgname=uboot-raspberrypi
pkgver=2020.07
pkgrel=1
pkgrel=2
pkgdesc="U-Boot for Raspberry Pi"
arch=('armv7h' 'aarch64')
url='http://www.denx.de/wiki/U-Boot/WebHome'
@ -19,6 +19,7 @@ source=("ftp://ftp.denx.de/pub/u-boot/u-boot-${pkgver/rc/-rc}.tar.bz2"
"https://github.com/raspberrypi/firmware/raw/${_commit}/boot/bcm2710-rpi-3-b-plus.dtb"
"https://github.com/raspberrypi/firmware/raw/${_commit}/boot/bcm2710-rpi-cm3.dtb"
"https://github.com/raspberrypi/firmware/raw/${_commit}/boot/bcm2711-rpi-4-b.dtb"
'0001-rpi-increase-space-for-kernel.patch'
'boot.txt.v2'
'boot.txt.v3'
'mkscr')
@ -27,13 +28,15 @@ md5sums=('86e51eeccd15e658ad1df943a0edf622'
'e4b819439961514c7441473d4733a1b4'
'38cab92f98944f0492c5320cf8b36870'
'04f2dd06c65cd7ad2932041cbe220a13'
'728c4a0a542db702b8d88ffe1994660c'
'69e883f0b8d1686b32bdf79684623f06'
'a71954312f2453af55c98ea302ce9a2f'
'be8abe44b86d63428d7ac3acc64ee3bf'
'021623a04afd29ac3f368977140cfbfd')
prepare() {
cd u-boot-${pkgver/rc/-rc}
patch -p1 -i ../0001-rpi-increase-space-for-kernel.patch
}
build() {

View file

@ -1,12 +1,5 @@
# After modifying, run ./mkscr
# Set load addresses
setenv kernel_addr_r 0x00080000
setenv scriptaddr 0x02C00000
setenv pxefile_addr_r 0x02D00000
setenv fdt_addr_r 0x02E00000
setenv ramdisk_addr_r 0x02F00000
# Set root partition to the second partition of boot device
part uuid ${devtype} ${devnum}:2 uuid