mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-18 22:54:00 +00:00
aur/mediatomb to 0.12.1-9
This commit is contained in:
parent
0c4cd8ded6
commit
7e20da5c25
2 changed files with 65 additions and 10 deletions
|
@ -6,7 +6,7 @@
|
|||
|
||||
pkgname=mediatomb
|
||||
pkgver=0.12.1
|
||||
pkgrel=8.1
|
||||
pkgrel=9
|
||||
pkgdesc="Free UPnP/DLNA media server"
|
||||
arch=('i686' 'x86_64')
|
||||
url="http://mediatomb.cc/"
|
||||
|
@ -21,15 +21,8 @@ source=("http://downloads.sourceforge.net/$pkgname/$pkgname-$pkgver.tar.gz"
|
|||
'tonewjs.patch'
|
||||
'jsparse.patch'
|
||||
'libav_0.7_support.patch'
|
||||
'libmp4v2_191_p497.patch')
|
||||
sha256sums=('31163c34a7b9d1c9735181737cb31306f29f1f2a0335fb4f53ecccf8f62f11cd'
|
||||
'1a67a1deb8a41467fe9bbf66358a255f0df97b0170a5fc3d48c1f768c8d328b9'
|
||||
'ba9753a4a380d4c717c987efec03a3c6d401d3ff93a6fced28098adbd3a44cc9'
|
||||
'0c02a20032f0c296800b1bb9644638970c2dedbc5ab7141d66a637235e9da6ce'
|
||||
'2cd8f5628c3a38b290526f008bae351b90211825f86e5959bf95f140748de574'
|
||||
'd9a3062858900d32b977f0d50d168fd7d36785b6ecc038c019e661e27f7b1c17'
|
||||
'c6523e8bf5e2da89b7475d6777ef9bffe7d089752ef2f7b27b5e39a4130fb0ff'
|
||||
'd39c2f9aab051c5447461718fd0ec72cf5982f6c920a4a985a50831f34babe84')
|
||||
'libmp4v2_191_p497.patch'
|
||||
'libavformat.patch')
|
||||
|
||||
build() {
|
||||
cd "$srcdir/$pkgname-$pkgver"
|
||||
|
@ -38,6 +31,7 @@ build() {
|
|||
patch -Np1 -i "$srcdir/jsparse.patch"
|
||||
patch -Np1 -i "$srcdir/libav_0.7_support.patch"
|
||||
patch -Np1 -i "$srcdir/libmp4v2_191_p497.patch"
|
||||
patch -Np1 -i "$srcdir/libavformat.patch"
|
||||
|
||||
./configure --prefix=/usr \
|
||||
--disable-mysql \
|
||||
|
@ -56,3 +50,12 @@ package() {
|
|||
install -D -m0755 "$srcdir/mediatomb.conf" "$pkgdir/etc/conf.d/mediatomb"
|
||||
install -d "$pkgdir/var/lib/mediatomb"
|
||||
}
|
||||
sha256sums=('31163c34a7b9d1c9735181737cb31306f29f1f2a0335fb4f53ecccf8f62f11cd'
|
||||
'1a67a1deb8a41467fe9bbf66358a255f0df97b0170a5fc3d48c1f768c8d328b9'
|
||||
'ba9753a4a380d4c717c987efec03a3c6d401d3ff93a6fced28098adbd3a44cc9'
|
||||
'0c02a20032f0c296800b1bb9644638970c2dedbc5ab7141d66a637235e9da6ce'
|
||||
'2cd8f5628c3a38b290526f008bae351b90211825f86e5959bf95f140748de574'
|
||||
'd9a3062858900d32b977f0d50d168fd7d36785b6ecc038c019e661e27f7b1c17'
|
||||
'c6523e8bf5e2da89b7475d6777ef9bffe7d089752ef2f7b27b5e39a4130fb0ff'
|
||||
'd39c2f9aab051c5447461718fd0ec72cf5982f6c920a4a985a50831f34babe84'
|
||||
'76b11706d70ed8f5e157d96ca441c90c46c42176102fcb651b4ab1102b61bfee')
|
||||
|
|
52
aur/mediatomb/libavformat.patch
Normal file
52
aur/mediatomb/libavformat.patch
Normal file
|
@ -0,0 +1,52 @@
|
|||
--- mediatomb-0.12.1.orig/src/metadata/ffmpeg_handler.cc 2012-06-18 02:50:35.000000000 -0400
|
||||
+++ mediatomb-0.12.1/src/metadata/ffmpeg_handler.cc 2012-06-18 02:59:02.000000000 -0400
|
||||
@@ -107,8 +107,8 @@
|
||||
return;
|
||||
for (const mapping_t *m = mapping; m->avname != NULL; m++)
|
||||
{
|
||||
- AVMetadataTag *tag = NULL;
|
||||
- tag = av_metadata_get(pFormatCtx->metadata, m->avname, NULL, 0);
|
||||
+ AVDictionaryEntry *tag = NULL;
|
||||
+ tag = av_dict_get(pFormatCtx->metadata, m->avname, NULL, 0);
|
||||
if (tag && tag->value && tag->value[0])
|
||||
{
|
||||
log_debug("Added metadata %s: %s\n", m->avname, tag->value);
|
||||
@@ -278,7 +278,7 @@
|
||||
int x = 0;
|
||||
int y = 0;
|
||||
|
||||
- AVFormatContext *pFormatCtx;
|
||||
+ AVFormatContext *pFormatCtx = avformat_alloc_context();
|
||||
|
||||
// Suppress all log messages
|
||||
av_log_set_callback(FfmpegNoOutputStub);
|
||||
@@ -286,15 +286,15 @@
|
||||
// Register all formats and codecs
|
||||
av_register_all();
|
||||
|
||||
- // Open video file
|
||||
- if (av_open_input_file(&pFormatCtx,
|
||||
- item->getLocation().c_str(), NULL, 0, NULL) != 0)
|
||||
+ // Open video file
|
||||
+ if (avformat_open_input(&pFormatCtx,
|
||||
+ item->getLocation().c_str(), NULL, NULL) != 0)
|
||||
return; // Couldn't open file
|
||||
|
||||
// Retrieve stream information
|
||||
- if (av_find_stream_info(pFormatCtx) < 0)
|
||||
+ if (avformat_find_stream_info(pFormatCtx,NULL) < 0)
|
||||
{
|
||||
- av_close_input_file(pFormatCtx);
|
||||
+ avformat_close_input(&pFormatCtx);
|
||||
return; // Couldn't find stream information
|
||||
}
|
||||
// Add metadata using ffmpeg library calls
|
||||
@@ -303,7 +303,7 @@
|
||||
addFfmpegResourceFields(item, pFormatCtx, &x, &y);
|
||||
|
||||
// Close the video file
|
||||
- av_close_input_file(pFormatCtx);
|
||||
+ avformat_close_input(&pFormatCtx);
|
||||
}
|
||||
|
||||
Ref<IOHandler> FfmpegHandler::serveContent(Ref<CdsItem> item, int resNum, off_t *data_size)
|
Loading…
Reference in a new issue